summaryrefslogtreecommitdiff
path: root/app-misc/gentoo/gentoo-0.20.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/gentoo/gentoo-0.20.7.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/gentoo/gentoo-0.20.7.ebuild')
-rw-r--r--app-misc/gentoo/gentoo-0.20.7.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/app-misc/gentoo/gentoo-0.20.7.ebuild b/app-misc/gentoo/gentoo-0.20.7.ebuild
new file mode 100644
index 000000000000..f84fcd4a62e7
--- /dev/null
+++ b/app-misc/gentoo/gentoo-0.20.7.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="Graphical file manager for Unix-like systems, using GTK+"
+HOMEPAGE="http://gentoo.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE="nls"
+
+RDEPEND="
+ >x11-libs/gtk+-3.12:3
+ dev-libs/glib:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/pango
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+DOCS=(
+ AUTHORS BUGS CONFIG-CHANGES CREDITS NEWS README TODO docs/{FAQ,menus.txt}
+)
+
+src_prepare() {
+ sed -i \
+ -e 's^icons/gnome/16x16/mimetypes^gentoo/icons^' \
+ gentoorc.in || die
+ sed -i \
+ -e '/GTK_DISABLE_DEPRECATED/d' \
+ -e '/^GENTOO_CFLAGS=/s|".*"|"${CFLAGS}"|g' \
+ -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' \
+ configure.ac || die #357343
+
+ eapply_user
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/gentoo \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ docinto html
+ dodoc -r docs/{images,config,*.{html,css}}
+
+ newman docs/gentoo.1x gentoo.1
+
+ docinto scratch
+ dodoc docs/scratch/*
+
+ make_desktop_entry ${PN} Gentoo \
+ /usr/share/${PN}/icons/${PN}.png \
+ "System;FileTools;FileManager"
+}