summaryrefslogtreecommitdiff
path: root/app-misc/gcal/gcal-4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-27 18:07:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-27 18:07:28 +0000
commit67f76a858f1ac826bd8a550d756d9ec6e340ed4f (patch)
tree45f4ada6be05bc180a14e017c9d5c6b58a0eec6e /app-misc/gcal/gcal-4.1.ebuild
parent38b7258d086dd5e263c3bbe3880c8c956676bc71 (diff)
gentoo resync : 27.01.2018
Diffstat (limited to 'app-misc/gcal/gcal-4.1.ebuild')
-rw-r--r--app-misc/gcal/gcal-4.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/gcal/gcal-4.1.ebuild b/app-misc/gcal/gcal-4.1.ebuild
new file mode 100644
index 000000000000..da50405b5703
--- /dev/null
+++ b/app-misc/gcal/gcal-4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="The GNU Calendar - a replacement for cal"
+HOMEPAGE="https://www.gnu.org/software/gcal/"
+SRC_URI="mirror://gnu/gcal/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="ncurses nls unicode"
+
+DEPEND="
+ app-arch/xz-utils
+ nls? ( >=sys-devel/gettext-0.17 )"
+
+RDEPEND="nls? ( virtual/libintl )"
+
+DOCS=( BUGS LIMITATIONS NEWS README THANKS TODO )
+
+src_configure() {
+ tc-export CC
+ append-cppflags -D_GNU_SOURCE
+ econf \
+ --disable-rpath \
+ $(use_enable nls) \
+ $(use_enable ncurses term) \
+ $(use_enable unicode)
+}