summaryrefslogtreecommitdiff
path: root/app-misc/g15daemon/g15daemon-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /app-misc/g15daemon/g15daemon-9999.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'app-misc/g15daemon/g15daemon-9999.ebuild')
-rw-r--r--app-misc/g15daemon/g15daemon-9999.ebuild77
1 files changed, 32 insertions, 45 deletions
diff --git a/app-misc/g15daemon/g15daemon-9999.ebuild b/app-misc/g15daemon/g15daemon-9999.ebuild
index 5e6baded32a9..71c34ecf83b2 100644
--- a/app-misc/g15daemon/g15daemon-9999.ebuild
+++ b/app-misc/g15daemon/g15daemon-9999.ebuild
@@ -1,14 +1,13 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-PYTHON_COMPAT=( python2_7 )
GENTOO_DEPEND_ON_PERL="no"
ESVN_PROJECT=${PN}/trunk
ESVN_REPO_URI="https://svn.code.sf.net/p/${PN}/code/trunk/${PN}-wip"
-inherit eutils linux-info perl-module python-r1 base subversion autotools
+inherit autotools flag-o-matic linux-info perl-module subversion systemd toolchain-funcs udev
DESCRIPTION="Takes control of the G15 keyboard, through the linux kernel uinput device driver"
HOMEPAGE="https://sourceforge.net/projects/g15daemon/"
@@ -17,7 +16,7 @@ HOMEPAGE="https://sourceforge.net/projects/g15daemon/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="perl python static-libs"
+IUSE="perl static-libs"
DEPEND="virtual/libusb:0
>=dev-libs/libg15-9999
@@ -26,16 +25,14 @@ DEPEND="virtual/libusb:0
dev-lang/perl
dev-perl/GDGraph
>=dev-perl/Inline-0.4
- )
- python? ( ${PYTHON_DEPS} )"
+ )"
RDEPEND="${DEPEND}"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
PATCHES=(
"${FILESDIR}/${PN}-1.9.5.3-g510-keys.patch"
+ "${FILESDIR}/${PN}-1.9.5.3-docdir.patch"
+ "${FILESDIR}/${PN}-1.9.5.3-avoid_bashisms.patch"
)
-# "${FILESDIR}/${PN}-1.9.5.3-forgotten-open-mode.patch"
-# "${FILESDIR}/${PN}-1.9.5.3-overflow-fix.patch"
uinput_check() {
ebegin "Checking for uinput support"
@@ -43,7 +40,7 @@ uinput_check() {
linux_config_exists && linux_chkconfig_present INPUT_UINPUT
rc=$?
- if [[ $rc -ne 0 ]] ; then
+ if [[ ${rc} -ne 0 ]] ; then
eerror "To use g15daemon, you need to compile your kernel with uinput support."
eerror "Please enable uinput support in your kernel config, found at:"
eerror
@@ -55,49 +52,49 @@ uinput_check() {
}
pkg_setup() {
+ export CC="$(tc-getCC)" #729294
+
linux-info_pkg_setup
uinput_check
}
src_unpack() {
- if [[ ${PV} = *9999* ]]; then
+ if [[ ${PV} = *9999* ]] ; then
subversion_src_unpack
else
unpack ${A}
fi
- if use perl; then
+ if use perl ; then
unpack "./${P}/lang-bindings/perl-G15Daemon-0.2.tar.gz"
fi
- if use python; then
- unpack "./${P}/lang-bindings/pyg15daemon-0.0.tar.bz2"
- fi
}
src_prepare() {
- if [[ ${PV} = *9999* ]]; then
+ if [[ ${PV} = *9999* ]] ; then
subversion_wc_info
fi
- if use perl; then
+ if use perl ; then
perl-module_src_prepare
sed -i \
-e '1i#!/usr/bin/perl' \
- "${S}"/contrib/testbindings.pl
+ "${S}"/contrib/testbindings.pl || die
else
# perl-module_src_prepare always calls base_src_prepare
- base_src_prepare
+ default
fi
- if [[ ${PV} = *9999* ]]; then
+ if [[ ${PV} = *9999* ]] ; then
+ mv configure.{in,ac} || die
eautoreconf
fi
}
src_configure() {
- econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- $(use_enable static-libs static)
+ append-cflags -fcommon #706712
- if use perl; then
- cd "${WORKDIR}/G15Daemon-0.2"
+ econf $(use_enable static-libs static)
+
+ if use perl ; then
+ cd "${WORKDIR}/G15Daemon-0.2" || die
perl-module_src_configure
fi
}
@@ -105,8 +102,8 @@ src_configure() {
src_compile() {
default
- if use perl; then
- cd "${WORKDIR}/G15Daemon-0.2"
+ if use perl ; then
+ cd "${WORKDIR}/G15Daemon-0.2" || die
perl-module_src_compile
fi
}
@@ -114,23 +111,23 @@ src_compile() {
src_install() {
default
- find "${ED}" -name '*.la' -exec rm -f {} +
+ find "${ED}" -type f -name '*.la' -delete || die
# remove odd docs installed my make
- rm "${ED}/usr/share/doc/${PF}/"{LICENSE,README.usage}
+ rm "${ED}"/usr/share/doc/${PF}/README.usage || die
insinto /usr/share/${PN}/contrib
doins contrib/xmodmaprc
doins contrib/xmodmap.sh
- if use perl; then
+ if use perl ; then
doins contrib/testbindings.pl
fi
newconfd "${FILESDIR}/${PN}-1.2.7.confd" ${PN}
newinitd "${FILESDIR}/${PN}-1.9.5.3.initd" ${PN}
+ systemd_dounit "${FILESDIR}/${PN}.service"
dobin "${FILESDIR}/g15daemon-hotplug"
- insinto /lib/udev/rules.d
- doins "${FILESDIR}/99-g15daemon.rules"
+ udev_dorules "${FILESDIR}/99-g15daemon.rules"
insinto /etc
doins "${FILESDIR}"/g15daemon.conf
@@ -139,22 +136,12 @@ src_install() {
exeinto /usr/lib/pm-utils/sleep.d
doexe "${FILESDIR}"/20g15daemon
- if use perl; then
+ if use perl ; then
ebegin "Installing Perl Bindings (G15Daemon.pm)"
- cd "${WORKDIR}/G15Daemon-0.2"
+ cd "${WORKDIR}/G15Daemon-0.2" || die
docinto perl
perl-module_src_install
fi
-
- if use python; then
- ebegin "Installing Python Bindings (g15daemon.py)"
- cd "${WORKDIR}/pyg15daemon"
-
- python_foreach_impl python_domodule g15daemon.py
-
- docinto python
- dodoc AUTHORS
- fi
}
pkg_postinst() {