summaryrefslogtreecommitdiff
path: root/app-misc/fx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-22 06:42:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-22 06:42:31 +0000
commit564687d289b862b8b079569a45a2d39d7b8c3585 (patch)
tree9ec555a8f8005c24f9d8198ba4941cc6f002a413 /app-misc/fx
parent30c47f3c341cb37e4808aaa3842b679d0ca420e8 (diff)
gentoo auto-resync : 22:01:2025 - 06:42:31
Diffstat (limited to 'app-misc/fx')
-rw-r--r--app-misc/fx/Manifest4
-rw-r--r--app-misc/fx/fx-35.0.0.ebuild37
-rw-r--r--app-misc/fx/metadata.xml11
3 files changed, 52 insertions, 0 deletions
diff --git a/app-misc/fx/Manifest b/app-misc/fx/Manifest
new file mode 100644
index 000000000000..c3b6e86b5773
--- /dev/null
+++ b/app-misc/fx/Manifest
@@ -0,0 +1,4 @@
+DIST fx-35.0.0-deps.tar.xz 14566724 BLAKE2B e1104d78516adcb9346a9a5e12ae6f0289ed08a0476b4a605254301b6a4d47d7b46915fd65dc54f538a388c5c2694027b09af90e0f465f6a5ff84e23a36e7ed7 SHA512 0474627801dbe5de029addc3562827fdc45434dedc8ca33555dfebac9465c315fc3626d600da04362f0fa900132dbb107404b72cdcf4840273a52231f94de4c5
+DIST fx-35.0.0.tar.gz 2666576 BLAKE2B ac2c6b928b04cef596837acbc76df5a835c004b8e726b8f3b9e78e8e4f5e2528f7091a517731d87c51323c67db55f25b118f2870ed57496ed31daf02c066eccf SHA512 3870b52a9b74494369c837041ce3f5dbe668159d5a823fcc4977a3bd348ca54510d346a2c3f78a47fbd6b7999820d819e47e55848da83482bb8f32c8a3ebaf81
+EBUILD fx-35.0.0.ebuild 813 BLAKE2B c7dd749bf7c197a3d679846e2feafc2779e4f6306e997e1a529ad65dd13f9ad81a55142f326a46fd4d108b96b79816e0d7d60a71cc98d70f007ca4feb1984426 SHA512 02b72c86d5ed36531b1d0c5910c043f070d5a4226199e19a00619f8a984ed7013814ce67e1aeedd29b14b5f4f02bcd17ce7ec83570693472e26a2174074e7f5a
+MISC metadata.xml 328 BLAKE2B 8ad2256481a1462af592fda768b219899bcdc33c98028510dc22a241f6078a7dc4b69a07e48e959f4086fb5c741466902bcaaadf35da5341d35e0e74f5344487 SHA512 3fae7e195ba759be6b0a418071e208f786632f79bbd046d7279eb548fc07c9e8c337272f711192d592a595f3ec05bce243acdeb63ff35d4e6583440124b4e777
diff --git a/app-misc/fx/fx-35.0.0.ebuild b/app-misc/fx/fx-35.0.0.ebuild
new file mode 100644
index 000000000000..7c36260ceb59
--- /dev/null
+++ b/app-misc/fx/fx-35.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module shell-completion
+
+DESCRIPTION=" Terminal JSON viewer & processor"
+HOMEPAGE="https://fx.wtf/ https://github.com/antonmedv/fx"
+SRC_URI="https://github.com/antonmedv/fx/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~arthurzam/distfiles/app-misc/${PN}/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ ego build -o fx .
+
+ mkdir "${T}/comp"
+ ./fx --comp bash > "${T}/comp/fx" || die
+ ./fx --comp zsh > "${T}/comp/_fx" || die
+ ./fx --comp fish > "${T}/comp/fx.fish" || die
+}
+
+src_test() {
+ ego test ./...
+}
+
+src_install() {
+ dobin fx
+ dodoc README.md
+
+ dobashcomp "${T}/comp/fx"
+ dozshcomp "${T}/comp/_fx"
+ dofishcomp "${T}/comp/fx.fish"
+}
diff --git a/app-misc/fx/metadata.xml b/app-misc/fx/metadata.xml
new file mode 100644
index 000000000000..29afbd37a5af
--- /dev/null
+++ b/app-misc/fx/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arthurzam@gentoo.org</email>
+ <name>Arthur Zamarin</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">antonmedv/fx</remote-id>
+ </upstream>
+</pkgmetadata>