summaryrefslogtreecommitdiff
path: root/app-misc/fsniper/fsniper-1.3.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/fsniper/fsniper-1.3.1-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/fsniper/fsniper-1.3.1-r2.ebuild')
-rw-r--r--app-misc/fsniper/fsniper-1.3.1-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-misc/fsniper/fsniper-1.3.1-r2.ebuild b/app-misc/fsniper/fsniper-1.3.1-r2.ebuild
new file mode 100644
index 000000000000..7b845d7f9bf8
--- /dev/null
+++ b/app-misc/fsniper/fsniper-1.3.1-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Monitors a given set of directories for new files"
+HOMEPAGE="https://github.com/l3ib/fsniper"
+SRC_URI="http://projects.l3ib.org/${PN}/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="
+ dev-libs/libpcre
+ sys-apps/file"
+
+RDEPEND="
+ ${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-format-security.patch
+ "${FILESDIR}"/${P}-umask.patch
+ "${FILESDIR}"/${P}-waitpid.patch
+)
+
+DOCS=( AUTHORS COPYING NEWS README example.conf )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+}