summaryrefslogtreecommitdiff
path: root/app-misc/fslurp/fslurp-2.1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/fslurp/fslurp-2.1.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/fslurp/fslurp-2.1.4.ebuild')
-rw-r--r--app-misc/fslurp/fslurp-2.1.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-misc/fslurp/fslurp-2.1.4.ebuild b/app-misc/fslurp/fslurp-2.1.4.ebuild
new file mode 100644
index 000000000000..b1e3a45e6a79
--- /dev/null
+++ b/app-misc/fslurp/fslurp-2.1.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Read and display data from Fronius IG and IG Plus inverters"
+HOMEPAGE="http://fslurp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCXX)"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc History README TODO
+}