summaryrefslogtreecommitdiff
path: root/app-misc/freewvs/freewvs-0.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-18 14:34:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-18 14:34:47 +0100
commit3a1b8b124a5b405562b6e0ccf04e7bd2ddc131a4 (patch)
tree586b06fa140c17c92f004998807e894c1874db27 /app-misc/freewvs/freewvs-0.1.3.ebuild
parente0d23d9d2468ec36070ef9fa63bd814db6a653da (diff)
gentoo auto-resync : 18:07:2022 - 14:34:47
Diffstat (limited to 'app-misc/freewvs/freewvs-0.1.3.ebuild')
-rw-r--r--app-misc/freewvs/freewvs-0.1.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/freewvs/freewvs-0.1.3.ebuild b/app-misc/freewvs/freewvs-0.1.3.ebuild
new file mode 100644
index 000000000000..3deae1e3a7b6
--- /dev/null
+++ b/app-misc/freewvs/freewvs-0.1.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1
+
+DESCRIPTION="Scans filesystem for known vulnerable web applications"
+HOMEPAGE="https://freewvs.schokokeks.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( README.md )
+
+pkg_postinst() {
+ einfo To use freewvs you need to run
+ einfo update-freewvsdb
+ einfo first. You should run this on a regular basis to update
+ einfo the web application data, e.g. via a cronjob.
+}
+
+# Only codingstyle and similar tests, require dependencies
+# not packaged in Gentoo
+RESTRICT="test"