summaryrefslogtreecommitdiff
path: root/app-misc/filebus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /app-misc/filebus
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'app-misc/filebus')
-rw-r--r--app-misc/filebus/Manifest3
-rw-r--r--app-misc/filebus/filebus-0.3.2.ebuild68
-rw-r--r--app-misc/filebus/metadata.xml11
3 files changed, 82 insertions, 0 deletions
diff --git a/app-misc/filebus/Manifest b/app-misc/filebus/Manifest
new file mode 100644
index 000000000000..d77d87c2f3e3
--- /dev/null
+++ b/app-misc/filebus/Manifest
@@ -0,0 +1,3 @@
+DIST filebus-0.3.2.tar.gz 17310 BLAKE2B 0f30aabcd316f52ea12d12b136befe643085dff5e283f65edf2a459b127cd3e2d48c472ae0dd8f302bb7211e4da5541a6fc7ac274573631ab03fc246bc8b566f SHA512 88ce3cd2d8aec7afd30d16315a6a8a37dee1b21d882571ef87c7dca56251e737d6500a5fad0124c62aea6383aae5ec30abd8abf86c2fac5d582f8fe96049eaa6
+EBUILD filebus-0.3.2.ebuild 1409 BLAKE2B 27687f694af313868388843ae88037ea08b6192adcbb4c64ed79bab64d77c62f6208e356da0f4912f1c23f24640da20a6ac27eb53a6e6125c7c68a8e40412187 SHA512 90475ee64cbe90e844597461ea3e884c95ae12598e2acfeb78491a6accb7fe25be1b18f8cbbe97af174d8e95798f3635466cc6dee3b0290b1f269df98a603553
+MISC metadata.xml 343 BLAKE2B 5c4fb3bd0f135a7698c7733f214e02890e8775b2ea837ebbe8e525e03bb25a8e660a00a9b1957a322cbb210cd5a3b36e2979cf1829ecbceeedd5d76b0a8735d5 SHA512 de474003476fe109709f9c0de51cbb1277c49c4002c1eaa11840800633f61f912a18cafb8f1a4516750ec05148920479c1c4076e1a11e30b9852c05f198e0b79
diff --git a/app-misc/filebus/filebus-0.3.2.ebuild b/app-misc/filebus/filebus-0.3.2.ebuild
new file mode 100644
index 000000000000..cfa1df91be48
--- /dev/null
+++ b/app-misc/filebus/filebus-0.3.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DISTUTILS_OPTIONAL=1
+DISTUTILS_USE_SETUPTOOLS=manual
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A user space multicast named pipe implementation backed by a regular file"
+HOMEPAGE="https://github.com/pipebus/filebus"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="+inotify python test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RDEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/filelock[${PYTHON_USEDEP}]
+ inotify? ( dev-python/watchdog[${PYTHON_USEDEP}] )
+ )"
+BDEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ if use python; then
+ distutils-r1_src_prepare
+ fi
+}
+
+src_compile() {
+ if use python; then
+ distutils-r1_src_compile
+ fi
+}
+
+src_test() {
+ "${BASH}" ./lib/bash/filebus-test.bash test || die
+
+ if use python; then
+ distutils-r1_src_test
+ fi
+}
+
+python_test() {
+ python test/test_filebus.py || die "tests failed for ${EPYTHON}"
+}
+
+src_install() {
+ if use python; then
+ distutils-r1_src_install
+ else
+ insinto /usr/libexec/filebus
+ doins lib/bash/*.bash
+ cat <<-EOF > "${T}/filebus"
+ #!/bin/sh
+ exec bash "${EPREFIX}/usr/libexec/filebus/filebus.bash" "\$@"
+ EOF
+ dobin "${T}/filebus"
+ dosym filebus /usr/bin/pipebus
+ fi
+}
diff --git a/app-misc/filebus/metadata.xml b/app-misc/filebus/metadata.xml
new file mode 100644
index 000000000000..063cf040c7b7
--- /dev/null
+++ b/app-misc/filebus/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">pipebus/filebus</remote-id>
+ <remote-id type="pypi">filebus</remote-id>
+ </upstream>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>