summaryrefslogtreecommitdiff
path: root/app-misc/filebus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /app-misc/filebus
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'app-misc/filebus')
-rw-r--r--app-misc/filebus/Manifest4
-rw-r--r--app-misc/filebus/filebus-0.3.4.ebuild68
-rw-r--r--app-misc/filebus/filebus-0.3.5.ebuild68
3 files changed, 140 insertions, 0 deletions
diff --git a/app-misc/filebus/Manifest b/app-misc/filebus/Manifest
index 09c165846fe5..3237aa51ef29 100644
--- a/app-misc/filebus/Manifest
+++ b/app-misc/filebus/Manifest
@@ -1,3 +1,7 @@
DIST filebus-0.3.2.tar.gz 17310 BLAKE2B 0f30aabcd316f52ea12d12b136befe643085dff5e283f65edf2a459b127cd3e2d48c472ae0dd8f302bb7211e4da5541a6fc7ac274573631ab03fc246bc8b566f SHA512 88ce3cd2d8aec7afd30d16315a6a8a37dee1b21d882571ef87c7dca56251e737d6500a5fad0124c62aea6383aae5ec30abd8abf86c2fac5d582f8fe96049eaa6
+DIST filebus-0.3.4.tar.gz 17404 BLAKE2B cf6a3fef2e7f3d69fb73df3f9134666e5d1d09d02cc94cd73c2818b1fc92132fafeb8b3b6f904316ab57a3aab4fa01ba00e0e5bfabf9a9c5194de3d6a8666417 SHA512 0619eda926ca77730558600d29a1b7811972b411b86d6c5374f1ccbcd0a4901f70eb87df7577690d72bb7eec4a4191f3b7b4bca237317352bdc0f0ce0f36f120
+DIST filebus-0.3.5.tar.gz 17373 BLAKE2B bd49f86e658bcc8dcdcc7cc0c5ca1a3c354a716137157753417b9b57294c14f058292650092e7e8bdb5563e041c009f36474508fb121e14487075cfc41b223bb SHA512 639b047be8fd3eba9cf97e57d7234f590aeb28e6e321195b435480ce0b334e14c236b888e79d14a824b16505e1c2d2c1fc04dd5d75b6f7ac1c8e9fbae6bf562f
EBUILD filebus-0.3.2.ebuild 1409 BLAKE2B 27687f694af313868388843ae88037ea08b6192adcbb4c64ed79bab64d77c62f6208e356da0f4912f1c23f24640da20a6ac27eb53a6e6125c7c68a8e40412187 SHA512 90475ee64cbe90e844597461ea3e884c95ae12598e2acfeb78491a6accb7fe25be1b18f8cbbe97af174d8e95798f3635466cc6dee3b0290b1f269df98a603553
+EBUILD filebus-0.3.4.ebuild 1412 BLAKE2B 963f10896782b2aa97997058c6ca8eeea3f0d5a3f3573d2cd21486cba21574778961485b49a52a98e7aa32b2fce707a1ccce51c0c3664baa75b16ab6c2ee3fc3 SHA512 b4e2bbcba53747be06ee20292ce1c852ad1f495d64abdde5e6193a235c017261e1976eb1838394c6205bf426db57fe6b2fe91d891446152dc2f5ca474005b91c
+EBUILD filebus-0.3.5.ebuild 1412 BLAKE2B 963f10896782b2aa97997058c6ca8eeea3f0d5a3f3573d2cd21486cba21574778961485b49a52a98e7aa32b2fce707a1ccce51c0c3664baa75b16ab6c2ee3fc3 SHA512 b4e2bbcba53747be06ee20292ce1c852ad1f495d64abdde5e6193a235c017261e1976eb1838394c6205bf426db57fe6b2fe91d891446152dc2f5ca474005b91c
MISC metadata.xml 344 BLAKE2B 5caade90b88d436416ff73af46b130b7b81e87f7c8850eac5eb6544432bec05da5c7d1f916f1f8306ff9dc13383dd6608667c8bc532712c57859ffd317fcde90 SHA512 4c172e9f8559f617647d0c6bf5b5408b53c5e26f9cfb96295584c594fcabfb768672c20ff4f16f4da738b391167aec2ea2f4929723f0167e8274df528c0bf561
diff --git a/app-misc/filebus/filebus-0.3.4.ebuild b/app-misc/filebus/filebus-0.3.4.ebuild
new file mode 100644
index 000000000000..aa9148dd2099
--- /dev/null
+++ b/app-misc/filebus/filebus-0.3.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DISTUTILS_OPTIONAL=1
+DISTUTILS_USE_SETUPTOOLS=manual
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A user space multicast named pipe implementation backed by a regular file"
+HOMEPAGE="https://github.com/pipebus/filebus"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="+inotify python test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RDEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/filelock[${PYTHON_USEDEP}]
+ inotify? ( dev-python/watchdog[${PYTHON_USEDEP}] )
+ )"
+BDEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ if use python; then
+ distutils-r1_src_prepare
+ fi
+}
+
+src_compile() {
+ if use python; then
+ distutils-r1_src_compile
+ fi
+}
+
+src_test() {
+ "${BASH}" ./lib/bash/filebus-test.bash test || die
+
+ if use python; then
+ distutils-r1_src_test
+ fi
+}
+
+python_test() {
+ python test/test_filebus.py || die "tests failed for ${EPYTHON}"
+}
+
+src_install() {
+ if use python; then
+ distutils-r1_src_install
+ else
+ insinto /usr/libexec/filebus
+ doins lib/bash/*.bash
+ cat <<-EOF > "${T}/filebus"
+ #!/bin/sh
+ exec bash "${EPREFIX}/usr/libexec/filebus/filebus.bash" "\$@"
+ EOF
+ dobin "${T}/filebus"
+ dosym filebus /usr/bin/pipebus
+ fi
+}
diff --git a/app-misc/filebus/filebus-0.3.5.ebuild b/app-misc/filebus/filebus-0.3.5.ebuild
new file mode 100644
index 000000000000..aa9148dd2099
--- /dev/null
+++ b/app-misc/filebus/filebus-0.3.5.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DISTUTILS_OPTIONAL=1
+DISTUTILS_USE_SETUPTOOLS=manual
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A user space multicast named pipe implementation backed by a regular file"
+HOMEPAGE="https://github.com/pipebus/filebus"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="+inotify python test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RDEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/filelock[${PYTHON_USEDEP}]
+ inotify? ( dev-python/watchdog[${PYTHON_USEDEP}] )
+ )"
+BDEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ if use python; then
+ distutils-r1_src_prepare
+ fi
+}
+
+src_compile() {
+ if use python; then
+ distutils-r1_src_compile
+ fi
+}
+
+src_test() {
+ "${BASH}" ./lib/bash/filebus-test.bash test || die
+
+ if use python; then
+ distutils-r1_src_test
+ fi
+}
+
+python_test() {
+ python test/test_filebus.py || die "tests failed for ${EPYTHON}"
+}
+
+src_install() {
+ if use python; then
+ distutils-r1_src_install
+ else
+ insinto /usr/libexec/filebus
+ doins lib/bash/*.bash
+ cat <<-EOF > "${T}/filebus"
+ #!/bin/sh
+ exec bash "${EPREFIX}/usr/libexec/filebus/filebus.bash" "\$@"
+ EOF
+ dobin "${T}/filebus"
+ dosym filebus /usr/bin/pipebus
+ fi
+}