summaryrefslogtreecommitdiff
path: root/app-misc/fhem
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /app-misc/fhem
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'app-misc/fhem')
-rw-r--r--app-misc/fhem/Manifest2
-rw-r--r--app-misc/fhem/fhem-6.1.ebuild107
2 files changed, 109 insertions, 0 deletions
diff --git a/app-misc/fhem/Manifest b/app-misc/fhem/Manifest
index 26cfeb6af048..b079e8f1d115 100644
--- a/app-misc/fhem/Manifest
+++ b/app-misc/fhem/Manifest
@@ -3,5 +3,7 @@ AUX fhem.initd 447 BLAKE2B c724aa0b16fa7c6e1018e78c6ece9d1ba6357d147d1909326a5ad
AUX fhem.service-r1 240 BLAKE2B e52d6d324db876a1b477f09a480b8a7053af9bfc7264d3cc1fc35f7dfd9401c4a415867d7ac295f4750d6633abe9b9f24b7250c7dfeed31799597f42157a209d SHA512 87f10593f57eb5775a729005ec28fc0d5673044eea7a38ddcb32596ba6b26cd52d866fc2c1eb71985bffd3820f8574f965f42341761bb0ac95d042dca39d8320
AUX fhem.tmpfiles 31 BLAKE2B 57659fe7fe189d03cd1fdbd073421f2215b90db9d2c00b335ca3b98b7c42b23085c9ccadd85fc40c5c21e393c571bacc6804b06dc47de88bfcfe4384d7be88f8 SHA512 4e29020ae5d114c6ab3ad1935a8b4b1b4d6d521771554130304534f69a0ec6961f93b64ad45aabeeff9ab1a73dbe97187922f845c849565105801edffc1ac0ce
DIST fhem-6.0.tar.gz 28562819 BLAKE2B 4bc4f232caf0adc35ded72f380c1d4c816a22304af357f9b204fb856c2053038e3db2d834b7448d3cf43e84d3f435a36d047e48606b9e1083ab4963b38a75301 SHA512 a8e9d74b1d68ad7c9aea0a4d463aa877cb607458cb6ecf76203c96ff2156fd8b8a3b9cb5687ac0a5cd1eca5f94552433de55f3696b7be54a3cfa8df9cf74fbe1
+DIST fhem-6.1.tar.gz 32437246 BLAKE2B 0c7afce70d7fa4afe01b4dd46847cfb406a267c30ba6490b4ded75c365e745c0e84aa4872e6ca9c59f11b3082655e23295c59d69c5f91b272cc576df2e9e4978 SHA512 93767f6e8fa2b35b24192c1dd5de29bc9ac09f8690982870d1479350acc0954d6a635fcb2abfdac96f2f9b4f8217288486b35fa385f3388efd1407b4f14ebe8f
EBUILD fhem-6.0-r1.ebuild 2382 BLAKE2B 37f251813c0975d52116a57f257384d53953c2a0ee29ff06930f37f41856525e31b51cd8a0e48732df88cbd434d36de7482b3c0304f84ce50ed8b28982125b63 SHA512 ef616c697168a8f60732419533c395da530f5c49bb3063785b76fe6cba9819d93e2b00ee2d1e0f0426da24e76ab12c817cf90c1be96af97f248f6b80a9546d38
+EBUILD fhem-6.1.ebuild 2384 BLAKE2B 3177be5b0f0fed3121c8cff72e8b2ae54470393d0cde78234a1a4b396617803b7c0310264cf8659a6e76d6a4d68271750ea7d97779401786b482b44fa2dfc139 SHA512 d270a7beba057938ebf4f42dcf48d0759502502d32afa4c417c185520ed31bcf2c993ea9a2b608446687c402a3f7f72191083fee0b3ee1035c59d10ed295205a
MISC metadata.xml 649 BLAKE2B 65e494e68939d0c02cf09b5a56856a6615171a10603cea9dbaec0bc41804b841c92c4866b2b88c5026fcbb73b438080d22f0031e26807735fa8a84c44f0bca75 SHA512 68927bc6a1795cdf8dbc8c4f1a8a8d85f4810b910b5e0be35397a46d38d65dda035c7c408cfb86db427f3cfa33c4366674ad1adcb3a6dd1f63a9cdc53f49484f
diff --git a/app-misc/fhem/fhem-6.1.ebuild b/app-misc/fhem/fhem-6.1.ebuild
new file mode 100644
index 000000000000..ff54d3f73199
--- /dev/null
+++ b/app-misc/fhem/fhem-6.1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd tmpfiles
+
+DESCRIPTION="A GPL'd perl server for house automation"
+HOMEPAGE="https://www.fhem.de/"
+SRC_URI="https://www.fhem.de/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ acct-group/fhem
+ acct-user/fhem
+ dev-perl/Crypt-CBC
+ dev-perl/Device-SerialPort
+ dev-perl/Digest-CRC
+ dev-perl/JSON
+"
+
+DEPEND="media-gfx/pngcrush"
+
+src_prepare() {
+ default
+
+ # Allow install path to be set by DESTDIR in Makefile
+ sed -i -e 's,^\(BINDIR=\),\1'\$\(DESTDIR\)',' Makefile || die
+
+ # Remove docs in Makefile, as they will be installed manually
+ sed -i -e 's/docs//g' Makefile || die
+ sed -i -e '/README_DEMO.txt/d' Makefile || die
+
+ # Remove manpage in Makefile, as it will be installed manually
+ sed -i -e '/fhem.pl.1/d' Makefile || die
+
+ # Remove lcd4linux binaries, as they are provied by app-misc/lcd4linux
+ rm -r contrib/lcd4linux || die
+
+ # Remove log dir, as it will be replaced with a symlink
+ rm -r log || die
+
+ # Fix fhemicon_darksmall.png, as it reports "broken IDAT window length"
+ # Reported to Upstream: https://forum.fhem.de/index.php/topic,86238.0.html
+ pngcrush -fix -force -ow www/images/default/fhemicon_darksmall.png || die
+
+ cp "${FILESDIR}"/fhem.cfg fhem.cfg || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local DOCS=(
+ "CHANGED"
+ "HISTORY"
+ "MAINTAINER.txt"
+ "README.SVN"
+ "README_DEMO.txt"
+ "docs"/*.txt
+ "docs"/*.patch
+ "docs"/*.pdf
+ "docs/changelog"
+ "docs/copyright"
+ "docs/dotconfig"
+ "docs/fhem.odg.readme"
+ "docs/LIESMICH.update-thirdparty"
+ "docs"/README*
+ "docs/X10"
+ )
+
+ if use doc; then
+ local DOCS+=( "docs/X10" )
+ local HTML_DOCS=( "docs/"*.eps "docs/"*.html "docs"/*.jpg "docs"/*.js "docs"/*.odg "docs/"*.png "docs/km271" )
+ fi
+
+ diropts -o fhem -g fhem
+ keepdir "/var/lib/fhem"
+ keepdir "/var/log/fhem"
+ diropts
+
+ dosym ../../var/lib/fhem /opt/fhem/data
+ dosym ../../var/log/fhem /opt/fhem/log
+
+ default
+
+ newinitd "${FILESDIR}"/fhem.initd fhem
+
+ systemd_newunit "${FILESDIR}"/fhem.service-r1 fhem.service
+ newtmpfiles "${FILESDIR}"/fhem.tmpfiles fhem.conf
+
+ newman docs/fhem.man fhem.pl.1
+
+ echo 'CONFIG_PROTECT="/opt/fhem /var/lib/fhem"' > "${T}"/99fhem || die
+ doenvd "${T}"/99fhem
+
+ fowners fhem:fhem /opt/fhem/fhem.cfg
+}
+
+pkg_postinst() {
+ tmpfiles_process fhem.conf
+}