summaryrefslogtreecommitdiff
path: root/app-misc/fhem
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/fhem
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/fhem')
-rw-r--r--app-misc/fhem/Manifest5
-rw-r--r--app-misc/fhem/fhem-5.8.ebuild99
-rw-r--r--app-misc/fhem/files/fhem.cfg27
-rw-r--r--app-misc/fhem/files/fhem.initd17
-rw-r--r--app-misc/fhem/metadata.xml20
5 files changed, 168 insertions, 0 deletions
diff --git a/app-misc/fhem/Manifest b/app-misc/fhem/Manifest
new file mode 100644
index 000000000000..61eb71f5e033
--- /dev/null
+++ b/app-misc/fhem/Manifest
@@ -0,0 +1,5 @@
+AUX fhem.cfg 791 BLAKE2B ba55b71711199794c38720ad724fbc9d5f05d1713c1af0d02662765e8248e845bc3c07ae619b46e450d9b3a96a993a814e0c831a51edce6129d8efe07baee0db SHA512 9ce1c1cc2d7c55a29df2e344ad6600704e68536b734997a7cc1a73a225970c26f924c902c4d4e6f318e22a000b9b4ec2ceb52edd650fe3a8d12488b5293f7ad3
+AUX fhem.initd 447 BLAKE2B c724aa0b16fa7c6e1018e78c6ece9d1ba6357d147d1909326a5adc580af2cad57a0c13549b3c9f4b19b6fdad279ebbf8d0b64a36f29690911b342a06c865c7da SHA512 3be01778d970f4b93e551ff3769ed7b0825508dc5216a43ed0bb12f589103350bdb400561cbada9315050d32a99f723f5291e9bf1c6318642b16b8b9dc9e8c61
+DIST fhem-5.8.tar.gz 22139481 BLAKE2B 444b041b591d3c960036a262e6eb3fda026d4b229a21df16d7817c32a1fd57282a7fbe5559164b760bd9cfad314c2977e7d6f611320d35be090cdb9df66fb8fd SHA512 6cfaa14288ce553a2418db4cb47c719f2d5edbccbde9e76f221cd47cf8a175a67125031c4971f9f9972b218fc709a267757c2abefe6a33be47eb4bb45e23be57
+EBUILD fhem-5.8.ebuild 2226 BLAKE2B 1e938078cde599e3a2acde068ff4e9f4be16c3160ca95819d7c51f0ca8e3c32902577c3076cdef2972dc13ac5b0cf31eb5bff9afc476548a3b25b34872724836 SHA512 9e104f7626b17dd8b43bd2ef36d264a1d48219d36fff8345f1b0bde78c289b88c3c4f3ab87a0e60d3683134b486759d5c5d407357367380daeab005a2662e1c6
+MISC metadata.xml 767 BLAKE2B 16319027b755dc2d63c9176681196af9da38d9c5002ca75554f824bca03c67303cee0f1b15f9583d8264eb87c25373704569ac629258c81ed999882500f04014 SHA512 ba31d04179d2f12b1ba803a4cb589ca17b35b33013b78804fb89a716644bcad9fdb71795b36a6519e90b125164b7fe5d6744f0e1e519fc129a7197bd722c6ae4
diff --git a/app-misc/fhem/fhem-5.8.ebuild b/app-misc/fhem/fhem-5.8.ebuild
new file mode 100644
index 000000000000..70fd300295f7
--- /dev/null
+++ b/app-misc/fhem/fhem-5.8.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit user
+
+DESCRIPTION="A GPL'd perl server for house automation"
+HOMEPAGE="https://www.fhem.de/"
+SRC_URI="https://www.fhem.de/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="dev-perl/Crypt-CBC
+ dev-perl/Device-SerialPort
+ dev-perl/Digest-CRC
+ dev-perl/JSON"
+
+DEPEND="media-gfx/pngcrush"
+
+QA_PREBUILT="opt/fhem/contrib/lcd4linux/fritzbox_dpf/lcd4linux
+ opt/fhem/contrib/lcd4linux/rpi_dpf/lcd4linux"
+
+pkg_setup() {
+ enewgroup fhem
+ enewuser fhem -1 -1 /opt/fhem fhem
+}
+
+src_prepare() {
+ default
+
+ # Allow install path to be set by DESTDIR in Makefile
+ sed -i -e 's,^\(BINDIR=\),\1'\$\(DESTDIR\)',' Makefile || die
+
+ # Remove docs in Makefile, as they will be installed manually
+ sed -i -e 's/docs//g' Makefile || die
+ sed -i -e '/README_DEMO.txt/d' Makefile || die
+
+ # Remove manpage in Makefile, as it will be installed manually
+ sed -i -e '/fhem.pl.1/d' Makefile || die
+
+ # Remove log dir, as it will be replaced with a symlink
+ rm -r log || die
+
+ # Fix fhemicon_darksmall.png, as it reports "broken IDAT window length"
+ # Reported to Upstream: https://forum.fhem.de/index.php/topic,86238.0.html
+ pngcrush -fix -force -ow www/images/default/fhemicon_darksmall.png || die
+
+ cp "${FILESDIR}"/fhem.cfg fhem.cfg || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local DOCS=(
+ "CHANGED"
+ "HISTORY"
+ "README.SVN"
+ "README_DEMO.txt"
+ "docs"/*.txt
+ "docs"/*.patch
+ "docs"/*.pdf
+ "docs/changelog"
+ "docs/copyright"
+ "docs/dotconfig"
+ "docs/fhem.odg.readme"
+ "docs/LIESMICH.update-thirdparty"
+ "docs"/README*
+ "docs/X10"
+ )
+
+ if use doc; then
+ local DOCS+=( "docs/X10" )
+ local HTML_DOCS=( "docs/"*.eps "docs/"*.html "docs"/*.jpg "docs"/*.js "docs"/*.odg "docs/"*.png "docs/km271" )
+ fi
+
+ diropts -o fhem -g fhem
+ keepdir "/var/lib/fhem"
+ keepdir "/var/log/fhem"
+
+ dosym ../../var/lib/fhem /opt/fhem/data
+ dosym ../../var/log/fhem /opt/fhem/log
+
+ default
+
+ newinitd "${FILESDIR}"/fhem.initd fhem
+
+ newman docs/fhem.man fhem.pl.1
+
+ echo 'CONFIG_PROTECT="/opt/fhem /var/lib/fhem"' > "${T}"/99fhem || die
+ doenvd "${T}"/99fhem
+
+ fowners fhem:fhem /opt/fhem/fhem.cfg
+}
diff --git a/app-misc/fhem/files/fhem.cfg b/app-misc/fhem/files/fhem.cfg
new file mode 100644
index 000000000000..04f7ae9a4681
--- /dev/null
+++ b/app-misc/fhem/files/fhem.cfg
@@ -0,0 +1,27 @@
+attr global logfile ./log/fhem-%Y-%m.log
+attr global pidfilename /run/fhem/fhem.pid
+attr global modpath .
+attr global statefile ./data/fhem.save
+attr global verbose 3
+attr global updateInBackground
+
+define telnetPort telnet 7072 global
+
+define WEB FHEMWEB 8083 global
+
+define WEBphone FHEMWEB 8084 global
+attr WEBphone stylesheetPrefix smallscreen
+
+define WEBtablet FHEMWEB 8085 global
+attr WEBtablet stylesheetPrefix touchpad
+
+# Fake FileLog entry, to access the fhem log from FHEMWEB
+define Logfile FileLog ./log/fhem-%Y-%m.log fakelog
+
+define autocreate autocreate
+attr autocreate filelog ./data/%NAME-%Y.log
+
+define eventTypes eventTypes ./data/eventTypes.txt
+
+# Disable this to avoid looking for new USB devices on startup
+define initialUsbCheck notify global:INITIALIZED usb create
diff --git a/app-misc/fhem/files/fhem.initd b/app-misc/fhem/files/fhem.initd
new file mode 100644
index 000000000000..424948719010
--- /dev/null
+++ b/app-misc/fhem/files/fhem.initd
@@ -0,0 +1,17 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+home="/opt/fhem"
+command="${home}/fhem.pl"
+command_args="${home}/fhem.cfg"
+command_group="fhem"
+command_user="fhem"
+name="FHEM"
+pidfile_path="/run/fhem"
+pidfile="${pidfile_path}/fhem.pid"
+start_stop_daemon_args="--chdir ${home}"
+
+start_pre() {
+ checkpath -d -o "${command_user}:${command_group}" -q "${pidfile_path}"
+}
diff --git a/app-misc/fhem/metadata.xml b/app-misc/fhem/metadata.xml
new file mode 100644
index 000000000000..92b432980845
--- /dev/null
+++ b/app-misc/fhem/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ FHEM is a GPL'd perl server for house automation.
+ It is used to automate some common tasks in the household like
+ switching lamps, shutters, heating and to log events like
+ temperature, humidity, power consumption.
+ In order to use FHEM you'll need some attached hardware
+ like the CUL-, EnOcean- or Z-Wave-USB-Stick to access the actors and sensors.
+ </longdescription>
+</pkgmetadata>