summaryrefslogtreecommitdiff
path: root/app-misc/fastfetch/fastfetch-0.2.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-14 12:12:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-14 12:12:48 +0100
commitb6323af2602e6a5cd4920d4af06b5c2f3949b9d0 (patch)
tree7d427f015930068f8d06e8f5aa622635ac3b61ca /app-misc/fastfetch/fastfetch-0.2.9999.ebuild
parent4b61f038fc5ecca26609a997fcc662c7cf9e0498 (diff)
gentoo auto-resync : 14:08:2023 - 12:12:48
Diffstat (limited to 'app-misc/fastfetch/fastfetch-0.2.9999.ebuild')
-rw-r--r--app-misc/fastfetch/fastfetch-0.2.9999.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/app-misc/fastfetch/fastfetch-0.2.9999.ebuild b/app-misc/fastfetch/fastfetch-0.2.9999.ebuild
index 7a1c4c649c9a..950efaa60c13 100644
--- a/app-misc/fastfetch/fastfetch-0.2.9999.ebuild
+++ b/app-misc/fastfetch/fastfetch-0.2.9999.ebuild
@@ -20,14 +20,16 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="X chafa dbus gnome imagemagick networkmanager opencl opengl osmesa pci pulseaudio sqlite vulkan wayland xcb xfce xrandr"
+IUSE="X chafa dbus ddcutil gnome imagemagick networkmanager opencl opengl osmesa pci pulseaudio sqlite vulkan wayland xcb xfce xrandr"
# note - qa-vdb will always report errors because fastfetch loads the libs dynamically
RDEPEND="
+ dev-libs/yyjson
sys-libs/zlib
X? ( x11-libs/libX11 )
chafa? ( media-gfx/chafa )
dbus? ( sys-apps/dbus )
+ ddcutil? ( app-misc/ddcutil:= )
gnome? (
dev-libs/glib
gnome-base/dconf
@@ -54,6 +56,8 @@ REQUIRED_USE="
chafa? ( imagemagick )
"
+PATCHES=( "${FILESDIR}"/${PN}-2.0.0-dont-fetch-yyjson.patch )
+
src_configure() {
local fastfetch_enable_imagemagick7=no
local fastfetch_enable_imagemagick6=no
@@ -63,12 +67,12 @@ src_configure() {
fi
local mycmakeargs=(
- -DENABLE_LIBCJSON=no
-DENABLE_RPM=no
-DENABLE_ZLIB=yes
-DENABLE_CHAFA=$(usex chafa)
-DENABLE_DBUS=$(usex dbus)
+ -DENABLE_DDCUTIL=$(usex ddcutil)
-DENABLE_DCONF=$(usex gnome)
-DENABLE_EGL=$(usex opengl)
-DENABLE_GIO=$(usex gnome)