summaryrefslogtreecommitdiff
path: root/app-misc/elasticsearch/elasticsearch-7.13.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /app-misc/elasticsearch/elasticsearch-7.13.2.ebuild
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'app-misc/elasticsearch/elasticsearch-7.13.2.ebuild')
-rw-r--r--app-misc/elasticsearch/elasticsearch-7.13.2.ebuild82
1 files changed, 0 insertions, 82 deletions
diff --git a/app-misc/elasticsearch/elasticsearch-7.13.2.ebuild b/app-misc/elasticsearch/elasticsearch-7.13.2.ebuild
deleted file mode 100644
index bdf9f6e767d4..000000000000
--- a/app-misc/elasticsearch/elasticsearch-7.13.2.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit systemd tmpfiles
-
-DESCRIPTION="Free and Open, Distributed, RESTful Search Engine"
-HOMEPAGE="https://www.elastic.co/elasticsearch/"
-SRC_URI="https://artifacts.elastic.co/downloads/${PN}/${P}-no-jdk-linux-x86_64.tar.gz"
-LICENSE="Apache-2.0 BSD-2 Elastic-2.0 LGPL-3 MIT public-domain"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="acct-group/elasticsearch
- acct-user/elasticsearch
- virtual/jre"
-
-QA_PREBUILT="usr/share/elasticsearch/modules/x-pack-ml/platform/linux-x86_64/\(bin\|lib\)/.*"
-QA_PRESTRIPPED="usr/share/elasticsearch/modules/x-pack-ml/platform/linux-x86_64/\(bin\|lib\)/.*"
-
-src_prepare() {
- default
-
- rm LICENSE.txt NOTICE.txt || die
- rmdir logs || die
-}
-
-src_install() {
- keepdir /etc/${PN}
- keepdir /etc/${PN}/scripts
-
- insinto /etc/${PN}
- doins -r config/.
- rm -r config || die
-
- fowners root:${PN} /etc/${PN}
- fperms 2750 /etc/${PN}
-
- insinto /usr/share/${PN}
- doins -r .
-
- exeinto /usr/share/${PN}/bin
- doexe "${FILESDIR}/elasticsearch-systemd-pre-exec"
-
- fperms -R +x /usr/share/${PN}/bin
- fperms -R +x /usr/share/${PN}/modules/x-pack-ml/platform/linux-x86_64/bin
-
- keepdir /var/{lib,log}/${PN}
- fowners ${PN}:${PN} /var/{lib,log}/${PN}
- fperms 0750 /var/{lib,log}/${PN}
- dodir /usr/share/${PN}/plugins
-
- insinto /etc/sysctl.d
- newins "${FILESDIR}/${PN}.sysctl.d" ${PN}.conf
-
- newconfd "${FILESDIR}/${PN}.conf.4" ${PN}
- newinitd "${FILESDIR}/${PN}.init.8" ${PN}
-
- systemd_install_serviced "${FILESDIR}/${PN}.service.conf"
- systemd_newunit "${FILESDIR}"/${PN}.service.3 ${PN}.service
-
- newtmpfiles "${FILESDIR}"/${PN}.tmpfiles.d ${PN}.conf
-}
-
-pkg_postinst() {
- tmpfiles_process ${PN}.conf
-
- elog
- elog "You may create multiple instances of ${PN} by"
- elog "symlinking the init script:"
- elog "ln -sf /etc/init.d/${PN} /etc/init.d/${PN}.instance"
- elog
- elog "Please make sure you put elasticsearch.yml, log4j2.properties and scripts"
- elog "from /etc/${PN} into the configuration directory of the instance:"
- elog "/etc/${PN}/instance"
- elog
- ewarn "Please make sure you have proper permissions on /etc/${PN}"
- ewarn "prior to keystore generation or you may experience startup fails."
- ewarn "chown root:${PN} /etc/${PN} && chmod 2750 /etc/${PN}"
- ewarn "chown root:${PN} /etc/${PN}/${PN}.keystore && chmod 0660 /etc/${PN}/${PN}.keystore"
-}