summaryrefslogtreecommitdiff
path: root/app-misc/dtach
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/dtach
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/dtach')
-rw-r--r--app-misc/dtach/Manifest6
-rw-r--r--app-misc/dtach/dtach-0.8-r1.ebuild25
-rw-r--r--app-misc/dtach/dtach-0.9.ebuild19
-rw-r--r--app-misc/dtach/files/dtach-0.8-CVE-2012-3368.patch35
-rw-r--r--app-misc/dtach/metadata.xml12
5 files changed, 97 insertions, 0 deletions
diff --git a/app-misc/dtach/Manifest b/app-misc/dtach/Manifest
new file mode 100644
index 000000000000..6c574490b687
--- /dev/null
+++ b/app-misc/dtach/Manifest
@@ -0,0 +1,6 @@
+AUX dtach-0.8-CVE-2012-3368.patch 1040 BLAKE2B ded617740765ca7aa814cc98acb46a3680077fc5baf1c55e0298bc772a4987efe2723a01d0f8b3a295173c8fe92c5d066993f9946b6b4beae80cc2de8aaebae8 SHA512 64ab0e8384e4f04e43b8565440b0ec3f0d43b87e142cd15dda0eec2b320aa3e8ed437524dcdbd390b83f4cb39c13df3575318be4de5f8eec50fb710c9ec1170b
+DIST dtach-0.8.tar.gz 55472 BLAKE2B 9627075763f02787d7071658d1ae040d0c18dfe91f2954546398431e677b7c90cf67c23af0cc20182b354656d50b579c378f54d9f691853b7707a5761bc69b4f SHA512 ad0a788d10a5e1e1be4c353b64e1e4a0dc8c888492a638b2442d7c59ef31d67975357116435a1059141bfc2c82a3a6e9e490faa87cf81e5fc3bc7457a99c1193
+DIST dtach-0.9.tar.gz 60608 BLAKE2B 915b3a13cfd86a2e72505c9f8778ebbc9f25db761815e1352c0bc1281aaddcc95a837a880999379c19912fd3980bb77a20711796ef71b06282f1a27a6cc3572d SHA512 28c13dc8c96c16b9c6153a3a11fdeb4a4bc72e84e1f2575043b047cd8e600a47232f29544ffd87d82e2575623ec2e999a26e23e9eac25ec81c7722bdf98cfb18
+EBUILD dtach-0.8-r1.ebuild 472 BLAKE2B fe7f93c1bb254d2d1115f0cc96ead198ab266712fab96a4dc55bf93e04311cbbeea74b1f25b2bdb16e70520c3f3b70d2c3f4dd167271d1d4ba0c54cb46a28d4e SHA512 cddc92673cb9ab6153c477c2a77f95584edcb4a7140c5e275ddb9ad64773c56084e9609d06c9a00cb226ac3cbe71842114b6fd3522e0db6b624f4adb1fdd216a
+EBUILD dtach-0.9.ebuild 464 BLAKE2B 05f6f7540c4859d50d54bb2b12b215c75393d0f3e15c91e7a47abcf9d835c9d5b84bf373fab0200e2ae81f0fa610f89441a5555514c9f4bf5d0bde5130e2444b SHA512 934755b47e1835affcbd1d5f92545b42ea6f315ed810d397ae069fa69aef9f4a5abd99e4a1ef92528db86ebcd2aad7c04462093813b4af5fcd940b38020c1759
+MISC metadata.xml 393 BLAKE2B 0a07b0eac6407190f07439b29f3cfbe185450ba5dfe0c4d3988c6d6abfe12c728029bda874cfaef61c48abe6182288e70ceee27d5db22b8eec03b20476db2991 SHA512 39071ddc8ee3913fb6898bbf5ce5488c76f6a7fa5f3f3905359a228d432cc76fe0336c0640d0fcd26c1be97abc220626c4258c5cd1de280a50d033b57d84aaa7
diff --git a/app-misc/dtach/dtach-0.8-r1.ebuild b/app-misc/dtach/dtach-0.8-r1.ebuild
new file mode 100644
index 000000000000..34e56870b850
--- /dev/null
+++ b/app-misc/dtach/dtach-0.8-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Emulates the detach feature of screen"
+HOMEPAGE="http://dtach.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha amd64 ~arm ppc x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-CVE-2012-3368.patch
+}
+
+src_install() {
+ dobin dtach
+ doman dtach.1
+ dodoc README
+}
diff --git a/app-misc/dtach/dtach-0.9.ebuild b/app-misc/dtach/dtach-0.9.ebuild
new file mode 100644
index 000000000000..9f494f43e668
--- /dev/null
+++ b/app-misc/dtach/dtach-0.9.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Emulates the detach feature of screen"
+HOMEPAGE="http://dtach.sourceforge.net/ https://github.com/crigler/dtach"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="alpha amd64 arm ~arm64 ~ia64 ppc ~ppc64 s390 sparc x86 ~amd64-fbsd"
+IUSE=""
+
+src_install() {
+ dobin dtach
+ doman dtach.1
+ dodoc README
+}
diff --git a/app-misc/dtach/files/dtach-0.8-CVE-2012-3368.patch b/app-misc/dtach/files/dtach-0.8-CVE-2012-3368.patch
new file mode 100644
index 000000000000..82d5f0e1e159
--- /dev/null
+++ b/app-misc/dtach/files/dtach-0.8-CVE-2012-3368.patch
@@ -0,0 +1,35 @@
+Fix error handling for read from stdin in attach.c
+
+attach.c did not correctly handle a read from stdin when read returned
+an error. The code assigned the return value of read to pkt.len (an
+unsigned char) before checking the value. This prevented the error check
+from working correctly, since an unsigned integer can never be < 0.
+
+A packet with an invalid length was then sent to the master, which then
+sent 255 bytes of garbage to the program.
+
+Fix the bug in attach.c and the unchecked packet length bug in master.c.
+
+Report and initial patch by Enrico Scholz.
+
+--- attach.c 2012/07/01 21:26:10 1.12
++++ attach.c 2012/07/01 21:44:34 1.13
+@@ -237,12 +237,16 @@
+ /* stdin activity */
+ if (n > 0 && FD_ISSET(0, &readfds))
+ {
++ ssize_t len;
++
+ pkt.type = MSG_PUSH;
+ memset(pkt.u.buf, 0, sizeof(pkt.u.buf));
+- pkt.len = read(0, pkt.u.buf, sizeof(pkt.u.buf));
++ len = read(0, pkt.u.buf, sizeof(pkt.u.buf));
+
+- if (pkt.len <= 0)
++ if (len <= 0)
+ exit(1);
++
++ pkt.len = len;
+ process_kbd(s, &pkt);
+ n--;
+ }
diff --git a/app-misc/dtach/metadata.xml b/app-misc/dtach/metadata.xml
new file mode 100644
index 000000000000..b49e8d43f1e8
--- /dev/null
+++ b/app-misc/dtach/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Shell Tools Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">dtach</remote-id>
+ <remote-id type="github">crigler/dtach</remote-id>
+ </upstream>
+</pkgmetadata>