summaryrefslogtreecommitdiff
path: root/app-misc/digitemp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/digitemp
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/digitemp')
-rw-r--r--app-misc/digitemp/Manifest5
-rw-r--r--app-misc/digitemp/digitemp-3.5.0-r2.ebuild75
-rw-r--r--app-misc/digitemp/digitemp-3.7.1.ebuild75
-rw-r--r--app-misc/digitemp/metadata.xml23
4 files changed, 178 insertions, 0 deletions
diff --git a/app-misc/digitemp/Manifest b/app-misc/digitemp/Manifest
new file mode 100644
index 000000000000..859be87da990
--- /dev/null
+++ b/app-misc/digitemp/Manifest
@@ -0,0 +1,5 @@
+DIST digitemp-3.5.0.tar.gz 267947 BLAKE2B bdd5cd84160d4826205ac74676897b9caa296c203fcde738c99f89baaeb7637f3995afeb7741e1d1d3e6cb64776de2479fe7d54d1b499a400cbf7b59f8d46349 SHA512 59055a97ae35cdc86bb893a755975b688d3be9185e717f5da0024d664e6c93dd5a7f10f1230772c3bc1bc76a088392da083ba63d28e054727b9f68ce31de64d3
+DIST digitemp-3.7.1.tar.gz 144870 BLAKE2B 5d00197ba0122772d96c3185f430119961d214f50dc07dcd5881e1aa1135283680ff38b4d92736827f5c7644b11930b9418b8467f276e832e40f4228d08d1774 SHA512 e5eaf576b544c61049a358dece7dc96d9793b751ef08645060f3b2c1a2006e2906c3aa3f97de3dab46818290d664d2e784a948b2495b538a200b6d71b03173d2
+EBUILD digitemp-3.5.0-r2.ebuild 1826 BLAKE2B a9cfe9ca027e64237c2e46a8e1f216e0824eccec720c84e9e17fcae440c058ef4cc49e366259e075de879c0fe9014dbffc1a088b1a91a2674efe84872e06a5ee SHA512 2dc36c29e0c64c9f87372493d0aefb26105af1cee219c51ed6c4d224a378cec9a793fdcbfccbfa3bc1f94733ce286f8562fede0bfa1626faee3995aefa0f63f6
+EBUILD digitemp-3.7.1.ebuild 1845 BLAKE2B 8a2fd58c5505e05edf1982b14dc89e589e498b948d15647ab9ff8061ae25b088715a2b701878e938cbf8e483222283d810dd546aecb4464d95ad239678587f4b SHA512 7d6d89ef1d5f3d8bd154073f8dcf05d40847ec9d202b3c03b3ca42d22fdcb78560f11c090a26bdae07cc5ee9def88c3de98fe8e05f12427ea4ec2ef90605acca
+MISC metadata.xml 982 BLAKE2B 9a74eb54a17f249dd527e5aa4b292dadce934da1d1303ba6ca3bb5503c5e235836261495af1eb3c04e0322725c46838b1c902e8f5862856edb3696a147a74184 SHA512 8dda9bc7dff244e54e4951d553f2255bd1da1279221374fc514b5483e36ae129fc9e154c8bf07bf66b3ddc9b2bdac172184b3d9b89c06852f0f9f2237de627a2
diff --git a/app-misc/digitemp/digitemp-3.5.0-r2.ebuild b/app-misc/digitemp/digitemp-3.5.0-r2.ebuild
new file mode 100644
index 000000000000..cd0f7c008a75
--- /dev/null
+++ b/app-misc/digitemp/digitemp-3.5.0-r2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Temperature logging and reporting using Maxim's iButtons and 1-Wire protocol"
+HOMEPAGE="https://www.digitemp.com/ https://www.ibutton.com/"
+SRC_URI="https://www.digitemp.com/software/linux/${P}.tar.gz"
+
+IUSE="ds9097 ds9097u ds2490"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+
+DEPEND="ds2490? ( virtual/libusb:0 )"
+
+targets() {
+ # default is to compile to the ds9097u.
+ if ! ( use ds9097 || use ds9097u || use ds2490 ); then
+ echo ds9097u
+ fi
+ for target in ds9097 ds9097u ds2490; do
+ if use ${target}; then
+ echo ${target}
+ fi
+ done
+}
+
+src_prepare() {
+ sed -i -e "/^CFLAGS/s:-O2:${CFLAGS}:" \
+ -e "/^LIBS/s:=:= ${LDFLAGS}:" Makefile
+ # default is to compile to the ds9097u.
+ if ! ( use ds9097 || use ds9097u || use ds2490 ); then
+ ewarn "If you don't choose a component to install, we default to ds9097u"
+ fi
+}
+
+src_compile() {
+ local targets=$(targets)
+
+ for target in $targets; do
+ emake clean
+ emake CC="$(tc-getCC)" LOCK="no" ${target} || die "emake ${target} failed"
+ done
+}
+
+src_install() {
+ for target in $(echo $(targets) | tr '[:lower:]' '[:upper:]'); do
+ dobin digitemp_${target} && \
+ dosym digitemp_${target} /usr/bin/digitemp
+ done
+
+ if [[ $(targets|wc -l) -ge 1 ]]; then
+ echo
+ ewarn "/usr/bin/digitemp has been symlinked to /usr/bin/digitemp_${target}"
+ ewarn "If you want to access the others, they are available at /usr/bin/digitemp_*"
+ echo
+ fi
+
+ dodoc README FAQ TODO
+
+ for example in perl python rrdb; do
+ insinto "/usr/share/doc/${PF}/${example}_examples"
+ doins -r ${example}/*
+ done
+}
+
+pkg_postinst() {
+ echo
+ elog "Examples of using digitemp with python, perl, and rrdtool are"
+ elog "located in /usr/share/doc/${PF}/"
+ echo
+}
diff --git a/app-misc/digitemp/digitemp-3.7.1.ebuild b/app-misc/digitemp/digitemp-3.7.1.ebuild
new file mode 100644
index 000000000000..718f8d20bbf8
--- /dev/null
+++ b/app-misc/digitemp/digitemp-3.7.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Temperature logging and reporting using Maxim's iButtons and 1-Wire protocol"
+HOMEPAGE="https://www.digitemp.com/ https://www.ibutton.com/"
+SRC_URI="https://github.com/bcl/digitemp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE="ds9097 ds9097u ds2490"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="ds2490? ( virtual/libusb:0 )"
+
+targets() {
+ # default is to compile to the ds9097u.
+ if ! ( use ds9097 || use ds9097u || use ds2490 ); then
+ echo ds9097u
+ fi
+ for target in ds9097 ds9097u ds2490; do
+ if use ${target}; then
+ echo ${target}
+ fi
+ done
+}
+
+src_prepare() {
+ sed -i -e "/^CFLAGS/s:-O2:${CFLAGS}:" \
+ -e "/^LIBS/s:=:= ${LDFLAGS}:" Makefile
+ # default is to compile to the ds9097u.
+ if ! ( use ds9097 || use ds9097u || use ds2490 ); then
+ ewarn "If you don't choose a component to install, we default to ds9097u"
+ fi
+}
+
+src_compile() {
+ local targets=$(targets)
+
+ for target in $targets; do
+ emake clean
+ emake CC="$(tc-getCC)" LOCK="no" ${target} || die "emake ${target} failed"
+ done
+}
+
+src_install() {
+ for target in $(echo $(targets) | tr '[:lower:]' '[:upper:]'); do
+ dobin digitemp_${target} && \
+ dosym digitemp_${target} /usr/bin/digitemp
+ done
+
+ if [[ $(targets|wc -l) -ge 1 ]]; then
+ echo
+ ewarn "/usr/bin/digitemp has been symlinked to /usr/bin/digitemp_${target}"
+ ewarn "If you want to access the others, they are available at /usr/bin/digitemp_*"
+ echo
+ fi
+
+ dodoc README FAQ TODO
+
+ for example in perl python rrdb; do
+ insinto "/usr/share/doc/${PF}/${example}_examples"
+ doins -r ${example}/*
+ done
+}
+
+pkg_postinst() {
+ echo
+ elog "Examples of using digitemp with python, perl, and rrdtool are"
+ elog "located in /usr/share/doc/${PF}/"
+ echo
+}
diff --git a/app-misc/digitemp/metadata.xml b/app-misc/digitemp/metadata.xml
new file mode 100644
index 000000000000..7ed6505057eb
--- /dev/null
+++ b/app-misc/digitemp/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription>
+DigiTemp is a simple to use program for reading values from 1-wire devices. Its
+main use is for reading temperature sensors, but it also reads counters, and
+understands the 1-wire hubs with devices on different branches of the network.
+DigiTemp now supports the following 1-wire temperature sensors: DS18S20 (and
+DS1820), DS18B20, DS1822, the DS2438 Smart Battery Monitor, DS2422 and DS2423
+Counters, DS2409 MicroLAN Coupler (used in 1-wire hubs), and the AAG TAI-8540
+humidity sensor.
+ </longdescription>
+ <use>
+ <flag name="ds2490">Build support for the ds2490 sensor</flag>
+ <flag name="ds9097">Build support for the ds9097 sensor</flag>
+ <flag name="ds9097u">Build support for the ds9097u sensor</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">bcl/digitemp</remote-id>
+ </upstream>
+</pkgmetadata>
+