summaryrefslogtreecommitdiff
path: root/app-misc/digitemp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-misc/digitemp
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-misc/digitemp')
-rw-r--r--app-misc/digitemp/Manifest2
-rw-r--r--app-misc/digitemp/digitemp-3.7.1.ebuild77
2 files changed, 0 insertions, 79 deletions
diff --git a/app-misc/digitemp/Manifest b/app-misc/digitemp/Manifest
index 9022e4c6d73a..52505f1d367d 100644
--- a/app-misc/digitemp/Manifest
+++ b/app-misc/digitemp/Manifest
@@ -1,5 +1,3 @@
-DIST digitemp-3.7.1.tar.gz 144870 BLAKE2B 5d00197ba0122772d96c3185f430119961d214f50dc07dcd5881e1aa1135283680ff38b4d92736827f5c7644b11930b9418b8467f276e832e40f4228d08d1774 SHA512 e5eaf576b544c61049a358dece7dc96d9793b751ef08645060f3b2c1a2006e2906c3aa3f97de3dab46818290d664d2e784a948b2495b538a200b6d71b03173d2
DIST digitemp-3.7.2.tar.gz 146166 BLAKE2B 9718e5d8a135e99cfd8893f5f4d2cc40a0bcdffa4e01c4ef460d654b38d9808c75ea1efced6211672033a67be8ba7f30f34320ef8e64d47d8a88be8bbac8c997 SHA512 807934ecc743df5ee69e9a8a0f5e90e469f03e577cc80b4510e6ac4ecc61ff9c79e05642602a4f50b4acda7e1f53e33016e6c201898ab0b44c76f3f7ac028820
-EBUILD digitemp-3.7.1.ebuild 1787 BLAKE2B eab478eaee2516bee1c1282816cb4fec4042ad39b2e6ae866aa198527ddf0e1e8011078435dcd353022b4d3070da6873f0d62534e471276a7457dc42cc39f283 SHA512 8e15e866c2cb62f9021042ef4cf3e3a7e97f9da38681f8210ddd6d3e4df05f85bae4285dd02302fadce9973aafa8c49e7c7d9c4231eb2b2fff7d17e2e9222e67
EBUILD digitemp-3.7.2.ebuild 1787 BLAKE2B 4cd84f2d3b02bfd644c630cbf7fc675626a36d6721ff1c0eab0289e2f7633d5fa9577ae56c71bfe4c6c6ec28f078840bcfc592dbb2a2bb3bc6e21901a51223f3 SHA512 c6ccdb78afeb3dbb1d06eab3d5504e74780e7db11d885c46899d70c612a6725114c8116bfb6a3699aa78dccdaa91e00892119b9d2e72e2ae78178bb59cdb007e
MISC metadata.xml 982 BLAKE2B c76e77aba3cbd377a3459302669c327abda9b437c659149c768d0d7d8a791210302115b403df09c3802a5af0bee3370e8ee6cd18306d8d29e80d56eafc391cbc SHA512 abb3db43dce3e259defefccdb71fffa2cdbb8fc21149cc1167b04c71b854e0dbbf1996f32293d4369aa9af0131e01a12fc57a4156514e956272f1ee8f9cf0606
diff --git a/app-misc/digitemp/digitemp-3.7.1.ebuild b/app-misc/digitemp/digitemp-3.7.1.ebuild
deleted file mode 100644
index 65431c4aae4f..000000000000
--- a/app-misc/digitemp/digitemp-3.7.1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="Temperature logging and reporting using Maxim's iButtons and 1-Wire protocol"
-HOMEPAGE="https://www.digitemp.com/ https://www.ibutton.com/"
-SRC_URI="https://github.com/bcl/digitemp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 x86"
-IUSE="ds9097 ds9097u ds2490"
-
-DEPEND="ds2490? ( virtual/libusb:0 )"
-
-targets() {
- # default is to compile to the ds9097u.
- if ! ( use ds9097 || use ds9097u || use ds2490 ); then
- echo ds9097u
- fi
-
- for target in ds9097 ds9097u ds2490; do
- if use ${target}; then
- echo ${target}
- fi
- done
-}
-
-src_prepare() {
- default
-
- sed -i \
- -e "/^CFLAGS/s:-O2:${CFLAGS}:" \
- -e "/^LIBS/s:=:= ${LDFLAGS}:" \
- Makefile || die
-
- # default is to compile to the ds9097u.
- if ! ( use ds9097 || use ds9097u || use ds2490 ); then
- ewarn "If you don't choose a component to install, we default to ds9097u"
- fi
-}
-
-src_compile() {
- local targets=$(targets)
-
- for target in ${targets}; do
- emake clean
- emake CC="$(tc-getCC)" LOCK="no" ${target}
- done
-}
-
-src_install() {
- for target in $(echo $(targets) | tr '[:lower:]' '[:upper:]'); do
- dobin digitemp_${target} && \
- dosym digitemp_${target} /usr/bin/digitemp
- done
-
- if [[ $(targets|wc -l) -ge 1 ]]; then
- ewarn "/usr/bin/digitemp has been symlinked to /usr/bin/digitemp_${target}"
- ewarn "If you want to access the others, they are available at /usr/bin/digitemp_*"
- fi
-
- dodoc README FAQ TODO
-
- for example in perl python rrdb; do
- docinto ${example}_examples
- dodoc -r ${example}/*
- done
-}
-
-pkg_postinst() {
- elog "Examples of using digitemp with python, perl, and rrdtool are"
- elog "located in /usr/share/doc/${PF}/"
-}