summaryrefslogtreecommitdiff
path: root/app-misc/digitemp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-misc/digitemp
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-misc/digitemp')
-rw-r--r--app-misc/digitemp/Manifest2
-rw-r--r--app-misc/digitemp/digitemp-3.7.1.ebuild28
2 files changed, 16 insertions, 14 deletions
diff --git a/app-misc/digitemp/Manifest b/app-misc/digitemp/Manifest
index 3728f78f26c4..f4f396974e10 100644
--- a/app-misc/digitemp/Manifest
+++ b/app-misc/digitemp/Manifest
@@ -1,3 +1,3 @@
DIST digitemp-3.7.1.tar.gz 144870 BLAKE2B 5d00197ba0122772d96c3185f430119961d214f50dc07dcd5881e1aa1135283680ff38b4d92736827f5c7644b11930b9418b8467f276e832e40f4228d08d1774 SHA512 e5eaf576b544c61049a358dece7dc96d9793b751ef08645060f3b2c1a2006e2906c3aa3f97de3dab46818290d664d2e784a948b2495b538a200b6d71b03173d2
-EBUILD digitemp-3.7.1.ebuild 1808 BLAKE2B 3a81fb123fe2cef98264968f31abd4b41672b5825d96baa75ecf87070d91cdfb785e6521195d3d41f49a2d1d717b60321a906569f9f2cf0e43cec9033fa98754 SHA512 4d0bce875ed4bc7cdbc985d9acebb40ec74740a5c0caff5aa063b0178780b89b8c7b5abfeaabe2d03a70e10da07c3134335426ba198ca86e280b21aa51ab5687
+EBUILD digitemp-3.7.1.ebuild 1787 BLAKE2B eab478eaee2516bee1c1282816cb4fec4042ad39b2e6ae866aa198527ddf0e1e8011078435dcd353022b4d3070da6873f0d62534e471276a7457dc42cc39f283 SHA512 8e15e866c2cb62f9021042ef4cf3e3a7e97f9da38681f8210ddd6d3e4df05f85bae4285dd02302fadce9973aafa8c49e7c7d9c4231eb2b2fff7d17e2e9222e67
MISC metadata.xml 981 BLAKE2B 70fbbfade9dbd7f8d24b2c871a5667fe6028e0cf8c51b76dc574d089c42bb61f0f845d3a065c1c8264312fc938d3cb4e57d5e88bda945b3337df37c2941a32e1 SHA512 1928a628e949a7a383a52d3a35751002ae3c37da973978347dff8a422c92e283e3e1dbef345e6557344a2d1884180f3f295d88634d80096184842cc08553923b
diff --git a/app-misc/digitemp/digitemp-3.7.1.ebuild b/app-misc/digitemp/digitemp-3.7.1.ebuild
index 01e1ebe0ca3a..65431c4aae4f 100644
--- a/app-misc/digitemp/digitemp-3.7.1.ebuild
+++ b/app-misc/digitemp/digitemp-3.7.1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit toolchain-funcs
@@ -9,10 +9,10 @@ DESCRIPTION="Temperature logging and reporting using Maxim's iButtons and 1-Wire
HOMEPAGE="https://www.digitemp.com/ https://www.ibutton.com/"
SRC_URI="https://github.com/bcl/digitemp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-IUSE="ds9097 ds9097u ds2490"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="amd64 x86"
+IUSE="ds9097 ds9097u ds2490"
DEPEND="ds2490? ( virtual/libusb:0 )"
@@ -21,6 +21,7 @@ targets() {
if ! ( use ds9097 || use ds9097u || use ds2490 ); then
echo ds9097u
fi
+
for target in ds9097 ds9097u ds2490; do
if use ${target}; then
echo ${target}
@@ -29,8 +30,13 @@ targets() {
}
src_prepare() {
- sed -i -e "/^CFLAGS/s:-O2:${CFLAGS}:" \
- -e "/^LIBS/s:=:= ${LDFLAGS}:" Makefile
+ default
+
+ sed -i \
+ -e "/^CFLAGS/s:-O2:${CFLAGS}:" \
+ -e "/^LIBS/s:=:= ${LDFLAGS}:" \
+ Makefile || die
+
# default is to compile to the ds9097u.
if ! ( use ds9097 || use ds9097u || use ds2490 ); then
ewarn "If you don't choose a component to install, we default to ds9097u"
@@ -40,9 +46,9 @@ src_prepare() {
src_compile() {
local targets=$(targets)
- for target in $targets; do
+ for target in ${targets}; do
emake clean
- emake CC="$(tc-getCC)" LOCK="no" ${target}
+ emake CC="$(tc-getCC)" LOCK="no" ${target}
done
}
@@ -53,23 +59,19 @@ src_install() {
done
if [[ $(targets|wc -l) -ge 1 ]]; then
- echo
ewarn "/usr/bin/digitemp has been symlinked to /usr/bin/digitemp_${target}"
ewarn "If you want to access the others, they are available at /usr/bin/digitemp_*"
- echo
fi
dodoc README FAQ TODO
for example in perl python rrdb; do
- insinto "/usr/share/doc/${PF}/${example}_examples"
- doins -r ${example}/*
+ docinto ${example}_examples
+ dodoc -r ${example}/*
done
}
pkg_postinst() {
- echo
elog "Examples of using digitemp with python, perl, and rrdtool are"
elog "located in /usr/share/doc/${PF}/"
- echo
}