summaryrefslogtreecommitdiff
path: root/app-misc/digitemp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /app-misc/digitemp
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'app-misc/digitemp')
-rw-r--r--app-misc/digitemp/Manifest2
-rw-r--r--app-misc/digitemp/digitemp-3.7.2.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/app-misc/digitemp/Manifest b/app-misc/digitemp/Manifest
index 3a1159bb0f49..6550f5b3c124 100644
--- a/app-misc/digitemp/Manifest
+++ b/app-misc/digitemp/Manifest
@@ -1,3 +1,5 @@
DIST digitemp-3.7.1.tar.gz 144870 BLAKE2B 5d00197ba0122772d96c3185f430119961d214f50dc07dcd5881e1aa1135283680ff38b4d92736827f5c7644b11930b9418b8467f276e832e40f4228d08d1774 SHA512 e5eaf576b544c61049a358dece7dc96d9793b751ef08645060f3b2c1a2006e2906c3aa3f97de3dab46818290d664d2e784a948b2495b538a200b6d71b03173d2
+DIST digitemp-3.7.2.tar.gz 146166 BLAKE2B 9718e5d8a135e99cfd8893f5f4d2cc40a0bcdffa4e01c4ef460d654b38d9808c75ea1efced6211672033a67be8ba7f30f34320ef8e64d47d8a88be8bbac8c997 SHA512 807934ecc743df5ee69e9a8a0f5e90e469f03e577cc80b4510e6ac4ecc61ff9c79e05642602a4f50b4acda7e1f53e33016e6c201898ab0b44c76f3f7ac028820
EBUILD digitemp-3.7.1.ebuild 1787 BLAKE2B eab478eaee2516bee1c1282816cb4fec4042ad39b2e6ae866aa198527ddf0e1e8011078435dcd353022b4d3070da6873f0d62534e471276a7457dc42cc39f283 SHA512 8e15e866c2cb62f9021042ef4cf3e3a7e97f9da38681f8210ddd6d3e4df05f85bae4285dd02302fadce9973aafa8c49e7c7d9c4231eb2b2fff7d17e2e9222e67
+EBUILD digitemp-3.7.2.ebuild 1789 BLAKE2B bad0015092bcbbe59decc21ade8562c30ce3b0247788a4137d4521342623eb76d8753e8b006a4531033e0b58458982ab9b32a3abddc1cdc604a91f1e0ebfd709 SHA512 c3dfbce91844ac5b9639b44f4f7c22155b905197a2e861f3648e546b2fb857df27ee6b66fad77275443443b3ded1ee5763ce70c9a776a7a4f1f9bfda0ef5993c
MISC metadata.xml 982 BLAKE2B c76e77aba3cbd377a3459302669c327abda9b437c659149c768d0d7d8a791210302115b403df09c3802a5af0bee3370e8ee6cd18306d8d29e80d56eafc391cbc SHA512 abb3db43dce3e259defefccdb71fffa2cdbb8fc21149cc1167b04c71b854e0dbbf1996f32293d4369aa9af0131e01a12fc57a4156514e956272f1ee8f9cf0606
diff --git a/app-misc/digitemp/digitemp-3.7.2.ebuild b/app-misc/digitemp/digitemp-3.7.2.ebuild
new file mode 100644
index 000000000000..c2fd1c941d08
--- /dev/null
+++ b/app-misc/digitemp/digitemp-3.7.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Temperature logging and reporting using Maxim's iButtons and 1-Wire protocol"
+HOMEPAGE="https://www.digitemp.com/ https://www.ibutton.com/"
+SRC_URI="https://github.com/bcl/digitemp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="ds9097 ds9097u ds2490"
+
+DEPEND="ds2490? ( virtual/libusb:0 )"
+
+targets() {
+ # default is to compile to the ds9097u.
+ if ! ( use ds9097 || use ds9097u || use ds2490 ); then
+ echo ds9097u
+ fi
+
+ for target in ds9097 ds9097u ds2490; do
+ if use ${target}; then
+ echo ${target}
+ fi
+ done
+}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "/^CFLAGS/s:-O2:${CFLAGS}:" \
+ -e "/^LIBS/s:=:= ${LDFLAGS}:" \
+ Makefile || die
+
+ # default is to compile to the ds9097u.
+ if ! ( use ds9097 || use ds9097u || use ds2490 ); then
+ ewarn "If you don't choose a component to install, we default to ds9097u"
+ fi
+}
+
+src_compile() {
+ local targets=$(targets)
+
+ for target in ${targets}; do
+ emake clean
+ emake CC="$(tc-getCC)" LOCK="no" ${target}
+ done
+}
+
+src_install() {
+ for target in $(echo $(targets) | tr '[:lower:]' '[:upper:]'); do
+ dobin digitemp_${target} && \
+ dosym digitemp_${target} /usr/bin/digitemp
+ done
+
+ if [[ $(targets|wc -l) -ge 1 ]]; then
+ ewarn "/usr/bin/digitemp has been symlinked to /usr/bin/digitemp_${target}"
+ ewarn "If you want to access the others, they are available at /usr/bin/digitemp_*"
+ fi
+
+ dodoc README FAQ TODO
+
+ for example in perl python rrdb; do
+ docinto ${example}_examples
+ dodoc -r ${example}/*
+ done
+}
+
+pkg_postinst() {
+ elog "Examples of using digitemp with python, perl, and rrdtool are"
+ elog "located in /usr/share/doc/${PF}/"
+}