summaryrefslogtreecommitdiff
path: root/app-misc/devtodo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-27 00:07:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-27 00:07:23 +0100
commit3c1648a0749c1d66b300d857e6b417c1162890da (patch)
tree2b13f04c2c10d472e5bb7cc40fe6048bf8bc549d /app-misc/devtodo
parent994fe442814c4d169bb0f1ee9745604928006b39 (diff)
gentoo auto-resync : 27:05:2024 - 00:07:23
Diffstat (limited to 'app-misc/devtodo')
-rw-r--r--app-misc/devtodo/Manifest1
-rw-r--r--app-misc/devtodo/devtodo-0.1.20-r4.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-misc/devtodo/Manifest b/app-misc/devtodo/Manifest
index 3d41c1566388..fd3ef18f1862 100644
--- a/app-misc/devtodo/Manifest
+++ b/app-misc/devtodo/Manifest
@@ -4,4 +4,5 @@ AUX devtodo-0.1.20-gentoo.patch 3167 BLAKE2B 505d6b85188f2bedc08d2192455a64f49a7
AUX devtodo.bash-completion 1424 BLAKE2B 10166a35074d1f501d76a0f60e383c6f6198242b4c22ae2b17468f887e2d6caa2466bbfae290d76cf8199156703591633aaa755298c7ebcd1274faa09656a369 SHA512 6139218a2bc4d06f2af23fc04247e8fa3d70eaf3affe326dbb8b1bbbb880f2534f1c1bf4c54079231bed7c1c64465705deb5a5cb1a0f4ca5415ccddae726b20b
DIST devtodo-0.1.20.tar.gz 390935 BLAKE2B 1605fb6ae6f416ea9b7c072463aacedf7fe997a362b3188addce9c6fbdd9bf99f2f7d4524870fb09f0a0c29e9886011a8fae737388a3151ecc489f3fe4fec980 SHA512 58cff0455c735af4530fc9321d1eade8272dd5759eeb8a688a641c9be11830b87be116801e3cd1d90a27e070775fa00d7b4d6b3399eba7aad5c752bfda9c28fb
EBUILD devtodo-0.1.20-r3.ebuild 1614 BLAKE2B 5097efa46020c1609c8e14f76b574b1aab54f1359cc82b3cb9d3b36dfcef46ac313cbae0d0af7707b207c047bca53759911c89362c87d4a07ca0285ab660a839 SHA512 6c164a27e4cefd1df85c5704f71f8d61d81b4336cba06deb9c8789a01c634eb71bbd18a57bb596163c4a02067f2b05ff6739f8e29aa7ac558f0d64c6e2a5a6cc
+EBUILD devtodo-0.1.20-r4.ebuild 1638 BLAKE2B a0725f61b0d6bc36c3b0e1a481db69a0acbe7f8faf9bc7bcbef68fb560098981a2e5efc8700a9c234c798ceeb696f8a10c1da17d064d4ff044fb55ca8f65d9fc SHA512 983ef71861952e5913ef31215f64691531dacede67536baffc86dbf1ea9172e2c671cb1ff7a06ad244673cd452e22b62f02ca01f610bd4eb357e069a94b27b56
MISC metadata.xml 272 BLAKE2B a253052dbe7dfd2dea2cdc3692698a5a94d0e2414979a348d56448cee6329b7fe29a1f252146f9ff04c1ea3b270996631395ecea454ac901eb726dc0b4dd9f29 SHA512 247c1006dd352c3cc7ee07dee2f283394767bdc0f72f0438a6cc845ac53549c05b3741c64ffedb992f003759e67f24aaa7121561db97d1b095c11269115746dc
diff --git a/app-misc/devtodo/devtodo-0.1.20-r4.ebuild b/app-misc/devtodo/devtodo-0.1.20-r4.ebuild
new file mode 100644
index 000000000000..9a089f102981
--- /dev/null
+++ b/app-misc/devtodo/devtodo-0.1.20-r4.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools bash-completion-r1 flag-o-matic toolchain-funcs
+
+DESCRIPTION="Hierarchical command-line task manager"
+HOMEPAGE="https://swapoff.org/devtodo1.html"
+SRC_URI="https://swapoff.org/files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ >=sys-libs/ncurses-5.2:0=
+ >=sys-libs/readline-4.1:0="
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog QuickStart README doc/scripts.sh doc/scripts.tcsh doc/todorc.example )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-bashcom_spaces.patch
+)
+
+src_prepare() {
+ default
+
+ mv configure.{in,ac} || die
+
+ # fix regex.h issue on case-insensitive file-systems #332235
+ sed \
+ -e 's/Regex.h/DTRegex.h/' \
+ -i util/Lexer.h util/Makefile.{am,in} util/Regex.cc || die
+ mv util/{,DT}Regex.h || die
+
+ sed \
+ -e "/^LIBS/s:$: $($(tc-getPKG_CONFIG) --libs ncurses):g" \
+ -i src/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ replace-flags -O[23] -O1
+
+ local myeconfargs=(
+ --sysconfdir="${EPREFIX}/etc/devtodo"
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ newbashcomp contrib/${PN}.bash-completion ${PN}
+ rm contrib/${PN}.bash-completion || die 'rm failed'
+
+ bashcomp_alias devtodo tda tdd tde tdr todo
+
+ dodoc -r contrib
+}
+
+pkg_postinst() {
+ elog "Because of a conflict with app-misc/tdl, the tdl symbolic link"
+ elog "and manual page have been removed."
+}