summaryrefslogtreecommitdiff
path: root/app-misc/detachtty
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-08 09:27:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-08 09:27:00 +0100
commitafdfa05c5ce824f49340d033a80cdee422ac264a (patch)
treee0d45d2626035a2af2187a8359cd122dd9d4a21b /app-misc/detachtty
parent6cefebc8e850c862f7623af22feef1b895a79884 (diff)
gentoo auto-resync : 08:08:2023 - 09:27:00
Diffstat (limited to 'app-misc/detachtty')
-rw-r--r--app-misc/detachtty/Manifest4
-rw-r--r--app-misc/detachtty/detachtty-11.0.0-r1.ebuild30
-rw-r--r--app-misc/detachtty/files/detachtty-11.0.0-clang16-build-fix.patch43
-rw-r--r--app-misc/detachtty/metadata.xml3
4 files changed, 79 insertions, 1 deletions
diff --git a/app-misc/detachtty/Manifest b/app-misc/detachtty/Manifest
index 0b4bf6bb8f2d..9a924ac8d95a 100644
--- a/app-misc/detachtty/Manifest
+++ b/app-misc/detachtty/Manifest
@@ -1,4 +1,6 @@
+AUX detachtty-11.0.0-clang16-build-fix.patch 810 BLAKE2B 9583e3c87803b78ffba6d86cf3786be0eacca2a186d6e5fd612157355ae22003d28139b541ef96de3342c7560ca4accda9ea62fd4f40a0f63bca97404993e4c9 SHA512 6ba2ba204097e756609c2c9af17b53a49d87cc45ab2a79d3fa775367ffc6920acba8c4c5f5760a3bf567dd961f1b41b79abefaad8db238dbab69fc812727babe
AUX detachtty-11.0.0-sparc.patch 2669 BLAKE2B c1912520e5e7388bd905059a0d3f0d28726533884c4eafa89b1f6800feb2e05740dd96ee0b501f76d4f2329cf0e49b7b349d6990e12c359be13615f84e77670b SHA512 b62b7f809d79ba8f391f4f3b0c84eb969884b9de1f8ef27a50e1af84f6fe6f699c17321a6f4b225ae8c64d463c090a1bb5d105bf450a01aec4ccf8bb189449f5
DIST detachtty-11.0.0.tar.gz 23189 BLAKE2B 734489fe35acb5bfb381b8fee1b91d60f15ec795f2ba58f5855544d913957f7da4174c15583dc4090e397c5f562e78a23c1534a741a9812980f4a9cd2d2e291e SHA512 608d68ebe9b8fae55b4295b9c50d8e9065226dbb78818535af79bd2e70cc4a831820b6c673414289548b1063843b5dc80c8b7d2371dd716a16eceb20cd064a10
+EBUILD detachtty-11.0.0-r1.ebuild 681 BLAKE2B 61382cb119e896487f13e974751c3a0b7f258c717f1595bfb5167f0c96f795b6d5fe5cfe13a5f6761ab4bc0b758f9eb15c3f330ce4631ca42612f167e0c723bd SHA512 70ffe9f2a4d6f4f683a546367797997951551a942c3f8a31b54f2682af019976b10a707347c4df16b3a9b5685af26d8901ba411460197e048df26ede575a00e7
EBUILD detachtty-11.0.0.ebuild 632 BLAKE2B 0a118db31a6f4dc05bb848f53d1949728deaa4956458bd9ca0848f16e49516605bc0a7e2ed494d090a16c3b6f6d6a6096ff0533059cb69df6fb4b9d83108a1c8 SHA512 6cdbf7fcfb37ec030344cf6ac68b544bbe8f68bad4fefde6f565c85a7ccc9cea6c825a09c0cd96bf7c6539c4019c665548d4a9971a81e2a00ea504417ca55b2f
-MISC metadata.xml 722 BLAKE2B 37cae352305296b27699d3259b62de49d3e418e3d10edd854ff9f8ad8eb1aef245242bdf386e300d0426d21f184c8c5d64fe4eec7ffa7de4a6e156b5d0b0294f SHA512 07d6b9a618776747b6cdaa0d80abd0e8ad2d7dee3314ef16609aea1bfad9cc98acfa86879b02b53e98a1f3adf87b8a8790563761d39d0899d377a699f89588e1
+MISC metadata.xml 805 BLAKE2B 7414ac0367f4111cd0e453909bcc8ea89b921f0ef5c4bed76bf8751f2965eff639c1d0122605fe9e1383d16df8002f5235f0196cec6b8fe879c36e65c25a2a23 SHA512 311aec96e3feda42a65a924c56107f6e0b303e8bd1f702ca73557dbaeb6499cdc5bc062c5794a89c618312e558e66e4b0e9ff42d0667ccdd13389d92a353906f
diff --git a/app-misc/detachtty/detachtty-11.0.0-r1.ebuild b/app-misc/detachtty/detachtty-11.0.0-r1.ebuild
new file mode 100644
index 000000000000..48a44f103550
--- /dev/null
+++ b/app-misc/detachtty/detachtty-11.0.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Attach/detach from interactive processes across the network"
+HOMEPAGE="https://github.com/cosmos72/detachtty"
+SRC_URI="https://github.com/cosmos72/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${P}-sparc.patch"
+ "${FILESDIR}/${P}-clang16-build-fix.patch"
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin attachtty detachtty
+ doman "${PN}.1"
+ dosym detachtty.1 /usr/share/man/man1/attachtty.1
+ einstalldocs
+}
diff --git a/app-misc/detachtty/files/detachtty-11.0.0-clang16-build-fix.patch b/app-misc/detachtty/files/detachtty-11.0.0-clang16-build-fix.patch
new file mode 100644
index 000000000000..62a3cc1c3eb1
--- /dev/null
+++ b/app-misc/detachtty/files/detachtty-11.0.0-clang16-build-fix.patch
@@ -0,0 +1,43 @@
+Bug: https://bugs.gentoo.org/894544
+Upstream PR: https://github.com/cosmos72/detachtty/pull/6
+--- a/attachtty.c
++++ b/attachtty.c
+@@ -22,6 +22,7 @@
+
+ #include <errno.h>
+ #include <time.h>
++#include <string.h>
+
+ #include "config.h"
+
+--- a/config.h
++++ b/config.h
+@@ -24,7 +24,7 @@
+ #define DETACHTTY_CONFIG_H
+
+ #include <netdb.h>
+-#include <sys/poll.h>
++#include <poll.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <sys/un.h>
+--- a/copy-stream.c
++++ b/copy-stream.c
+@@ -23,6 +23,7 @@
+ #include <errno.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
++#include <string.h>
+
+ #include "config.h"
+
+--- a/detachtty.c
++++ b/detachtty.c
+@@ -26,6 +26,7 @@
+ #include <sys/stat.h>
+ #include <pty.h>
+ #include <fcntl.h>
++#include <string.h>
+
+ #ifndef UNIX_PATH_MAX
+ # define UNIX_PATH_MAX 108
diff --git a/app-misc/detachtty/metadata.xml b/app-misc/detachtty/metadata.xml
index 42ebc5a05cc5..583880214955 100644
--- a/app-misc/detachtty/metadata.xml
+++ b/app-misc/detachtty/metadata.xml
@@ -15,4 +15,7 @@
concept to GNU Screen but is better suited toward scrolling interfaces (not
full-screen, random-access based applications).
</longdescription>
+ <upstream>
+ <remote-id type="github">cosmos72/detachtty</remote-id>
+ </upstream>
</pkgmetadata>