summaryrefslogtreecommitdiff
path: root/app-misc/detachtty
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/detachtty
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/detachtty')
-rw-r--r--app-misc/detachtty/Manifest3
-rw-r--r--app-misc/detachtty/detachtty-9-r1.ebuild27
-rw-r--r--app-misc/detachtty/metadata.xml18
3 files changed, 48 insertions, 0 deletions
diff --git a/app-misc/detachtty/Manifest b/app-misc/detachtty/Manifest
new file mode 100644
index 000000000000..4a91d5090cf1
--- /dev/null
+++ b/app-misc/detachtty/Manifest
@@ -0,0 +1,3 @@
+DIST detachtty_9.tar.gz 13081 BLAKE2B 28bb6a946d04717bc60ac7f65b791a8bb59a5ce1a2f7d7fabb63776538ade3fe046e874007effe7dd6ba7ebac8d739e16b0b0e2372ce4154385164d7939b498c SHA512 8ae7edc1a1c7727eb4d32a1a4327932e374ac838b441f34aee99cfe83e922f1d70383ab0aab2299808f28fea6229f5c122a7624b7ff992ab92b9c3f53483d035
+EBUILD detachtty-9-r1.ebuild 600 BLAKE2B 26747aa2903250488781353bcf93ecb0f66b086e63a691cd84725f3e9b7e7717927509aada2d64b017ca4a12c6cafb0c566ea7cf354b076c8a88032d8b6f0315 SHA512 4902bab8a023b424d9d6f1d583ab431b50375e878d0ed5e7e08840a762e4176dd56c681e632b01fb8a0bd20220c254af0b945561cbf272f5bdeae1f6a0759cda
+MISC metadata.xml 703 BLAKE2B 68c8ac450ee3a0fba9c9e217653526978c03635b843e9068f6c6e0937d927a030d78a9683f11f81273aaabb8c94f039f1211a1cc5b5ec58b2126d1ffdecc281e SHA512 00e9860010346c6dbad86cd3dd2eaea29f1e91df559b7f5b7dd634a48a0875830a46cab665efd3e3e87eafd6566ecec6ed6e4a691fdc48ebea327f527a312794
diff --git a/app-misc/detachtty/detachtty-9-r1.ebuild b/app-misc/detachtty/detachtty-9-r1.ebuild
new file mode 100644
index 000000000000..889f3998d57b
--- /dev/null
+++ b/app-misc/detachtty/detachtty-9-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+MY_P="${P/-/_}"
+
+DESCRIPTION="Attach/detach from interactive processes across the network"
+HOMEPAGE="https://packages.debian.org/unstable/admin/detachtty"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin "${PN}" attachtty
+ doman "${PN}.1"
+ dosym detachtty.1 /usr/share/man/man1/attachtty.1
+ einstalldocs
+}
diff --git a/app-misc/detachtty/metadata.xml b/app-misc/detachtty/metadata.xml
new file mode 100644
index 000000000000..d83290efbddf
--- /dev/null
+++ b/app-misc/detachtty/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Shell Tools Project</name>
+</maintainer>
+<maintainer type="project">
+ <email>common-lisp@gentoo.org</email>
+ <name>Gentoo Common Lisp Project</name>
+</maintainer>
+<longdescription>
+detachtty is a utility that lets you run interactive programs non-interactively.
+Reattaching can be done locally or over the network. detachtty is similar in
+concept to GNU Screen but is better suited toward scrolling interfaces (not
+full-screen, random-access based applications).
+</longdescription>
+</pkgmetadata>