summaryrefslogtreecommitdiff
path: root/app-misc/ddccontrol/ddccontrol-0.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-13 06:46:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-13 06:46:47 +0000
commitafb19abe0ec73761b4e330ee952a19e98d4bc7e3 (patch)
treec831ae0927550faddb9a37c12b33f38c1b376073 /app-misc/ddccontrol/ddccontrol-0.6.0.ebuild
parent360468f13add58583c7780bcacafb5452a07851d (diff)
gentoo auto-resync : 13:03:2024 - 06:46:47
Diffstat (limited to 'app-misc/ddccontrol/ddccontrol-0.6.0.ebuild')
-rw-r--r--app-misc/ddccontrol/ddccontrol-0.6.0.ebuild89
1 files changed, 0 insertions, 89 deletions
diff --git a/app-misc/ddccontrol/ddccontrol-0.6.0.ebuild b/app-misc/ddccontrol/ddccontrol-0.6.0.ebuild
deleted file mode 100644
index 5324da6ba848..000000000000
--- a/app-misc/ddccontrol/ddccontrol-0.6.0.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools
-
-DESCRIPTION="Control monitor parameters, like brightness, contrast, RGB color levels via DDC"
-HOMEPAGE="https://github.com/ddccontrol/ddccontrol/"
-SRC_URI="https://github.com/ddccontrol/ddccontrol/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc gtk nls +pci static-libs"
-
-# Upstream doesn't seem to care about tests: failures for lack of translations,
-# and no real test targets.
-RESTRICT='test'
-
-RDEPEND="app-misc/ddccontrol-db
- dev-libs/glib:2
- dev-libs/libxml2:2
- app-arch/xz-utils
- gtk? (
- dev-libs/atk
- media-libs/fontconfig
- media-libs/freetype
- media-libs/harfbuzz:=
- x11-libs/cairo
- x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:2
- x11-libs/pango
- )
- pci? ( sys-apps/pciutils )"
-DEPEND="${RDEPEND}"
-BDEPEND="dev-perl/XML-Parser
- dev-util/gdbus-codegen
- dev-util/intltool
- sys-kernel/linux-headers
- doc? (
- >=app-text/docbook-xsl-stylesheets-1.65.1
- app-text/htmltidy
- >=dev-libs/libxslt-1.1.6
- )
- nls? ( sys-devel/gettext )"
-
-src_prepare() {
- # ppc/ppc64 do not have inb/outb/ioperm
- # they also do not have (sys|asm)/io.h
- if ! use amd64 && ! use x86 ; then
- local card
- for card in sis intel810 ; do
- sed -r -i \
- -e "/${card}.Po/d" \
- -e "s~${card}[^[:space:]]*~ ~g" \
- src/ddcpci/Makefile.{am,ini} || die
- done
- sed -i \
- -e '/sis_/d' \
- -e '/i810_/d' \
- src/ddcpci/main.c || die
- fi
-
- default
-
- ## Save for a rainy day or future patching
- touch config.rpath ABOUT-NLS
- eautoreconf
- intltoolize --force || die "intltoolize failed"
-}
-
-src_configure() {
- # amdadl broken, bug #527268
- econf \
- --htmldir='$(datarootdir)'/doc/${PF}/html \
- --disable-gnome-applet \
- --disable-amdadl \
- $(use_enable doc) \
- $(use_enable gtk gnome) \
- $(use_enable nls) \
- $(use_enable pci ddcpci) \
- $(use_enable static-libs static)
-}
-
-src_install() {
- default
- use static-libs || find "${ED}" -name '*.la' -delete
-}