summaryrefslogtreecommitdiff
path: root/app-misc/ddccontrol/ddccontrol-0.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /app-misc/ddccontrol/ddccontrol-0.6.0.ebuild
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'app-misc/ddccontrol/ddccontrol-0.6.0.ebuild')
-rw-r--r--app-misc/ddccontrol/ddccontrol-0.6.0.ebuild85
1 files changed, 85 insertions, 0 deletions
diff --git a/app-misc/ddccontrol/ddccontrol-0.6.0.ebuild b/app-misc/ddccontrol/ddccontrol-0.6.0.ebuild
new file mode 100644
index 000000000000..fe92023703fc
--- /dev/null
+++ b/app-misc/ddccontrol/ddccontrol-0.6.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Control monitor parameters, like brightness, contrast, RGB color levels via DDC"
+HOMEPAGE="http://ddccontrol.sourceforge.net/"
+SRC_URI="https://github.com/ddccontrol/ddccontrol/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc gtk nls +pci static-libs"
+
+RDEPEND="app-misc/ddccontrol-db
+ dev-libs/glib:2
+ dev-libs/libxml2:2
+ app-arch/xz-utils
+ gtk? (
+ dev-libs/atk
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/harfbuzz:=
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/pango
+ )
+ pci? ( sys-apps/pciutils )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-perl/XML-Parser
+ dev-util/gdbus-codegen
+ dev-util/intltool
+ sys-kernel/linux-headers
+ doc? (
+ >=app-text/docbook-xsl-stylesheets-1.65.1
+ app-text/htmltidy
+ >=dev-libs/libxslt-1.1.6
+ )
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ # ppc/ppc64 do not have inb/outb/ioperm
+ # they also do not have (sys|asm)/io.h
+ if ! use amd64 && ! use x86 ; then
+ local card
+ for card in sis intel810 ; do
+ sed -r -i \
+ -e "/${card}.Po/d" \
+ -e "s~${card}[^[:space:]]*~ ~g" \
+ src/ddcpci/Makefile.{am,ini} || die
+ done
+ sed -i \
+ -e '/sis_/d' \
+ -e '/i810_/d' \
+ src/ddcpci/main.c || die
+ fi
+
+ default
+
+ ## Save for a rainy day or future patching
+ touch config.rpath ABOUT-NLS
+ eautoreconf
+ intltoolize --force || die "intltoolize failed"
+}
+
+src_configure() {
+ # amdadl broken, bug #527268
+ econf \
+ --htmldir='$(datarootdir)'/doc/${PF}/html \
+ --disable-gnome-applet \
+ --disable-amdadl \
+ $(use_enable doc) \
+ $(use_enable gtk gnome) \
+ $(use_enable nls) \
+ $(use_enable pci ddcpci) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}" -name '*.la' -delete
+}