summaryrefslogtreecommitdiff
path: root/app-misc/datefudge/datefudge-1.24.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /app-misc/datefudge/datefudge-1.24.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'app-misc/datefudge/datefudge-1.24.ebuild')
-rw-r--r--app-misc/datefudge/datefudge-1.24.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/datefudge/datefudge-1.24.ebuild b/app-misc/datefudge/datefudge-1.24.ebuild
new file mode 100644
index 000000000000..ade713b8eb6f
--- /dev/null
+++ b/app-misc/datefudge/datefudge-1.24.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="A program (and preload library) to fake system date"
+HOMEPAGE="https://packages.qa.debian.org/d/datefudge.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 arm arm64 hppa ~ia64 ~m68k ~mips ~ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/dpkg-parsechangelog/d' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" libdir="/usr/$(get_libdir)" VERSION="${PV}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" CC="$(tc-getCC)" libdir="/usr/$(get_libdir)" install
+ einstalldocs
+}