summaryrefslogtreecommitdiff
path: root/app-misc/cw/cw-1.0.16-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/cw/cw-1.0.16-r3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/cw/cw-1.0.16-r3.ebuild')
-rw-r--r--app-misc/cw/cw-1.0.16-r3.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/app-misc/cw/cw-1.0.16-r3.ebuild b/app-misc/cw/cw-1.0.16-r3.ebuild
new file mode 100644
index 000000000000..5a667b143f95
--- /dev/null
+++ b/app-misc/cw/cw-1.0.16-r3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A non-intrusive real-time ANSI color wrapper for common unix-based commands"
+HOMEPAGE="http://cwrapper.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cwrapper/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-ldflags.patch \
+ "${FILESDIR}"/${PV}-path.patch \
+ "${FILESDIR}"/${PV}-collision.patch \
+ "${FILESDIR}"/${PV}-format-security.patch
+ tc-export CC
+}
+
+src_compile() {
+ emake local
+}
+
+src_install() {
+ insinto /usr/share/cw
+ doins etc/*
+
+ exeinto /usr/libexec/cw
+ doexe def/*
+
+ doman man/cwu*
+ newman man/cw.* color-wrapper
+ dodoc CHANGES CONTRIB INSTALL README PLATFORM doc/README*
+
+ dobin bin/{cwu,colorcfg}
+ # app-misc/color currently conflicts; hopefully 'colors' is safe
+ newbin bin/color colors
+ # media-radio/unixcw currently conflicts;
+ newbin bin/cw color-wrapper
+}
+
+pkg_postinst() {
+ ebegin "Updating definition files"
+ cwu /usr/libexec/cw /usr/bin/color-wrapper # >/dev/null
+ eend $?
+
+ elog "To enable color-wrapper, as your user, run:"
+ elog " colorcfg [1|2|3]"
+ elog "to add relevant environment variables to your ~/.bash_profile"
+ elog "Run colorcfg without options to see what [1|2|3] means."
+ elog
+ elog "After sourcing your ~/.bash_profile, commands for which definitions"
+ elog "are provided should have colored output."
+ elog
+ elog "To enable/disable colored output, run: 'colors [on|off]'."
+}