summaryrefslogtreecommitdiff
path: root/app-misc/cpipe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/cpipe
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/cpipe')
-rw-r--r--app-misc/cpipe/Manifest3
-rw-r--r--app-misc/cpipe/cpipe-3.0.3.ebuild32
-rw-r--r--app-misc/cpipe/metadata.xml11
3 files changed, 46 insertions, 0 deletions
diff --git a/app-misc/cpipe/Manifest b/app-misc/cpipe/Manifest
new file mode 100644
index 000000000000..a89821a1902b
--- /dev/null
+++ b/app-misc/cpipe/Manifest
@@ -0,0 +1,3 @@
+DIST cpipe-3.0.3.tar.gz 16392 BLAKE2B 6aadb1b186bbf9aa5d804ca719baaff662116084c1e24c9fac38526e8fd190421189dfb02787f430dd0997b3b1bcba41ba002630a324e508190a0b6bd6b0af91 SHA512 255e3833ddaf27af1768e650a47d0565224ddd22137636ae0fae491a4d03f523b74a76f26b261c71442a7509f42eee64b75fbcf7078641a64b66a2590bb803b3
+EBUILD cpipe-3.0.3.ebuild 649 BLAKE2B 681dbcee08f62a22faf8e5202815d776870923ff5d5e221f034e2ba3c20bdd5e784375ad31f361c5b76322e8809be240b94c39e7893de68dc7e1cf1b3983de2a SHA512 d5664f0b059e092f0e4ca41e8aaf630cbabab2a07c25616b550069355d6570c35737aca7c4211c37943be15a6b968348eed2c43c8b8e71ddcc7a8e481789bd0b
+MISC metadata.xml 330 BLAKE2B ae60f1e0f28436199a2f72cdb7ec2714258a8ba42eca5bee81c54bf3cfdbcaf04f450c737897242d064c611947124b8865d6b2720eea1eaca4e8643a8fd09e9c SHA512 5d888afdae9cd65ef26799a4c311dd11bbe8cbea93d6e8ba4e92086cce3df5708be39ea4c20a1ea0bd76d9e06846dd1f48af120f0812f4be75e9ae1f43e669bb
diff --git a/app-misc/cpipe/cpipe-3.0.3.ebuild b/app-misc/cpipe/cpipe-3.0.3.ebuild
new file mode 100644
index 000000000000..1f656dc38a49
--- /dev/null
+++ b/app-misc/cpipe/cpipe-3.0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Counting pipe, measures data transfered over pipe"
+HOMEPAGE="https://github.com/HaraldKi/cpipe"
+SRC_URI="https://github.com/HaraldKi/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s/CFLAGS =/CFLAGS =${CFLAGS} /" \
+ -e "s/-lm/-lm ${LDFLAGS}/" \
+ -e "s/744/644/" makefile || die "sed failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+}
diff --git a/app-misc/cpipe/metadata.xml b/app-misc/cpipe/metadata.xml
new file mode 100644
index 000000000000..449e6b0b1299
--- /dev/null
+++ b/app-misc/cpipe/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">HaraldKi/cpipe</remote-id>
+ </upstream>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ <name>Patrice Clement</name>
+ </maintainer>
+</pkgmetadata>