summaryrefslogtreecommitdiff
path: root/app-misc/cpipe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-01 03:14:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-01 03:14:33 +0100
commit0c764edfecb7e9e124d4669acd98bed09e23b6c0 (patch)
tree2862ab17d2f88cb7c9614b7fbe579f25ae604b8d /app-misc/cpipe
parentae1bf373db295b495e1f685d116e3411bf10df0b (diff)
gentoo auto-resync : 01:08:2022 - 03:14:32
Diffstat (limited to 'app-misc/cpipe')
-rw-r--r--app-misc/cpipe/Manifest3
-rw-r--r--app-misc/cpipe/cpipe-3.0.3-r1.ebuild (renamed from app-misc/cpipe/cpipe-3.0.3.ebuild)23
-rw-r--r--app-misc/cpipe/files/cpipe-3.0.3-makefile.patch29
3 files changed, 40 insertions, 15 deletions
diff --git a/app-misc/cpipe/Manifest b/app-misc/cpipe/Manifest
index e40f39877e4d..8e32347ee09f 100644
--- a/app-misc/cpipe/Manifest
+++ b/app-misc/cpipe/Manifest
@@ -1,3 +1,4 @@
+AUX cpipe-3.0.3-makefile.patch 740 BLAKE2B f8d06251e55a628dbf8c350add2fe06847ac9fea43f3b2270518c694adcf7e31a2acf7e91efcc9208cc6d4435c014f60db78eb9e43cd38584ff187625186ded9 SHA512 59ffd761f78fb22cf635797ed569bed96a396360ecadebe90ba922d241f3ecc94a033b6c7d6be8922845e872fbee07168699a5cdc831cc4351c27589cc2f16cb
DIST cpipe-3.0.3.tar.gz 16392 BLAKE2B 6aadb1b186bbf9aa5d804ca719baaff662116084c1e24c9fac38526e8fd190421189dfb02787f430dd0997b3b1bcba41ba002630a324e508190a0b6bd6b0af91 SHA512 255e3833ddaf27af1768e650a47d0565224ddd22137636ae0fae491a4d03f523b74a76f26b261c71442a7509f42eee64b75fbcf7078641a64b66a2590bb803b3
-EBUILD cpipe-3.0.3.ebuild 644 BLAKE2B c29c211536ec43791fcad22570821d96e1bd57900e9c7fbd2037cf331246d877f19fb5acbe760029fc28f5190984288dd49372f8750ff5bfbc8d658471d379ab SHA512 dc9b5aa72edc885a9c904a86dc56a7dc17c22e861334ed0632a52fc54ca808bab8e0b054550f66c5a8aa1f50d99ea15cb82c890dddbe1656d0e416c08cf3c54a
+EBUILD cpipe-3.0.3-r1.ebuild 518 BLAKE2B 6828572e1c6d5507bd6a84f4e695c995b282bdb55a6c947695f7a2d70b47adbb3dacf84b3241de3088d72c7c561d071dd9380907cc6834c30a40b4f37cde571c SHA512 91a5a9a1d4b708f0882e5bc4c2ab7a9ff13d639efd57b0dc4e929cba03ace72edb66ab68972e5ac0b83e9e21f4054366daea66ca788215714a11417163a7d14e
MISC metadata.xml 331 BLAKE2B ad015a065c62101a0484d3a6842fe16f056d7cff573cb5ab42a5ff3f92482ddc2058dc02a62b43c760795789e15468e5f0d5086ac89220c1d7bca694e140566f SHA512 edd33297ae9253a468754eb98612a3a6c23dec70d877aafc414549cac534e33e51b1659c085eeb4554a30f0555d9930d655a0c7a29b87e5efa990c0ad85a9e47
diff --git a/app-misc/cpipe/cpipe-3.0.3.ebuild b/app-misc/cpipe/cpipe-3.0.3-r1.ebuild
index ff2b6594a3f6..e1798e5b3092 100644
--- a/app-misc/cpipe/cpipe-3.0.3.ebuild
+++ b/app-misc/cpipe/cpipe-3.0.3-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
@@ -13,20 +13,15 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-src_prepare() {
- default
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
- sed -i \
- -e "s/CFLAGS =/CFLAGS =${CFLAGS} /" \
- -e "s/-lm/-lm ${LDFLAGS}/" \
- -e "s/744/644/" makefile || die "sed failed"
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+src_configure() {
+ tc-export CC
}
src_install() {
- dobin "${PN}"
- doman "${PN}.1"
+ dobin cpipe
+
+ einstalldocs
+ doman cpipe.1
}
diff --git a/app-misc/cpipe/files/cpipe-3.0.3-makefile.patch b/app-misc/cpipe/files/cpipe-3.0.3-makefile.patch
new file mode 100644
index 000000000000..d68bb56f2967
--- /dev/null
+++ b/app-misc/cpipe/files/cpipe-3.0.3-makefile.patch
@@ -0,0 +1,29 @@
+--- a/makefile
++++ b/makefile
+@@ -15,14 +15,14 @@
+ MANDIR=$(prefix)/man/man1
+
+ ## Your favorite compiler flags.
+-CFLAGS = -O2 -W -Wall -pedantic
++CFLAGS += -W -Wall -pedantic
++LDLIBS = -lm
+
+ VERSION=$(shell cat .version)
+ ########################################################################
+ all: cpipe cpipe.1
+
+-cpipe: cpipe.o cmdline.o
+- $(CC) -o $@ cpipe.o cmdline.o -lm
++cpipe: cmdline.o
+
+ cpipe.1: cpipe.1.in
+ sed -e "s/|VERSION|/${VERSION}/g" <cpipe.1.in >cpipe.1
+@@ -37,7 +37,7 @@
+ install: cpipe cpipe.1
+ mkdir -p $(BINDIR) $(MANDIR)
+ cp cpipe $(BINDIR); chmod 755 $(BINDIR)/cpipe
+- cp cpipe.1 $(MANDIR); chmod 744 $(MANDIR)/cpipe.1
++ cp cpipe.1 $(MANDIR); chmod 644 $(MANDIR)/cpipe.1
+
+ uninstall:
+ -rm $(BINDIR)/cpipe