summaryrefslogtreecommitdiff
path: root/app-misc/countrycodes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-02 09:17:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-02 09:17:58 +0100
commite594c992ffc7a67aab370bfe0634d498dbd82b8a (patch)
tree4f2368520ca4f275439a3da159a7d6f0a2deead9 /app-misc/countrycodes
parent8f4c38a7c36dcb0533df606e6906314a00b70933 (diff)
gentoo auto-resync : 02:08:2022 - 09:17:58
Diffstat (limited to 'app-misc/countrycodes')
-rw-r--r--app-misc/countrycodes/Manifest3
-rw-r--r--app-misc/countrycodes/countrycodes-1.0.6.ebuild29
-rw-r--r--app-misc/countrycodes/files/1.0.6-Makefile.patch35
3 files changed, 67 insertions, 0 deletions
diff --git a/app-misc/countrycodes/Manifest b/app-misc/countrycodes/Manifest
index 47350d04938b..fade5980f659 100644
--- a/app-misc/countrycodes/Manifest
+++ b/app-misc/countrycodes/Manifest
@@ -1,4 +1,7 @@
AUX 1.0.5-Makefile.patch 1010 BLAKE2B a45e729398432a402296a57a6b82cf994bd91608c3af5ed1aaaaaca399930f7d14220eb932bff6fe89d7989c7a6e3f29bd4652cdfd2e82608217fdabcbc46d4f SHA512 73b43a54e52490ee662cb7af7505d4d0bccbd16851b19010be36e0b309bd0d81636ef855cdb1c49f83c9d7dbac036191eaf8b38396759b1e14588b28a9dd1f17
+AUX 1.0.6-Makefile.patch 728 BLAKE2B e94780600af8855903af12f0ac2b3645d8080bb38753cdc107a04d4ead1c8b2ef26c4c68d230ba4eef3431af8a97852e1871068c90513fb2eb70ec9a34408646 SHA512 0bc5828d6c4b587e508fa01355bef6b3a95918118adfedd4c1502845706534336e20ecacda637c4f42193ccce2b4d20b51d93062002cef4d897e4d65d95defc9
DIST countrycodes-1.0.5.tar.gz 18621 BLAKE2B 1f2e1fb0f96d1388687929895c310e1e93c320f4d3f3f4cfe19c50d2ab850bafcefb5e13cfdaed546237ae5873eb95ae574ac47c0048bc2fa37c96158b5082fe SHA512 d62beaaccdbc8f7e14f3edf0044aeeef6375a3deffc0e4246a49fb8209ed7256208c878f811950c5c3bfda729988a46c173aecec72ee66e8843932d97064f035
+DIST countrycodes-1.0.6.tar.gz 18834 BLAKE2B b5e0806618da0dd740a890b9c4d369cf2c44182515ec91aaa08a5e19da447635fb8536611a278ffcc419b506efa07df7e71bf5d520895a059c4aaa6e0cbc9b48 SHA512 be069593f60f785ef4d2e107340b941902a9c45d81ed04f8518a78f2be610ffdd1675da3da1d07271fc7ab736aabdd9f92f060d132e7b7b41310f1b653c53244
EBUILD countrycodes-1.0.5-r4.ebuild 710 BLAKE2B 049005d915058af95f12a8f2c5c3693206f3386428a1afb3aef62ef92360c073c50996fe312879c3456996387b94f9f18cb4975811c82627468f634821cc6566 SHA512 eb10abc32ee84401560148c65e4e230b4aa8b4d70f5306cec5ddc5d40f5e31cb79e1bafd89059a4550f8b273f8cf36412757b9dd77329e9ffe55bea0ca5b9611
+EBUILD countrycodes-1.0.6.ebuild 652 BLAKE2B f49e767a29d538f33aa88af26cae0d644e662028b27106ebc5928ea1be14276d2f27d417880cc87c1d892a65155b582407bedcb891e5755d07d0704ec7eabfee SHA512 b6c65e764a3aead17f93dbf34b4a710b161a6b5f024837f22727da6307a85cadbab3ffb2c2b0f556efa60ccdc4775561e90b731485135a1b1714f7e54855bfc0
MISC metadata.xml 266 BLAKE2B 74ac06b4ea12603c8713e69cbff9ce6874266fc48ee5c846f0ac3d50bf577c3edb1e4b6690ec44fc4dd51e55e96dd5c2478831c9f754b04661fe7700d8baf66f SHA512 b996554131284e3556af42d2c5032c5b1635de67d48983096991935e7ee04c32aadc93e48cae5160861e86d64eb6fd4abafc40d9dd8b85ddc032b042a77677cb
diff --git a/app-misc/countrycodes/countrycodes-1.0.6.ebuild b/app-misc/countrycodes/countrycodes-1.0.6.ebuild
new file mode 100644
index 000000000000..01499421f229
--- /dev/null
+++ b/app-misc/countrycodes/countrycodes-1.0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="An ISO 3166 country code finder"
+HOMEPAGE="https://sourceforge.net/projects/countrycodes/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+PATCHES=( "${FILESDIR}"/${PV}-Makefile.patch )
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ emake \
+ prefix="${ED}"/usr \
+ mandir="${ED}"/usr/share/man install
+ dosym iso3166 /usr/bin/countrycodes
+ dosym iso3166.1 /usr/share/man/man1/countrycodes
+ dodoc README
+}
diff --git a/app-misc/countrycodes/files/1.0.6-Makefile.patch b/app-misc/countrycodes/files/1.0.6-Makefile.patch
new file mode 100644
index 000000000000..051c02946230
--- /dev/null
+++ b/app-misc/countrycodes/files/1.0.6-Makefile.patch
@@ -0,0 +1,35 @@
+diff --git a/Makefile b/Makefile
+index b6e1323..b11a453 100644
+--- a/Makefile
++++ b/Makefile
+@@ -23,10 +23,9 @@ BINMODE=755
+ LOGDIRMODE=700
+
+ # Compiler to use
+-CC=gcc
+
+ # Compiler warnings
+-WARNINGS= -pedantic -Wall
++CFLAGS += -pedantic -Wall
+
+ # Compiler flags
+ CCOPTS = -O2 -fomit-frame-pointer
+@@ -58,7 +57,7 @@ PROGRAM = iso3166
+ all: $(PROGRAM)
+
+ $(PROGRAM): $(ISO3166OBJ)
+- $(CC) $(CCOPTS) $(ISO3166OBJ) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $(ISO3166OBJ) -o $@
+
+ clean:
+ $(RM) $(ISO3166OBJ) core defines.h $(PROGRAM)
+@@ -79,9 +78,6 @@ uninstall:
+ $(RM) ${bindir}/$(PROGRAM)
+ $(RM) ${mandir}/iso3166.1
+
+-.c.o:
+- $(CC) $(CCOPTS) $(WARNINGS) -c $<
+-
+ $(ISO3166OBJ): common.h defines.h protos.h tables.h
+
+ defines.h: