summaryrefslogtreecommitdiff
path: root/app-misc/countrycodes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/countrycodes
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/countrycodes')
-rw-r--r--app-misc/countrycodes/Manifest4
-rw-r--r--app-misc/countrycodes/countrycodes-1.0.5-r3.ebuild32
-rw-r--r--app-misc/countrycodes/files/1.0.5-Makefile.patch42
-rw-r--r--app-misc/countrycodes/metadata.xml8
4 files changed, 86 insertions, 0 deletions
diff --git a/app-misc/countrycodes/Manifest b/app-misc/countrycodes/Manifest
new file mode 100644
index 000000000000..8e89dd1deb59
--- /dev/null
+++ b/app-misc/countrycodes/Manifest
@@ -0,0 +1,4 @@
+AUX 1.0.5-Makefile.patch 1034 BLAKE2B 54c932527ba2eb9cfc9906571ab4e683e854359b677ef454e674e79bcb71ef2a28679f523785ad4eceab767fb976cc4a2388cbecca5e715aa21f6f5a9ae245aa SHA512 a0416ee6b6b7416d9f0f1d379b2b4a86fb0b0ca6df2dd5f0bf3d4e54ba1fa3213da1561a38b1757d2f98b4cf96df1ff74cdea1b7e05587c7250d77353f522832
+DIST countrycodes-1.0.5.tar.gz 18621 BLAKE2B 1f2e1fb0f96d1388687929895c310e1e93c320f4d3f3f4cfe19c50d2ab850bafcefb5e13cfdaed546237ae5873eb95ae574ac47c0048bc2fa37c96158b5082fe SHA512 d62beaaccdbc8f7e14f3edf0044aeeef6375a3deffc0e4246a49fb8209ed7256208c878f811950c5c3bfda729988a46c173aecec72ee66e8843932d97064f035
+EBUILD countrycodes-1.0.5-r3.ebuild 718 BLAKE2B a898ca882636d63bd98cfb6df0ff7724efbb94d8c05664236d459b3b81750cba6d47ed06b5f6aea3252eb907e0f8b283de033f4ee52b5ebf8b12677bbe22e99c SHA512 4b34f1b15dd64e2fd328d6107117a4008f778ced83978c9262380a63a538cf7b3b1ad5656eb32ab74065fb0b80f6b606df06c34285b839c523ef903d36895a9a
+MISC metadata.xml 265 BLAKE2B 75452ad720a31a08fc0dcd02eec704c18b11bc0660686f9a320b85fc879f55a564ce9c3b6a8c710781b74c5e8eb3d0544c02a042fb35a0b62a5e1491f675296a SHA512 176f814d8c555e8726f36e012367b698e8a19a0662982621029a7f9190beecc5e6798e43c51698dc149364966cdeff7061121e54fa9d4cf2a3559a6ce4904e25
diff --git a/app-misc/countrycodes/countrycodes-1.0.5-r3.ebuild b/app-misc/countrycodes/countrycodes-1.0.5-r3.ebuild
new file mode 100644
index 000000000000..1860a7e686ea
--- /dev/null
+++ b/app-misc/countrycodes/countrycodes-1.0.5-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="An ISO 3166 country code finder"
+HOMEPAGE="http://www.grigna.com/diego/linux/countrycodes/"
+SRC_URI="http://www.grigna.com/diego/linux/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~ia64 ~mips ppc ppc64 ~sparc x86"
+
+S="${WORKDIR}"/${P}/src
+
+PATCHES=( "${FILESDIR}/${PV}-Makefile.patch" )
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_install() {
+ emake \
+ prefix="${D}/usr" \
+ mandir="${D}/usr/share/man/man1" install
+ dosym iso3166 /usr/bin/countrycodes
+ dosym iso3166.1 /usr/share/man/man1/countrycodes
+ dodoc ../doc/{Changelog,README}
+}
diff --git a/app-misc/countrycodes/files/1.0.5-Makefile.patch b/app-misc/countrycodes/files/1.0.5-Makefile.patch
new file mode 100644
index 000000000000..677e59acc5c0
--- /dev/null
+++ b/app-misc/countrycodes/files/1.0.5-Makefile.patch
@@ -0,0 +1,42 @@
+diff --git a/Makefile b/Makefile
+index 9330578..3ff7319 100644
+--- a/Makefile
++++ b/Makefile
+@@ -26,13 +26,13 @@ BINMODE=755
+ LOGDIRMODE=700
+
+ # Compiler to use
+-CC=gcc
++CC ?= gcc
+
+ # Compiler warnings
+-WARNINGS= -pedantic -Wall
++WARNINGS=
+
+ # Compiler flags
+-CCOPTS = -O2 -fomit-frame-pointer
++CCOPTS = ${CFLAGS}
+
+ # The makefile standards document I read says that I have to put it here...
+ SHELL = /bin/sh
+@@ -61,7 +61,7 @@ PROGRAM = iso3166
+ all: $(PROGRAM)
+
+ $(PROGRAM): $(ISO3166OBJ)
+- $(CC) $(CCOPTS) $(ISO3166OBJ) -o $@
++ $(CC) $(CCOPTS) $(LDFLAGS) $(ISO3166OBJ) -o $@
+
+ clean:
+ rm -f $(ISO3166OBJ) core defines.h $(PROGRAM)
+@@ -70,8 +70,10 @@ strip:
+ strip $(PROGRAM)
+
+ install:
+- $(INSTALL) -g root -m $(BINMODE) -o root -s ${srcdir}/$(PROGRAM) ${bindir}
++ mkdir -p ${bindir}
++ $(INSTALL) -g root -m $(BINMODE) -o root ${srcdir}/$(PROGRAM) ${bindir}
+ @echo "Installing man page..."
++ mkdir -p ${mandir}
+ @$(SEDBIN) $(SEDCMDS) ${docdir}/iso3166.1.in > ${mandir}/iso3166.1
+ @chown 0.0 ${mandir}/iso3166.1
+ @echo
diff --git a/app-misc/countrycodes/metadata.xml b/app-misc/countrycodes/metadata.xml
new file mode 100644
index 000000000000..3cf14bf74636
--- /dev/null
+++ b/app-misc/countrycodes/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Shell Tools Project</name>
+ </maintainer>
+</pkgmetadata>