summaryrefslogtreecommitdiff
path: root/app-misc/color
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-09 00:04:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-09 00:04:30 +0100
commit94ead5b3c01213a82c9b72a2df165452421db42b (patch)
tree8a48ed4d21de4204607288d00e68a671bef1e8f8 /app-misc/color
parent418459f7de9eb29d6db8b61681f39c467d9600e1 (diff)
gentoo auto-resync : 09:10:2023 - 00:04:30
Diffstat (limited to 'app-misc/color')
-rw-r--r--app-misc/color/Manifest3
-rw-r--r--app-misc/color/color-1.2-r3.ebuild (renamed from app-misc/color/color-1.2-r2.ebuild)23
-rw-r--r--app-misc/color/files/1.2-ldflags.patch23
3 files changed, 15 insertions, 34 deletions
diff --git a/app-misc/color/Manifest b/app-misc/color/Manifest
index f0bf3c86dc15..4efdfa3a75b4 100644
--- a/app-misc/color/Manifest
+++ b/app-misc/color/Manifest
@@ -1,4 +1,3 @@
-AUX 1.2-ldflags.patch 404 BLAKE2B e07b9c473e8b673d11c3837c6759c5beacc58fcf81ed1b9f0804d614fedc524983c237eb83be33182a384997f666842af554a950d26d8e7106f109ab5beee6b1 SHA512 44c774102cf9800b38d0831be640758a802cb2fdc2949036617ee23a47565944d514ecbee6532d2f426c766aef48814f362f7e0cb27ce8b280295af106426380
DIST color-1.2.tar.gz 10040 BLAKE2B 1359f77e88c1c20d3643d6b00cad43fe5fbdb26d406d338132a5541668482c1a14e452ff502c10164f2d32d5c79b390328ffdad85012093d69fd767255f08fda SHA512 58f7d379bca3352b2e39eab83d2fa5891df86c45722541eb810becce813c8e866f28b856ed244a75b173f0dab5dbdc84ceb91d96175dcd2484e29abb98ba87ac
-EBUILD color-1.2-r2.ebuild 884 BLAKE2B 56a3fdd4e21e5e61119702b256fb81a1e0a091a9838bb7261ae66f003048d0f330ff03dc6ef1af8ca950f5da24db3fab7a19606485a7b63d1cb38b4569542d7b SHA512 e45ed2a84dd41475b7ce7f20a5a8dc028d0a04659a80164a975e00e3468f3ef108c8d41b4a83179171e036f357cfcf6004be87f37c80d6a92cf94a3424a72c4e
+EBUILD color-1.2-r3.ebuild 872 BLAKE2B bf82e92ecf00972c1393469c2f4a89dd95c9112d0b1361b3dd3c225184ed575e7e997069474871e23134bea987998b40d80ddd64b20082145056444fba570b72 SHA512 356c9375f6028e06e27ad4a01959bed641b678b70d7e5fbf5cd9aa7f2996da476a75731ddf8f2ec7746e84c61de03848c6e7dbcf0f489aa9eb39781752298954
MISC metadata.xml 589 BLAKE2B 2ccdcd2bb0dab4b14f2ad33fec03de7d106119f94a4ba1945e65698221b737be89d2a630f992b48b9bd7334616cf58ff228d16268ded40cf02b399287469942a SHA512 7edef86cd5ccce86c28ee0badcf136bdbf6c8ce9a9765b1a74b11e148fa57a46214e94bdf996409617f2fc657c016486da109c65f97f3aa9ef3e945fbb1485c5
diff --git a/app-misc/color/color-1.2-r2.ebuild b/app-misc/color/color-1.2-r3.ebuild
index 04850977dee3..0aa2258eb1c3 100644
--- a/app-misc/color/color-1.2-r2.ebuild
+++ b/app-misc/color/color-1.2-r3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
@@ -14,25 +14,30 @@ SLOT="0"
KEYWORDS="~alpha amd64 ~hppa ~ia64 ~mips ppc ppc64 ~sparc x86"
src_prepare() {
- eapply "${FILESDIR}"/${PV}-ldflags.patch
default
+ # just rely on implicit rules
+ rm Makefile || die
+}
+
+src_configure() {
tc-export CC
}
+src_compile() {
+ emake color
+}
+
src_install() {
dobin color
- dodoc CHANGELOG README
-
- # symlink for british users.
- dosym color /usr/bin/colour
+ einstalldocs
}
pkg_postinst() {
elog "For information on using colour in your shell scripts,"
- elog "run \`color\` without any arguments."
+ elog "run 'color' without any arguments."
elog
elog "To see all the colours available, use this command"
elog " $ color --list"
elog
- elog "More examples are available in ${EPREFIX}/usr/share/doc/${PF}."
+ elog "More examples are available in ${EROOT}/usr/share/doc/${PF}."
}
diff --git a/app-misc/color/files/1.2-ldflags.patch b/app-misc/color/files/1.2-ldflags.patch
deleted file mode 100644
index 9c95eda73b0e..000000000000
--- a/app-misc/color/files/1.2-ldflags.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 79c5b33..452e091 100644
---- a/Makefile
-+++ b/Makefile
-@@ -1,4 +1,4 @@
--CC = cc
-+CC ?= cc
- #CFLAGS = -W -Wall -O2 -g
- INCLUDE = $(wildcard *.h)
- OBJS = color.o
-@@ -6,8 +6,11 @@ EXE = color
-
- all: $(EXE)
-
-+OBJS: color.c
-+ $(CC) $(CFLAGS) -c $^ $@
-+
- $(EXE): $(OBJS)
-- $(CC) $(CFLAGS) -o $@ $^
-+ $(CC) $(LDFLAGS) -o $@ $^
-
- install: all
- cp $(EXE) /usr/local/bin