summaryrefslogtreecommitdiff
path: root/app-misc/ckb/ckb-0.4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /app-misc/ckb/ckb-0.4.2.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'app-misc/ckb/ckb-0.4.2.ebuild')
-rw-r--r--app-misc/ckb/ckb-0.4.2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-misc/ckb/ckb-0.4.2.ebuild b/app-misc/ckb/ckb-0.4.2.ebuild
new file mode 100644
index 000000000000..b9d31b54b0ea
--- /dev/null
+++ b/app-misc/ckb/ckb-0.4.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop cmake-utils systemd
+
+DESCRIPTION="Corsair K65/K70/K95 Driver"
+HOMEPAGE="https://github.com/ckb-next/ckb-next"
+SRC_URI="https://github.com/ckb-next/ckb-next/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-libs/quazip-0.7.2[qt5(+)]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ virtual/libudev:=
+ x11-libs/libX11
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGELOG.md README.md )
+S="${WORKDIR}/${PN}-next-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_UPDATER=yes
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ newinitd "${FILESDIR}"/ckb.initd ckb-daemon
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}