summaryrefslogtreecommitdiff
path: root/app-misc/chkcrontab
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /app-misc/chkcrontab
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'app-misc/chkcrontab')
-rw-r--r--app-misc/chkcrontab/Manifest1
-rw-r--r--app-misc/chkcrontab/chkcrontab-1.7-r1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/app-misc/chkcrontab/Manifest b/app-misc/chkcrontab/Manifest
index 47072fed67ba..0e2659bd1ade 100644
--- a/app-misc/chkcrontab/Manifest
+++ b/app-misc/chkcrontab/Manifest
@@ -1,3 +1,4 @@
DIST chkcrontab-1.7.tar.gz 25088 BLAKE2B 5e3cffcbcd064cfe8e9898dc74c215b14bdd69a4c110a91b73777cb024dd6dfe8d10ce862e82752baad65a8daf88dc45bee06f8e736393e0f973ee2f79f7bd96 SHA512 5236b1996a8d4f5d3861bf3d8a1bafafa271237965721ea4ff61e6712ee4546b9d0484483a0dac25f9d920904f899f2930b46df16d656083b422d95a1d6de0c0
+EBUILD chkcrontab-1.7-r1.ebuild 573 BLAKE2B 9c7aedbd963edec5c90df172e5cc6994023fe710cd78b65306421a2d2346cb15df4bd0c84587492e4beae5603d556391ffc02785bfa45fc25968ee821405d134 SHA512 24b1707c4dbe8c88e1f32218d07acce727b8a434590c77872a78f01e058b333b7afcd63fa529840d6a50c2a2d23c2a2282f003312c0cfa2be6a8dd1a425e6abc
EBUILD chkcrontab-1.7.ebuild 555 BLAKE2B fc96c290f6866ddd18ed02eae4c80b2e6e013c17b108b56e2aa1e0540b53c801df48a7425e6c4f46751e8334d71ceb0b469c551abb997e829f2226b18ba02d0c SHA512 de95af7a7820a7b0af60b04820f6ccbde2dafbfa6c1fe2a089d3c8f657992d4179caf4c49f6e79be1ce930d829f64a5959910fa7da4b50a29347edbcf781ef0c
MISC metadata.xml 463 BLAKE2B 82e0b38cdc6aeb0cb304f3448f326c129e5b936ff559e07e5ced9b1b72e840cc4f1573571eae46cc56639f6920e717e7d3f67eef6cf8aac5e9a11f5948ac70ca SHA512 d181e1a0b06519224d4e6b13b7157bd9741000c676e7f47c72dd27eb475d991a32480393bd62a599fb0a833908bae96b810fbdb17723723067edc6af3b3ab0ca
diff --git a/app-misc/chkcrontab/chkcrontab-1.7-r1.ebuild b/app-misc/chkcrontab/chkcrontab-1.7-r1.ebuild
new file mode 100644
index 000000000000..e5d5ef95ce97
--- /dev/null
+++ b/app-misc/chkcrontab/chkcrontab-1.7-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="A tool to detect crontab errors"
+HOMEPAGE="https://github.com/lyda/chkcrontab"
+SRC_URI="https://github.com/lyda/chkcrontab/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ doman doc/${PN}.1
+ distutils-r1_python_install_all
+}