summaryrefslogtreecommitdiff
path: root/app-misc/chkcrontab
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/chkcrontab
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/chkcrontab')
-rw-r--r--app-misc/chkcrontab/Manifest5
-rw-r--r--app-misc/chkcrontab/chkcrontab-1.6.ebuild26
-rw-r--r--app-misc/chkcrontab/chkcrontab-1.7.ebuild26
-rw-r--r--app-misc/chkcrontab/metadata.xml15
4 files changed, 72 insertions, 0 deletions
diff --git a/app-misc/chkcrontab/Manifest b/app-misc/chkcrontab/Manifest
new file mode 100644
index 000000000000..34b5d2fc8b7a
--- /dev/null
+++ b/app-misc/chkcrontab/Manifest
@@ -0,0 +1,5 @@
+DIST chkcrontab-1.6.tar.gz 24701 BLAKE2B a4a47e0e41a17a535662b22deb57dd49b461694f4842a59a1a9debe8523f4216f4834c64d01c62e24e13ee4d45e526f361650b402968a164b2802e0a13d63a63 SHA512 249061ecf7c8dc2d2275dcda3048fd00fc2ca85d39dabb2de61a3ab415243bbd1a61222be8c0ddfa66eb36577bb2efb27ba4a0c2a013559dee126c95cc73bd1b
+DIST chkcrontab-1.7.tar.gz 25088 BLAKE2B 5e3cffcbcd064cfe8e9898dc74c215b14bdd69a4c110a91b73777cb024dd6dfe8d10ce862e82752baad65a8daf88dc45bee06f8e736393e0f973ee2f79f7bd96 SHA512 5236b1996a8d4f5d3861bf3d8a1bafafa271237965721ea4ff61e6712ee4546b9d0484483a0dac25f9d920904f899f2930b46df16d656083b422d95a1d6de0c0
+EBUILD chkcrontab-1.6.ebuild 528 BLAKE2B c90cddccd32141129a7e263eaf4bcfefa07589745ae30df8359ef77825b3028660229e34996846787baaa863c2d8cae71215cf05e75eff3ae59c3b8b43c9fabf SHA512 4b032d1dfa0247d66f1c65a528176c816cc6ac8cb1f3e37e553547f41f0e8ea2050ad62f8497d5e059e47e0a6d796c95b252f1f4647c8cb60a47935785f5dbdd
+EBUILD chkcrontab-1.7.ebuild 539 BLAKE2B 09d120d685a46505a5d127ca7b56300b1f26fc7e41191bbd2306e775db9e8068b2e5ff62b55f1c293d984f9660c0879c816136ceee1c4b3fe81832f615d8634c SHA512 e178bb05433fa686eaff24a76c1552538199acba20258adbf28773d996f491e95a97a321a6887f4d62ee075d62a57f78f5b90f1ad3976b254d97d5c7bfb99c6c
+MISC metadata.xml 463 BLAKE2B 82e0b38cdc6aeb0cb304f3448f326c129e5b936ff559e07e5ced9b1b72e840cc4f1573571eae46cc56639f6920e717e7d3f67eef6cf8aac5e9a11f5948ac70ca SHA512 d181e1a0b06519224d4e6b13b7157bd9741000c676e7f47c72dd27eb475d991a32480393bd62a599fb0a833908bae96b810fbdb17723723067edc6af3b3ab0ca
diff --git a/app-misc/chkcrontab/chkcrontab-1.6.ebuild b/app-misc/chkcrontab/chkcrontab-1.6.ebuild
new file mode 100644
index 000000000000..bd45b594bf28
--- /dev/null
+++ b/app-misc/chkcrontab/chkcrontab-1.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool to detect crontab errors"
+HOMEPAGE="https://github.com/lyda/chkcrontab"
+SRC_URI="https://github.com/lyda/chkcrontab/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ doman doc/${PN}.1
+ distutils-r1_python_install_all
+}
diff --git a/app-misc/chkcrontab/chkcrontab-1.7.ebuild b/app-misc/chkcrontab/chkcrontab-1.7.ebuild
new file mode 100644
index 000000000000..b188e6979af1
--- /dev/null
+++ b/app-misc/chkcrontab/chkcrontab-1.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool to detect crontab errors"
+HOMEPAGE="https://github.com/lyda/chkcrontab"
+SRC_URI="https://github.com/lyda/chkcrontab/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+python_test() {
+ esetup.py test || die
+}
+
+python_install_all() {
+ doman doc/${PN}.1
+ distutils-r1_python_install_all
+}
diff --git a/app-misc/chkcrontab/metadata.xml b/app-misc/chkcrontab/metadata.xml
new file mode 100644
index 000000000000..d69c349ca9a7
--- /dev/null
+++ b/app-misc/chkcrontab/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hydrapolic@gmail.com</email>
+ <name>Tomáš Mózes</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lyda/chkcrontab</remote-id>
+ </upstream>
+</pkgmetadata>