summaryrefslogtreecommitdiff
path: root/app-misc/chkcrontab
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/chkcrontab
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/chkcrontab')
-rw-r--r--app-misc/chkcrontab/Manifest6
-rw-r--r--app-misc/chkcrontab/chkcrontab-1.6.ebuild26
-rw-r--r--app-misc/chkcrontab/chkcrontab-1.7.ebuild26
-rw-r--r--app-misc/chkcrontab/metadata.xml15
4 files changed, 73 insertions, 0 deletions
diff --git a/app-misc/chkcrontab/Manifest b/app-misc/chkcrontab/Manifest
new file mode 100644
index 000000000000..daef2426af10
--- /dev/null
+++ b/app-misc/chkcrontab/Manifest
@@ -0,0 +1,6 @@
+DIST chkcrontab-1.6.tar.gz 24701 SHA256 be7436d5ece4ad6390365f6edf0f1dc59dfd655a9de3b4699884343ceb150f2e SHA512 249061ecf7c8dc2d2275dcda3048fd00fc2ca85d39dabb2de61a3ab415243bbd1a61222be8c0ddfa66eb36577bb2efb27ba4a0c2a013559dee126c95cc73bd1b WHIRLPOOL 13995293e761930d0d900c3e7fa5b7695fad3416ade96fc34be415a448ca5e5969f5b82889d46041ed801ca2f13e5154a01698d753898ee9027bd9a2c8e6e29f
+DIST chkcrontab-1.7.tar.gz 25088 SHA256 1725172dbdea26f1aef915b9acd7100605e49f8675761900bc0992a227d767b9 SHA512 5236b1996a8d4f5d3861bf3d8a1bafafa271237965721ea4ff61e6712ee4546b9d0484483a0dac25f9d920904f899f2930b46df16d656083b422d95a1d6de0c0 WHIRLPOOL bf89b4a126e3244e2b02ec594e57cc50df802be75427148c326d132e1fcbd3df5346301093860d664ca221cc85e78c65768c2a43108f09de11a7c1fdad8a46fc
+EBUILD chkcrontab-1.6.ebuild 528 SHA256 1f2ea7ecb053fcdc64a635382fab22d50f8c83b42856ca8b791f7e65e832bc0a SHA512 4b032d1dfa0247d66f1c65a528176c816cc6ac8cb1f3e37e553547f41f0e8ea2050ad62f8497d5e059e47e0a6d796c95b252f1f4647c8cb60a47935785f5dbdd WHIRLPOOL 368e1c7f959a91337ff7db90ae04cfab013451ec1dfded712909b9846d00b4e6e7cab5cdd48130033a896072a7c0154a2c093e739d9184ca13aff4eb44bf1952
+EBUILD chkcrontab-1.7.ebuild 540 SHA256 e41e0c6138023044dcecc0b5c95ebf19dddf461028fe2150b8383bbcb622df86 SHA512 37ee9cc6d9fb562e2e1e520e2d75ea858703c75713ef05cbefacd37ddb7c6a5c1980e11c7a8ae819c2dd080ef2a5e64ed4cc41e440485cc33f0fc40215943976 WHIRLPOOL 28292de3218c9283cc5f22fbe04085239151ffbbe3ea76d189e8dbd03dbb3e4fe9f13fd10133b61d6b612afde1187c9fa141b160da7d7a2eb2a5ecdca3789568
+MISC ChangeLog 700 SHA256 db47152974a7fef4ab19036be8a61f535699c85f5316f6cf56e83dcf97fd2720 SHA512 c6bef5f7d78704b9df97e735b48a5240ac947934eb1ad23edb3705e80511bc847167aabe00b32bfb82df40a680ff2202e8601de758937eb1c730bf48e0c1c291 WHIRLPOOL 472eab35cf5982a9e7418078df18344627a900982e26ea65f1458a2394fcf4233f2d9efee71611db62add8e2a2e5942c9dcc734b0ed7fcc0620309e3c7fc7ef1
+MISC metadata.xml 463 SHA256 12acc6d8aa1569c29105b9e54d78a9268bca7526c8db4f912c214497ae0c6b5c SHA512 d181e1a0b06519224d4e6b13b7157bd9741000c676e7f47c72dd27eb475d991a32480393bd62a599fb0a833908bae96b810fbdb17723723067edc6af3b3ab0ca WHIRLPOOL 348a6615dbf4e2e3ed4eb887302ba2c5c5b6e67fa791da1c7b6949c24fd5951b2459bf08621358f4c58f5197aaa6b973ed917968f099ab4bd5d1f7505127375f
diff --git a/app-misc/chkcrontab/chkcrontab-1.6.ebuild b/app-misc/chkcrontab/chkcrontab-1.6.ebuild
new file mode 100644
index 000000000000..bd45b594bf28
--- /dev/null
+++ b/app-misc/chkcrontab/chkcrontab-1.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool to detect crontab errors"
+HOMEPAGE="https://github.com/lyda/chkcrontab"
+SRC_URI="https://github.com/lyda/chkcrontab/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ doman doc/${PN}.1
+ distutils-r1_python_install_all
+}
diff --git a/app-misc/chkcrontab/chkcrontab-1.7.ebuild b/app-misc/chkcrontab/chkcrontab-1.7.ebuild
new file mode 100644
index 000000000000..90a33181737b
--- /dev/null
+++ b/app-misc/chkcrontab/chkcrontab-1.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool to detect crontab errors"
+HOMEPAGE="https://github.com/lyda/chkcrontab"
+SRC_URI="https://github.com/lyda/chkcrontab/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="test"
+
+python_test() {
+ esetup.py test || die
+}
+
+python_install_all() {
+ doman doc/${PN}.1
+ distutils-r1_python_install_all
+}
diff --git a/app-misc/chkcrontab/metadata.xml b/app-misc/chkcrontab/metadata.xml
new file mode 100644
index 000000000000..d69c349ca9a7
--- /dev/null
+++ b/app-misc/chkcrontab/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hydrapolic@gmail.com</email>
+ <name>Tomáš Mózes</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lyda/chkcrontab</remote-id>
+ </upstream>
+</pkgmetadata>