summaryrefslogtreecommitdiff
path: root/app-misc/chkcrontab/chkcrontab-1.7-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-misc/chkcrontab/chkcrontab-1.7-r2.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-misc/chkcrontab/chkcrontab-1.7-r2.ebuild')
-rw-r--r--app-misc/chkcrontab/chkcrontab-1.7-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-misc/chkcrontab/chkcrontab-1.7-r2.ebuild b/app-misc/chkcrontab/chkcrontab-1.7-r2.ebuild
new file mode 100644
index 000000000000..3eb38db689fc
--- /dev/null
+++ b/app-misc/chkcrontab/chkcrontab-1.7-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="A tool to detect crontab errors"
+HOMEPAGE="https://github.com/lyda/chkcrontab"
+SRC_URI="https://github.com/lyda/chkcrontab/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ doman doc/${PN}.1
+ distutils-r1_python_install_all
+}