summaryrefslogtreecommitdiff
path: root/app-misc/cdircmp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
commite23cdda4dbb0c83b9e682ab5e916085a35203da5 (patch)
tree5a4ac448a3b288b731c24d947e0ce52df3cab07b /app-misc/cdircmp
parent8187a741807f3e9a9e26304973cf18087dcf2560 (diff)
gentoo resync : 23.06.2018
Diffstat (limited to 'app-misc/cdircmp')
-rw-r--r--app-misc/cdircmp/Manifest3
-rw-r--r--app-misc/cdircmp/cdircmp-0.3-r1.ebuild4
-rw-r--r--app-misc/cdircmp/cdircmp-0.3-r2.ebuild35
3 files changed, 39 insertions, 3 deletions
diff --git a/app-misc/cdircmp/Manifest b/app-misc/cdircmp/Manifest
index 40babd895eb8..872949edd513 100644
--- a/app-misc/cdircmp/Manifest
+++ b/app-misc/cdircmp/Manifest
@@ -1,3 +1,4 @@
DIST cdircmp-0.3.tar.gz 17253 BLAKE2B 090e73d2d60ff10e8ba01c77c172b6e4b4603c778f4ad8b29dbcedd8e214f54377c171bc964c14ab4f08dc8e995b5c6b55601f75977b35669cbcfb23d0c19fea SHA512 66fa27a3c06aa4bd6584da2c6a38ad0798f5f10eb9b021080c473d03733bd2dba344549e95c22485bf72536a03a4e91a7497192296b6c297166e47a679cf0079
-EBUILD cdircmp-0.3-r1.ebuild 750 BLAKE2B 2cd0d47339df57d57b563592bef95918005f0b903d8ece85a2ade1590b3eefc8c0f3374df09609dfce9c744424ca031ff0dbd1fed89d8ce1f5f65df6647a8c36 SHA512 34cfcebb8172ca0fc716733c5cbbb89fc0fe2eedc139406cca20a592f0120762cb8f2784d9690b8bb1a60ede03662b382805587649bb2d0ba8ce42676236781d
+EBUILD cdircmp-0.3-r1.ebuild 756 BLAKE2B 85ff26a39b82cb2bcd1b6ad1ed8215ade2d1f986c63a75215db444598bb933510eeac73a6b42a52164e4c8053c97ad247051f4981faf5ccd81b50968cfaf2ed1 SHA512 1f208a84a06f735e3631ec55159528ab24712cf74228d9f8e7957d3383202c8953a40815ebf339b812cf41cc1323d2eab41194384b795533b5c78499be68325d
+EBUILD cdircmp-0.3-r2.ebuild 663 BLAKE2B 371d80aa2cb1f654a0bba24d9cf21a2d418184ca73fa067d5a542594d9f7d44433deeeaed0db98c7aad01fb7ca6ada50096ca40be452cce03a4468e3f4b4d872 SHA512 2be97f0c1bed5525e7f1bb04ad123dedd83c6d3894909fce94838605b12d157cbe594c4fa21fada0e8e859f361945dbcef9cad0f843530f08628c43296220c96
MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-misc/cdircmp/cdircmp-0.3-r1.ebuild b/app-misc/cdircmp/cdircmp-0.3-r1.ebuild
index b2576f017b87..f7851f0207a2 100644
--- a/app-misc/cdircmp/cdircmp-0.3-r1.ebuild
+++ b/app-misc/cdircmp/cdircmp-0.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="2"
@@ -7,7 +7,7 @@ inherit toolchain-funcs
DESCRIPTION="Compare directories and select files to copy"
HOMEPAGE="http://home.hccnet.nl/paul.schuurmans/"
-SRC_URI="http://home.hccnet.nl/paul.schuurmans/download/${P}.tar.gz"
+SRC_URI="http://home.hccnet.nl/paul.schuurmans/linux/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
diff --git a/app-misc/cdircmp/cdircmp-0.3-r2.ebuild b/app-misc/cdircmp/cdircmp-0.3-r2.ebuild
new file mode 100644
index 000000000000..ea5818e44538
--- /dev/null
+++ b/app-misc/cdircmp/cdircmp-0.3-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Compare directories and select files to copy"
+HOMEPAGE="http://home.hccnet.nl/paul.schuurmans/"
+SRC_URI="http://home.hccnet.nl/paul.schuurmans/linux/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=sys-libs/ncurses-5.4:0="
+
+src_prepare() {
+ sed -i Makefile \
+ -e 's| -o | $(LDFLAGS)&|g' \
+ || die "sed Makefile"
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ einstalldocs
+ dobin ${PN}
+}