summaryrefslogtreecommitdiff
path: root/app-misc/cdcat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/cdcat
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/cdcat')
-rw-r--r--app-misc/cdcat/Manifest5
-rw-r--r--app-misc/cdcat/cdcat-0.3.ebuild47
-rw-r--r--app-misc/cdcat/metadata.xml5
3 files changed, 57 insertions, 0 deletions
diff --git a/app-misc/cdcat/Manifest b/app-misc/cdcat/Manifest
new file mode 100644
index 000000000000..30e3bad82e99
--- /dev/null
+++ b/app-misc/cdcat/Manifest
@@ -0,0 +1,5 @@
+DIST cdcat-0.3.tar.gz 7464 SHA256 b7c0ff819e572fa5b9c160a0d2fac391995c96c3bb5d61cc64ed63d17139a651 SHA512 6d30a22c29a1846a3899f384bcc395444af77b62024cb9f45da877819614c3f1ff495e03f7d7b498716fe4725c569c88a14480a37fc4e4fef5cfd9a640e4cfa3 WHIRLPOOL 68a0604bb6afe71c8c5836421f68a0d21fd0620865531add222e478a375ba8040d7a52b58c2b44b1e2502deeb5a07c7fbe2935432fb6a4a3049d3a312b500f78
+EBUILD cdcat-0.3.ebuild 1212 SHA256 cc3f0e49b555f198c7c82fd0249a2c176b33740f54f2886b4f33ebf0dbab1dbc SHA512 bbed8c988d199c4d169bfb886013b8a4a2a5b52cb11d03a51deb4f66ae4d7c6396ea0e3654b30e4ceececc78e56224f35c4ea24c61bef97dd11e87fd857fd63f WHIRLPOOL b72fb5ec4b5012af6196a1f8c87f176cca75db1571b3491a49d6e576a85c31a82c44f0f8fff3e758f9865cd1e1f29a95306c30e432cf005af7f975291a26b64b
+MISC ChangeLog 2645 SHA256 c2199e142bf165b1e8d7dffe3b22afd40f04cde1eb1e3deb809fa660adc54834 SHA512 c682980e73b030f7b479547b7246876ed9999a13977565fd1c9cef42073ca1f2a8b3353c69517b8816c2ccd4f819b18717fc41c0687f86125afadf154cfbbfe0 WHIRLPOOL eade880714bf1ab096706a2a010fe1390286206bf0e1152b6f32c1e11ccaed236c5c6b1d8020599bce45bf3e849006ccd492a902955d7275e4799f5097f84bcd
+MISC ChangeLog-2015 2041 SHA256 0389f24b9ae65e9732b6bc1ff0de97d83641a9a604df63cc03bba2d650a1fb52 SHA512 5874f6e707b2cf7fc9c22c7dd8baa64e3a7583407b138923168599d538727fd88cfa6b79890b59f1b1abeb1212e4c8b9920f2cbc6871e6c3042b85150052d2bc WHIRLPOOL 65fbe2a5c226ff833dfb7c1270c1a7507cfaa336d682edc8296c2ca0d58becd763be1c3126b4056845d48e24432e63c32064ce89c4a3389b7aa0efd4ebbdd2ab
+MISC metadata.xml 166 SHA256 2caff447f5bd2701d8456ada5cc633c41ef4373fa4bfeabeb73599d40bcc941b SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84 WHIRLPOOL 1ff70497eca6531f0e0614c72a19f4b8e5ff486a58d369f4f0b36308d1d6b01168f9da887740e3b9f536236be251d3fe05f904d27a9233a7cf613416ba882968
diff --git a/app-misc/cdcat/cdcat-0.3.ebuild b/app-misc/cdcat/cdcat-0.3.ebuild
new file mode 100644
index 000000000000..496a064140db
--- /dev/null
+++ b/app-misc/cdcat/cdcat-0.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="simple yet effective CD indexing program"
+# original src went away: SRC_URI="http://littledragon.home.ro/unix/${P}.tar.gz"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+HOMEPAGE="https://dev.gentoo.org/~centic/cdcat/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="virtual/cdrtools
+ !app-backup/cdbkup"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # workaround install.sh ignoring --man_prefix
+ sed -i 's:^MAN_PREFIX:#:' install.sh
+
+ # fix path to cd index files to be FHS-compliant
+ sed -i 's:/mnt/ext/cd:/var/lib/cdcat:' src/cdcat.pl
+
+ # work around problem with isoinfo -di
+ sed -i 's:isoinfo -di:isoinfo -d -i:' src/cdcat.pl
+}
+
+src_install() {
+ # workaround install.sh ignoring --man_prefix
+ export MAN_PREFIX="${D}/usr/share/man"
+ dodir /usr/share/man/man1
+
+ # create index files path
+ dodir /var/lib/cdcat
+ chgrp cdrom "${D}"/var/lib/cdcat
+ chmod g+ws,o+w "${D}"/var/lib/cdcat
+
+ # now use the included install.sh
+ ./install.sh --prefix="${D}/usr" \
+ --man_prefix="${D}/usr/share/man" || die "Install script failed."
+
+ insinto /etc
+ doins doc/cdcat.conf || die
+}
diff --git a/app-misc/cdcat/metadata.xml b/app-misc/cdcat/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/app-misc/cdcat/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>