summaryrefslogtreecommitdiff
path: root/app-misc/cdcat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /app-misc/cdcat
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'app-misc/cdcat')
-rw-r--r--app-misc/cdcat/Manifest3
-rw-r--r--app-misc/cdcat/cdcat-0.3-r1.ebuild47
-rw-r--r--app-misc/cdcat/cdcat-0.3.ebuild4
3 files changed, 51 insertions, 3 deletions
diff --git a/app-misc/cdcat/Manifest b/app-misc/cdcat/Manifest
index b964640d32c6..10fb23294b0a 100644
--- a/app-misc/cdcat/Manifest
+++ b/app-misc/cdcat/Manifest
@@ -1,3 +1,4 @@
DIST cdcat-0.3.tar.gz 7464 BLAKE2B 24d0acce5bca9f84d24944e74a463ec64fee19a989ef89c187dc283d5c87dbdffb76e9471159903603c07924e0affef6f1b48dc7ab5e7292e5ae427510f7a259 SHA512 6d30a22c29a1846a3899f384bcc395444af77b62024cb9f45da877819614c3f1ff495e03f7d7b498716fe4725c569c88a14480a37fc4e4fef5cfd9a640e4cfa3
-EBUILD cdcat-0.3.ebuild 1220 BLAKE2B 9bdec6ac62b4c2c51dbf5a7652adf90c75d459d45e4969a5b1866523f427d671917f935de3fac4847fc413104de53071db3c9bb975c9a240cc9b53ffc5d778a5 SHA512 98d1f7c4a0bd7ca6c06cbedc6323f2d40cee757c66bc8a6e9d88a86a3f202428dd8f3a681f2d82bbe91b5fb7723d7d44fb29eb1d9cea02e6aebb99fd2f0a1743
+EBUILD cdcat-0.3-r1.ebuild 1245 BLAKE2B c45100b1cb46d197421f9964a22edcbb7a5f4d026348d6a8c436c30df1d4463e6ecf353458957f8b9e8f05bf2cccc13a1ae42e91359ce0471e351195d9884e58 SHA512 1fc07b8db7fa5e486171370a4f0577321ce3d7c39766dd1eca9678ac11671c6430416a14490129d32b2928aae619b057f3ac9847fce7e14af15a859568269521
+EBUILD cdcat-0.3.ebuild 1231 BLAKE2B 435ec1d0f9750158055c9ddf2ebc1a31fa0223d51d59b34832fd9bd8cef528244e3a9d645c0d20b9149d0b1b578a4c43ef495d61b31822e07a84336da09a19ce SHA512 a21844dbbc3ba3206407dd59e0af6bc520fb09d83a08fc3454853bcd2c44853e8f68d2ffed1819a034c6e22c6792f0ba7b4b35d91df62f75716429a82f5185fa
MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-misc/cdcat/cdcat-0.3-r1.ebuild b/app-misc/cdcat/cdcat-0.3-r1.ebuild
new file mode 100644
index 000000000000..3649b8e2eacc
--- /dev/null
+++ b/app-misc/cdcat/cdcat-0.3-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Simple yet effective CD indexing program"
+# original src went away: SRC_URI="http://littledragon.home.ro/unix/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/cdcatalog/${P}.tar.gz"
+HOMEPAGE="http://cdcatalog.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="virtual/cdrtools
+ !app-backup/cdbkup"
+
+src_prepare() {
+ default
+ # workaround install.sh ignoring --man_prefix
+ sed -i 's:^MAN_PREFIX:#:' install.sh || die
+
+ # fix path to cd index files to be FHS-compliant
+ sed -i 's:/mnt/ext/cd:/var/lib/cdcat:' src/cdcat.pl || die
+
+ # work around problem with isoinfo -di
+ sed -i 's:isoinfo -di:isoinfo -d -i:' src/cdcat.pl || die
+}
+
+src_install() {
+ # workaround install.sh ignoring --man_prefix
+ export MAN_PREFIX="${D}/usr/share/man"
+ dodir /usr/share/man/man1
+
+ # create index files path
+ dodir /var/lib/cdcat
+ keepdir /var/lib/cdcat
+ chgrp cdrom "${D}"/var/lib/cdcat
+ chmod g+ws,o+w "${D}"/var/lib/cdcat || die
+
+ # now use the included install.sh
+ ./install.sh --prefix="${D}/usr" \
+ --man_prefix="${D}/usr/share/man" || die "Install script failed."
+
+ insinto /etc
+ doins doc/cdcat.conf
+}
diff --git a/app-misc/cdcat/cdcat-0.3.ebuild b/app-misc/cdcat/cdcat-0.3.ebuild
index e97b12414768..6f165bb146e3 100644
--- a/app-misc/cdcat/cdcat-0.3.ebuild
+++ b/app-misc/cdcat/cdcat-0.3.ebuild
@@ -5,8 +5,8 @@ EAPI=0
DESCRIPTION="simple yet effective CD indexing program"
# original src went away: SRC_URI="http://littledragon.home.ro/unix/${P}.tar.gz"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
-HOMEPAGE="https://dev.gentoo.org/~centic/cdcat/"
+SRC_URI="mirror://sourceforge/cdcatalog/${P}.tar.gz"
+HOMEPAGE="http://cdcatalog.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0"