summaryrefslogtreecommitdiff
path: root/app-misc/birthday
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/birthday
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/birthday')
-rw-r--r--app-misc/birthday/Manifest6
-rw-r--r--app-misc/birthday/birthday-1.6.2-r1.ebuild31
-rw-r--r--app-misc/birthday/birthday-1.6.2.ebuild34
-rw-r--r--app-misc/birthday/metadata.xml11
4 files changed, 82 insertions, 0 deletions
diff --git a/app-misc/birthday/Manifest b/app-misc/birthday/Manifest
new file mode 100644
index 000000000000..2483dde6ebae
--- /dev/null
+++ b/app-misc/birthday/Manifest
@@ -0,0 +1,6 @@
+DIST birthday-1.6.2.tar.bz2 85617 SHA256 355ad07ad3312d8f5c5b54c71596ac3a0e706c539167900d73cb65df30c8e2f4 SHA512 5081cd9f875260758d209165803715d3eb19e2256344172cb3ea01f87f859215ce68e29174c22eec467bdb6eebc11627a71674321bb9b96db9562d13cdc80882 WHIRLPOOL 226a0293a2a3b91dfd6eae09680a7e2df56de1c2329332574c2d4eb5be9520106309cccead7c71439d5b9f3149798d25321c167eda2ead3f972630698cd6665b
+EBUILD birthday-1.6.2-r1.ebuild 711 SHA256 8dbbaa4aee154ad14011a59d170b9c27d754427e787a4e213e0f2861566f3932 SHA512 5e4a0442541c083e8acf9e7247a9dace9461906c2fa5e1225e9b9c769ba92196e57eca36b554725354b68d819548f105b1623a683038df8fa6f1173d76fd55ef WHIRLPOOL a4292075185a8b19dbceca6c5248c3291e985e8dd8c0ef8ebad7d43c782f64ded2cb86b520141ae15622c15f90f4eccfe0f75a99880e42a438d583448fb2f386
+EBUILD birthday-1.6.2.ebuild 813 SHA256 e7bae80b456c6ecf18e284213e9bc2bb9135be26e3d7b8cc785e8e155fb32261 SHA512 48e2f5a7ab3a05008128803596af6be46227838614182c46f795de598539c9ea5adc7c22becb030d7f8bc47b69eac67ac2f2f77b1689863bd8958e9e2c653f28 WHIRLPOOL ca55cb1e915a042451a124945111c48b4cee8afb50a9889cc3d19f86ff5ff09ef952634dc83fda14b12dc54efa243916e874161d602a236155d031c19358c6c5
+MISC ChangeLog 3013 SHA256 36d63d6d1a30ff058ead875f5b5adf18b71fbfb92cd4a4a390b1e6666b62ec05 SHA512 c9addcdbbceb7779260e88dab8671715cdee67af170e3fc056d058b03200f34b47baa1b466b88107af1c364a40452cb97b51c4421a62bf32d209308e92a8bae1 WHIRLPOOL 242ac642445e34b2dd96fab1e075e09d47cae2f44eb1d9ac99fe14968ae879893fc2864988f07c7746498e89c0b303d961a84236cafcaeb02f80dc4bae2ffd4a
+MISC ChangeLog-2015 1990 SHA256 fc485e4a37fe6f34d544ec0a415ace63439c7d04838dc5f75d2df06d2e50f7da SHA512 7b9def7f5c695cb51067391acf14076dae60786d81442914f2ae2e5cb9ddc8f48686fb7cea82d6fd71b8a9ca700356a47f6247aaece87535308c3e91eca59e1f WHIRLPOOL 45660a75f281ba8fc49a698bd8b1f85b48903a90bd2f2cad68b5112da98ef5a59b64fb94955fc44b104dbdd08e759eac0931c5bbcf0854187f84ab3f262071e3
+MISC metadata.xml 343 SHA256 f634e0102d90da6c00bdca7d60675224622222dd050dbe5b0d7bcc8227cc14cf SHA512 1090fa6925bc056aba45841ccfdd8df241414eb187cb7a8d95379a65c3ef950849cf9e42d8f4dac1d44d2e7ae65f51d9498cee5e523a535ece88e553a75a1261 WHIRLPOOL 7f492df79a79fca8e981940970873cb44405c526dcc299e65261a5629a509b183708a0244229fadb4b1a18e0ed60ee939be72dd19f37ae156dc5c074087ac4af
diff --git a/app-misc/birthday/birthday-1.6.2-r1.ebuild b/app-misc/birthday/birthday-1.6.2-r1.ebuild
new file mode 100644
index 000000000000..caf191e6de43
--- /dev/null
+++ b/app-misc/birthday/birthday-1.6.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Displays a list of events happening in the near future"
+HOMEPAGE="https://sourceforge.net/projects/birthday/"
+SRC_URI="mirror://sourceforge/birthday/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ # Don't strip, install in correct share dir and respect CFLAGS
+ sed \
+ -e "s:install -s:install:g" -e "s:#SHARE:SHARE:g" -e "s:-O2:${CFLAGS}:g" \
+ -i Makefile || die
+ sed \
+ -e 's:grep -v:grep --binary-files=text -v:g' \
+ -i runtest.sh || die
+
+ default
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
diff --git a/app-misc/birthday/birthday-1.6.2.ebuild b/app-misc/birthday/birthday-1.6.2.ebuild
new file mode 100644
index 000000000000..cfdfb29b5b28
--- /dev/null
+++ b/app-misc/birthday/birthday-1.6.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit toolchain-funcs
+
+DESCRIPTION="Displays a list of events happening in the near future"
+HOMEPAGE="https://sourceforge.net/projects/birthday/"
+SRC_URI="mirror://sourceforge/birthday/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Don't strip, install in correct share dir and respect CFLAGS
+ sed \
+ -e "s:install -s:install:g" -e "s:#SHARE:SHARE:g" -e "s:-O2:${CFLAGS}:g" \
+ -i Makefile || die
+ sed \
+ -e 's:grep -v:grep --binary-files=text -v:g' \
+ -i runtest.sh || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
diff --git a/app-misc/birthday/metadata.xml b/app-misc/birthday/metadata.xml
new file mode 100644
index 000000000000..6461f9f10b33
--- /dev/null
+++ b/app-misc/birthday/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Shell Tools Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">birthday</remote-id>
+ </upstream>
+</pkgmetadata>