summaryrefslogtreecommitdiff
path: root/app-misc/birthday
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-01 03:14:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-01 03:14:33 +0100
commit0c764edfecb7e9e124d4669acd98bed09e23b6c0 (patch)
tree2862ab17d2f88cb7c9614b7fbe579f25ae604b8d /app-misc/birthday
parentae1bf373db295b495e1f685d116e3411bf10df0b (diff)
gentoo auto-resync : 01:08:2022 - 03:14:32
Diffstat (limited to 'app-misc/birthday')
-rw-r--r--app-misc/birthday/Manifest3
-rw-r--r--app-misc/birthday/birthday-1.6.2-r2.ebuild (renamed from app-misc/birthday/birthday-1.6.2-r1.ebuild)20
-rw-r--r--app-misc/birthday/files/birthday-1.6.2-makefile.patch44
3 files changed, 50 insertions, 17 deletions
diff --git a/app-misc/birthday/Manifest b/app-misc/birthday/Manifest
index ba8bae5ff965..667a0641bbd7 100644
--- a/app-misc/birthday/Manifest
+++ b/app-misc/birthday/Manifest
@@ -1,3 +1,4 @@
+AUX birthday-1.6.2-makefile.patch 1194 BLAKE2B e8a78b51ace48de9cfdea9b9e91530e6a30fa99d607fc65affc397738bc66d039c0a27532e84b0d6728fd51979d868357d1c28981959f3b2959135ef28240d32 SHA512 76043caa8cadbcd205e840408ff8e827f3ac9f0ea41229acf7ae4d16510113945edc66ebe7318f2af6418ce14c1d8ceb3b94d19d0fdb0f95c667370817a98540
DIST birthday-1.6.2.tar.bz2 85617 BLAKE2B bb922b4dbec35e967f5b0060a13b5429fe01478159ab930e2924dc0d397c47c265384f71dac63bb0f3bb609a0c98099529680c8d097b747d857086d885d9bb4b SHA512 5081cd9f875260758d209165803715d3eb19e2256344172cb3ea01f87f859215ce68e29174c22eec467bdb6eebc11627a71674321bb9b96db9562d13cdc80882
-EBUILD birthday-1.6.2-r1.ebuild 705 BLAKE2B e7af77b60d5c2ac3b460170ccf9c8a39f903f42e3d089f3ae22049295e5ea09c5fb436f9e918656d3337281d03d5f2c5befe9c6130b6e69bacfed49e24471707 SHA512 9d377776db6ef3f0df6d7f6d975ef86d9982b69530e8586dd2bf677dbe1fc65d78181ec382ac6c25cadb8bf4c3e003941a3e8806f2d34c11010db62ee5bfdeed
+EBUILD birthday-1.6.2-r2.ebuild 459 BLAKE2B 0203360b59e8e72b2767d1d596ac0ec7932f0e8e893c9793328975e52b01d792feddbb81bdea2e5d1228a479c202a1f8ccac3865b1a5842923b84a5c920e2bb1 SHA512 58be71ede93a6222e20c86b1f7df99265deba98810a233cb96cd8be68d977ba89729092b0cc67b7554d36d3023f1f10652411194e1c50c80d8471243acca4448
MISC metadata.xml 344 BLAKE2B eaa132e66b7d38bde12ab05545fd99a62dd86bee5448d4326dbad994cb015ce3fc1de2e5495a7fd5af2091b000c3c2e03643373492013fe66c8c89ecb712d0bf SHA512 d29a2fd3b7c82afd5a8f14b94bd1fbac2f238c3846f22d3d95f1789adc980fcc70f416ebb75ff4cb2c37aa452c2be7a268f2a458c465494114c6b148b8df8931
diff --git a/app-misc/birthday/birthday-1.6.2-r1.ebuild b/app-misc/birthday/birthday-1.6.2-r2.ebuild
index 4d2088dc58c5..53041e6b6378 100644
--- a/app-misc/birthday/birthday-1.6.2-r1.ebuild
+++ b/app-misc/birthday/birthday-1.6.2-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
@@ -13,20 +13,8 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 sparc x86"
-src_prepare() {
- # Don't strip, install in correct share dir and respect CFLAGS
- sed \
- -e "s@install -s@install@g" \
- -e "s@#SHARE@SHARE@g" \
- -e "s@-O2@${CFLAGS}@g" \
- -i Makefile || die
- sed \
- -e 's@grep -v@grep --binary-files=text -v@g' \
- -i runtest.sh || die
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
- default
-}
-
-src_compile() {
- emake CC="$(tc-getCC)"
+src_configure() {
+ tc-export CC
}
diff --git a/app-misc/birthday/files/birthday-1.6.2-makefile.patch b/app-misc/birthday/files/birthday-1.6.2-makefile.patch
new file mode 100644
index 000000000000..f48102d929b7
--- /dev/null
+++ b/app-misc/birthday/files/birthday-1.6.2-makefile.patch
@@ -0,0 +1,44 @@
+--- a/Makefile
++++ b/Makefile
+@@ -12,7 +12,7 @@
+ else
+ OSCFLAGS=-Wall -Wstrict-prototypes
+ endif
+-CFLAGS=-O2 $(DEBUG) -D$(OS) $(OSCFLAGS)
++CFLAGS += $(DEBUG) -D$(OS) $(OSCFLAGS)
+
+ # engine
+ ENGSRC=bdengine.c xmalloc.c
+@@ -48,16 +48,15 @@
+
+ else
+ birthday: $(CMDOBJ)
+- $(CC) $(LDFLAGS) $(CMDOBJ) -o $@
++ $(CC) $(LDFLAGS) $(CMDOBJ) -o $@ $(LIBS)
+
+ # you can override this to use the new FHS locations.
+-SHARE=
+-#SHARE=/share
++SHARE=/share
+
+ install: birthday birthday.man
+- install -d $(DESTDIR)/usr/bin $(DESTDIR)/usr$(SHARE)/man/man1
+- install -s birthday $(DESTDIR)/usr/bin/birthday
+- install -m 0644 birthday.man $(DESTDIR)/usr$(SHARE)/man/man1/birthday.1
++ install -d $(DESTDIR)$(EPREFIX)/usr/bin $(DESTDIR)$(EPREFIX)/usr$(SHARE)/man/man1
++ install birthday $(DESTDIR)$(EPREFIX)/usr/bin/birthday
++ install -m 0644 birthday.man $(DESTDIR)$(EPREFIX)/usr$(SHARE)/man/man1/birthday.1
+
+ test: birthday
+ sh runtest.sh -exec `pwd`/birthday test/*.t
+--- a/runtest.sh
++++ b/runtest.sh
+@@ -7,7 +7,7 @@
+ unset PASSED FAILED TAKEN KEEP
+
+ extract_section() {
+- sed -ne "/^\\*$1/,/^\\*/p" "$2" | grep -v '^*'
++ sed -ne "/^\\*$1/,/^\\*/p" "$2" | grep --binary-files=text -v '^*'
+ }
+
+ runtest() {