summaryrefslogtreecommitdiff
path: root/app-misc/binwalk/binwalk-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /app-misc/binwalk/binwalk-9999.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'app-misc/binwalk/binwalk-9999.ebuild')
-rw-r--r--app-misc/binwalk/binwalk-9999.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/app-misc/binwalk/binwalk-9999.ebuild b/app-misc/binwalk/binwalk-9999.ebuild
index 650ee2faadf9..cd3986d63469 100644
--- a/app-misc/binwalk/binwalk-9999.ebuild
+++ b/app-misc/binwalk/binwalk-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7,3_8} )
inherit distutils-r1
@@ -19,12 +19,17 @@ HOMEPAGE="https://github.com/ReFirmLabs/binwalk"
LICENSE="MIT"
SLOT="0"
-IUSE="graph"
+IUSE="test"
+RESTRICT="!test? ( test )"
-RDEPEND="
- $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7)
- graph? ( dev-python/pyqtgraph[opengl,${PYTHON_USEDEP}] )
-"
+RDEPEND="$(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7)"
+BDEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.2.0-disable-test-coverage.patch )
+
+python_test() {
+ esetup.py test
+}
python_install_all() {
local DOCS=( API.md INSTALL.md README.md )