summaryrefslogtreecommitdiff
path: root/app-misc/astrolog
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/astrolog
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/astrolog')
-rw-r--r--app-misc/astrolog/Manifest3
-rw-r--r--app-misc/astrolog/astrolog-5.40-r3.ebuild70
-rw-r--r--app-misc/astrolog/metadata.xml5
3 files changed, 78 insertions, 0 deletions
diff --git a/app-misc/astrolog/Manifest b/app-misc/astrolog/Manifest
new file mode 100644
index 000000000000..12babe4c7bc1
--- /dev/null
+++ b/app-misc/astrolog/Manifest
@@ -0,0 +1,3 @@
+DIST ast54unx.shr 1465432 BLAKE2B 9eec58fb66110a7fd072eee8b02dda109a22c1a1d59506943011041ab595e33eac39f5372ab55f587bcdfb447e599b16b8a9f0ccd04c54257b0dd38a85acde08 SHA512 824fcea1891dafc77692e84a36cc97a8afd90ad93d772edab8437e89869cdc912002f628fd86eecc8182ba4f1ad02cb98f42a30fde425bf94cf59f852b4eda1a
+EBUILD astrolog-5.40-r3.ebuild 2124 BLAKE2B 4d14b95dbbd64b513c95de7b9999d9706d7d59b73a54207e6768b0c49a1d468bc0c118d062936fba3132ff63dfb032819cd7acedbfa687af23875a2ec686fffa SHA512 5f24d1d927d3a18d6e8ae080135b9f6ef7a8093ebb3ba8eb1a4b6e7d3ec5e2c1bd74342c157cda7deab15733ed9c82a7837d1bbf545adc2c327cdaf36e4a052b
+MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-misc/astrolog/astrolog-5.40-r3.ebuild b/app-misc/astrolog/astrolog-5.40-r3.ebuild
new file mode 100644
index 000000000000..04fdcd95eae3
--- /dev/null
+++ b/app-misc/astrolog/astrolog-5.40-r3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A many featured astrology chart calculation program"
+HOMEPAGE="http://www.astrolog.org/astrolog.htm"
+SRC_URI="http://www.astrolog.org/ftp/ast54unx.shr"
+
+LICENSE="astrolog"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="X"
+
+DEPEND="X? ( x11-libs/libX11 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ sh "${DISTDIR}"/ast54unx.shr || die
+}
+
+src_prepare() {
+ default
+
+ # remove stripping of created binary, dump hardcoded CFLAGS,
+ # respect CC (bug #243606), and CFLAGS (bug #240057)
+ sed \
+ -e 's:strip:#strip:' -e 's:^CFLAGS = :#CFLAGS = :' \
+ -e 's:\tcc :\t$(CC) $(CFLAGS) $(LDFLAGS) :' \
+ -i Makefile || die
+
+ # we use /usr/share/astrolog for config and (optional) ephemeris-data-files
+ sed -i -e "s:~/astrolog:/usr/share/astrolog:g" astrolog.h || die
+
+ # if we use X, we need to add -L/usr/X11R6/lib to compile succesful
+ #use X && sed -i -e "s:-lm -lX11:-lm -lX11 -L/usr/X11R6/lib:g" Makefile
+
+ # if we do NOT use X, we disable it by removing the -lX11 from the Makefile
+ # and remove the "#define X11" and "#define MOUSE" from astrolog.h
+ use X || ( sed -i -e "s:-lm -lX11:-lm:g" Makefile || die
+ sed -i -e "s:#define X11:/*#define X11:g" astrolog.h || die
+ sed -i -e "s:#define MOUSE:/*#define MOUSE:g" astrolog.h || die)
+
+ # any user may have an own astrolog configfile
+ #sed -i -e "s:astrolog.dat:astrolog.dat:g" astrolog.h || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin astrolog
+ dodoc Helpfile.540 README.1ST README.540 Update.540
+ insinto /usr/share/astrolog
+ doins astrolog.dat
+}
+
+pkg_postinst() {
+ elog "There is a sample config file /usr/share/astrolog/astrolog.dat"
+ elog "astrolog looks in current dir for a file astrolog.dat before"
+ elog "using the file in /usr/share/astrolog"
+ elog "If you want extended accuracy of astrolog's calculations you"
+ elog "can emerge the optional package \"astrolog-ephemeris\" which"
+ elog "needs ~4.7 MB additional diskspace for the ephemeris-files"
+}
diff --git a/app-misc/astrolog/metadata.xml b/app-misc/astrolog/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/app-misc/astrolog/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>