summaryrefslogtreecommitdiff
path: root/app-misc/astrolog
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-19 15:38:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-19 15:38:48 +0100
commit3b882b15eed3bb219b5f340b63733c8cda643079 (patch)
treec84890953bd9a939137323d667a7762da89f0f0c /app-misc/astrolog
parent4d9aef45678c7cb55b24107642790224ab8c153b (diff)
gentoo auto-resync : 19:08:2023 - 15:38:48
Diffstat (limited to 'app-misc/astrolog')
-rw-r--r--app-misc/astrolog/Manifest2
-rw-r--r--app-misc/astrolog/astrolog-7.60.ebuild67
-rw-r--r--app-misc/astrolog/files/astrolog-7.60-drop-resiters.patch36
3 files changed, 105 insertions, 0 deletions
diff --git a/app-misc/astrolog/Manifest b/app-misc/astrolog/Manifest
index a7c5415e5165..0fb61252c5d7 100644
--- a/app-misc/astrolog/Manifest
+++ b/app-misc/astrolog/Manifest
@@ -1,3 +1,5 @@
+AUX astrolog-7.60-drop-resiters.patch 1354 BLAKE2B f986926b3ec4653bb17cb0363ebdf06896d68c140201a4ae714ba2aaf231717349c6e0426906e06561b1ef6f1e241d3b92d7020c357ecd438ebeeada617b9cfa SHA512 68bf5c0ade2c3cee96f198e3092930bff003e6913bfd5ae0fc16e7b381509f0bbb213c2d08009d4c9485e64be44293024a853b5efb19b837f700ffb292cb3593
DIST ast74src.zip 4483648 BLAKE2B d15d3e5d98337c5c5884973d079cffda9144a5c9f43ab48dd38f782eeef089d9fd5fb3f5a01f1d607bd2134e6a774494d4cf7d99e117d3092c8787626436e778 SHA512 540bda7ee10cde0723f6bd4afe410e4e9c59168e31dbdbd0b3b62a9e77ae83a971543fc812876258e2b7b9636f880c74b9be5497c54e7dd0e9b444bad2edbf6b
EBUILD astrolog-7.40.ebuild 1864 BLAKE2B 2e7e7b1902509516c193437dec820316e516c328ec44f5275d609990a512722909b0841b7780e86d162e0475275906579c978eea30503e42bd53c56d93e10a59 SHA512 495f9325356add4eefd40bb00c3c3271cf339b8304901f19fec0978893ef1891cc86372ad456e8653ce7b5447a0489126b9cb6fe059aecc648f3a1f527274c3d
+EBUILD astrolog-7.60.ebuild 1927 BLAKE2B dbef410b222c3b5490f87ec6a0b8c4113aac7f285bd92112509a0288604f09234fc9787176b0410d27ef84fcb1240eed049ec0c0b966971adccbb474e6fbbd11 SHA512 344871dde81b1ad19982cdab8e6d69b966889d3c1e19d2fa1d1a408d76fcb0844d4e4875493c7e5dd13efb79e4a5f6204ab601ea398bfb95ed1276e8df9801aa
MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/app-misc/astrolog/astrolog-7.60.ebuild b/app-misc/astrolog/astrolog-7.60.ebuild
new file mode 100644
index 000000000000..18d1dc655924
--- /dev/null
+++ b/app-misc/astrolog/astrolog-7.60.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Please bump with app-misc/astrolog-ephemeris
+
+inherit toolchain-funcs
+
+DESCRIPTION="A many featured astrology chart calculation program"
+HOMEPAGE="https://www.astrolog.org/astrolog.htm"
+SRC_URI="https://www.astrolog.org/ftp/ast74src.zip"
+
+LICENSE="astrolog"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="X"
+
+DEPEND="X? ( x11-libs/libX11 )"
+RDEPEND="${DEPEND}"
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-7.60-drop-resiters.patch
+)
+
+src_prepare() {
+ default
+
+ # remove stripping of created binary, dump hardcoded CFLAGS,
+ # respect CC (bug #243606), and CFLAGS (bug #240057)
+ sed \
+ -e 's:strip:#strip:' -e 's:^CFLAGS = :#CFLAGS = :' \
+ -e 's:\tcc :\t$(CC) $(CFLAGS) $(LDFLAGS) :' \
+ -i Makefile || die
+
+ # we use /usr/share/astrolog for config and (optional) ephemeris-data-files
+ sed -i -e "s:~/astrolog:/usr/share/astrolog:g" astrolog.h || die
+
+ # if we do NOT use X, we disable it by removing the -lX11 from the Makefile
+ # and remove the "#define X11" and "#define MOUSE" from astrolog.h
+ use X || ( sed -i -e "s:-lm -lX11:-lm:g" Makefile || die
+ sed -i -e "s:#define X11:/*#define X11:g" astrolog.h || die
+ sed -i -e "s:#define MOUSE:/*#define MOUSE:g" astrolog.h || die)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin astrolog
+ dodoc astrolog.doc changes.doc
+ insinto /usr/share/astrolog
+ doins astrolog.as
+}
+
+pkg_postinst() {
+ elog "There is a sample config file /usr/share/astrolog/astrolog.as"
+ elog "astrolog looks in current dir for a file astrolog.as before"
+ elog "using the file in /usr/share/astrolog"
+ elog "If you want extended accuracy of astrolog's calculations you"
+ elog "can emerge the optional package \"astrolog-ephemeris\" which"
+ elog "needs ~32.9 MB additional diskspace for the ephemeris-files"
+}
diff --git a/app-misc/astrolog/files/astrolog-7.60-drop-resiters.patch b/app-misc/astrolog/files/astrolog-7.60-drop-resiters.patch
new file mode 100644
index 000000000000..ae399f8e099d
--- /dev/null
+++ b/app-misc/astrolog/files/astrolog-7.60-drop-resiters.patch
@@ -0,0 +1,36 @@
+Bug: https://bugs.gentoo.org/894524
+Sent patch upstream, dev said they will take it in coming version,
+https://github.com/CruiserOne/Astrolog/pull/20#issuecomment-1666693982
+--- a/placalc.cpp
++++ b/placalc.cpp
+@@ -561,8 +561,8 @@ int hel(int planet, REAL8 t, REAL8 *al, REAL8 *ar, REAL8 *az, REAL8 *alp,
+ /* speed in radius, AU per day */
+ /* speed in z, AU per day */
+ {
+- register struct elements *e;
+- register struct eledata *d;
++ struct elements *e;
++ struct eledata *d;
+ REAL8 lk = 0.0;
+ REAL8 rk = 0.0;
+ REAL8 b, h1, sini, sinv, cosi, cosu, cosv, man, truanom, esquare,
+@@ -686,7 +686,7 @@ int hel(int planet, REAL8 t, REAL8 *al, REAL8 *ar, REAL8 *az, REAL8 *alp,
+ }
+
+
+-void disturb(register struct kor *k, REAL8 *al, REAL8 *ar, REAL8 lk, REAL8 rk,
++void disturb(struct kor *k, REAL8 *al, REAL8 *ar, REAL8 lk, REAL8 rk,
+ REAL8 man)
+ /* ENDMARK-terminated array of struct kor */
+ /* longitude in degrees, use a pointer to return value */
+--- a/placalc.h
++++ b/placalc.h
+@@ -256,7 +256,7 @@ extern REAL8 test_near_zero(REAL8);
+ extern REAL8 deltat(double);
+ extern void to_mean_ekl();
+ extern int afl2planet();
+-extern void disturb(register struct kor *, REAL8 *, REAL8 *, REAL8, REAL8,
++extern void disturb(struct kor *, REAL8 *, REAL8 *, REAL8, REAL8,
+ REAL8);
+ extern REAL8 fnu(REAL8, REAL8, REAL8);
+