summaryrefslogtreecommitdiff
path: root/app-misc/astrolog
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-misc/astrolog
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-misc/astrolog')
-rw-r--r--app-misc/astrolog/Manifest2
-rw-r--r--app-misc/astrolog/astrolog-7.40.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/app-misc/astrolog/Manifest b/app-misc/astrolog/Manifest
index 898a298d2d84..d8053908a497 100644
--- a/app-misc/astrolog/Manifest
+++ b/app-misc/astrolog/Manifest
@@ -1,3 +1,5 @@
DIST ast54unx.shr 1465432 BLAKE2B 9eec58fb66110a7fd072eee8b02dda109a22c1a1d59506943011041ab595e33eac39f5372ab55f587bcdfb447e599b16b8a9f0ccd04c54257b0dd38a85acde08 SHA512 824fcea1891dafc77692e84a36cc97a8afd90ad93d772edab8437e89869cdc912002f628fd86eecc8182ba4f1ad02cb98f42a30fde425bf94cf59f852b4eda1a
+DIST ast74src.zip 4483648 BLAKE2B d15d3e5d98337c5c5884973d079cffda9144a5c9f43ab48dd38f782eeef089d9fd5fb3f5a01f1d607bd2134e6a774494d4cf7d99e117d3092c8787626436e778 SHA512 540bda7ee10cde0723f6bd4afe410e4e9c59168e31dbdbd0b3b62a9e77ae83a971543fc812876258e2b7b9636f880c74b9be5497c54e7dd0e9b444bad2edbf6b
EBUILD astrolog-5.40-r3.ebuild 2124 BLAKE2B 4d14b95dbbd64b513c95de7b9999d9706d7d59b73a54207e6768b0c49a1d468bc0c118d062936fba3132ff63dfb032819cd7acedbfa687af23875a2ec686fffa SHA512 5f24d1d927d3a18d6e8ae080135b9f6ef7a8093ebb3ba8eb1a4b6e7d3ec5e2c1bd74342c157cda7deab15733ed9c82a7837d1bbf545adc2c327cdaf36e4a052b
+EBUILD astrolog-7.40.ebuild 1820 BLAKE2B 40aa2aa3af7df61c70c9b46237648f31d946116e6c6c2adeacb5c6477d931c2e3a12d3f2fd2cf01b733b9023dda566586b597fd0774e8452164886d55ea51504 SHA512 bb5d550b49925a0210e2e567eb1cc0d19aa9f663277dc100da44023bc62455eab85fdf47fc6e3a2655698dea6eab611c415949c359c710f4a00afb122ccce548
MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/app-misc/astrolog/astrolog-7.40.ebuild b/app-misc/astrolog/astrolog-7.40.ebuild
new file mode 100644
index 000000000000..ede487c65b7d
--- /dev/null
+++ b/app-misc/astrolog/astrolog-7.40.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A many featured astrology chart calculation program"
+HOMEPAGE="https://www.astrolog.org/astrolog.htm"
+SRC_URI="https://www.astrolog.org/ftp/ast74src.zip"
+
+LICENSE="astrolog"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="X"
+
+DEPEND="X? ( x11-libs/libX11 )"
+RDEPEND="${DEPEND}"
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+
+ # remove stripping of created binary, dump hardcoded CFLAGS,
+ # respect CC (bug #243606), and CFLAGS (bug #240057)
+ sed \
+ -e 's:strip:#strip:' -e 's:^CFLAGS = :#CFLAGS = :' \
+ -e 's:\tcc :\t$(CC) $(CFLAGS) $(LDFLAGS) :' \
+ -i Makefile || die
+
+ # we use /usr/share/astrolog for config and (optional) ephemeris-data-files
+ sed -i -e "s:~/astrolog:/usr/share/astrolog:g" astrolog.h || die
+
+ # if we do NOT use X, we disable it by removing the -lX11 from the Makefile
+ # and remove the "#define X11" and "#define MOUSE" from astrolog.h
+ use X || ( sed -i -e "s:-lm -lX11:-lm:g" Makefile || die
+ sed -i -e "s:#define X11:/*#define X11:g" astrolog.h || die
+ sed -i -e "s:#define MOUSE:/*#define MOUSE:g" astrolog.h || die)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin astrolog
+ dodoc astrolog.doc changes.doc
+ insinto /usr/share/astrolog
+ doins astrolog.as
+}
+
+pkg_postinst() {
+ elog "There is a sample config file /usr/share/astrolog/astrolog.as"
+ elog "astrolog looks in current dir for a file astrolog.as before"
+ elog "using the file in /usr/share/astrolog"
+ elog "If you want extended accuracy of astrolog's calculations you"
+ elog "can emerge the optional package \"astrolog-ephemeris\" which"
+ elog "needs ~32.9 MB additional diskspace for the ephemeris-files"
+}