summaryrefslogtreecommitdiff
path: root/app-misc/asciinema/asciinema-2.2.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-misc/asciinema/asciinema-2.2.0-r1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-misc/asciinema/asciinema-2.2.0-r1.ebuild')
-rw-r--r--app-misc/asciinema/asciinema-2.2.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-misc/asciinema/asciinema-2.2.0-r1.ebuild b/app-misc/asciinema/asciinema-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..af3286ed6ef5
--- /dev/null
+++ b/app-misc/asciinema/asciinema-2.2.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Command line recorder for asciinema.org service"
+HOMEPAGE="https://asciinema.org/ https://pypi.org/project/asciinema/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+
+PATCHES=(
+ "${FILESDIR}/asciinema-2.2.0-setup.patch"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -i -e "s|share/doc/asciinema|&-${PVR}|" setup.cfg || die
+}