summaryrefslogtreecommitdiff
path: root/app-misc/actkbd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/actkbd
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/actkbd')
-rw-r--r--app-misc/actkbd/Manifest6
-rw-r--r--app-misc/actkbd/actkbd-0.2.8-r2.ebuild48
-rw-r--r--app-misc/actkbd/files/actkbd-0.2.7-amd64.patch38
-rw-r--r--app-misc/actkbd/files/actkbd.confd12
-rw-r--r--app-misc/actkbd/files/actkbd.initd31
-rw-r--r--app-misc/actkbd/metadata.xml9
6 files changed, 144 insertions, 0 deletions
diff --git a/app-misc/actkbd/Manifest b/app-misc/actkbd/Manifest
new file mode 100644
index 000000000000..e8726d6ec790
--- /dev/null
+++ b/app-misc/actkbd/Manifest
@@ -0,0 +1,6 @@
+AUX actkbd-0.2.7-amd64.patch 1188 BLAKE2B b9dc0dac0241038a70e1bb4c3e7b0105326bd18bb5c3af55221a039879eb0cf8171b8ebe6b6819dc25bbd51476fd012d9db2f21ff0ad34580366df60f3c5bbd8 SHA512 921b5f654aabe06eb0589cf1b22bf44e3c7c662b088104dff8d439929ffa05fc6f658619bc54f5b0fa813a396ae740f05a121515af8f546395250a55a722dab0
+AUX actkbd.confd 276 BLAKE2B d06f7e45cbe94b042384186b2b47b69e2e657e2a9b5845d2427b8bfe0c09d2c319e53c78e6576b8b6dbbba8dd60325c2e92e6e88d5cd231cffda38b075d795ae SHA512 2128c4c3e1754014e7e1e446ce6d8753045d517c500a957ceb0e761d60c0141c6fc26f427891d2937c5cb56c60759b9045ba21418d2f57bd8dca11c10ade18bf
+AUX actkbd.initd 782 BLAKE2B a5c95e50da4c0ecd20ddd6d1426b19a8ea47e1b1495d7b5cf8e61bb8d26072acf2d07aacc4714b1b000ba63c1233c9d007ab32d5c4e12b7ea323d2e0d078f8a2 SHA512 1d5d0e62a09562d7274807f18d8a34735b4ddb47bc2cb99374a8b62ffef8d5e553a682e273b57ef99460b1850730520e9f12b1ffeab8c39ddaec50595e100b8e
+DIST actkbd-0.2.8.tar.bz2 23192 BLAKE2B dd756023de258f95354d91b521343311648937af82f65fa03748a2924711ae6d1a78cb58be44b0fe01fa5d706bcc575e68afa2663798fa776a1af3dedbc81974 SHA512 307d97b2854be801f1a4a8a8fbc408d3c83efd40f5bb35ea463b154fc0c9761fcb83a99905cd2730a24122ff222f60f31c4ac0163600ba463d4713846de2bf72
+EBUILD actkbd-0.2.8-r2.ebuild 1197 BLAKE2B ee60d4cc240d951d8a573e01666266064ad9cd8645ebd3175a52843af3bc080d25e6e838b2948416e8ea484208824af001e9325e17574408d54133f8fbb5dad4 SHA512 3971370b2d2b9cafb4d9570ef65a233fa392a95d8378429dacc57f78e1f89fc8aab8413466d163fce84d071929f219abb0ae886e7cfa20071113171fc982f0c1
+MISC metadata.xml 351 BLAKE2B 9dcf03875f2de0000bb108421dc815047ffdf17244bacbb7ec36e5186a4e65cc19f1d2bce281867034c12dff082c4402039e00f863d29012618f799481e24dc9 SHA512 f40d5dc16d267d0bf0171d927157805a4b31a3e2816eb128d3b9e6f0aded5b45b1865c1e06ceccf56618f68a15682fc3f416e7af49af007073b50fdb383359cd
diff --git a/app-misc/actkbd/actkbd-0.2.8-r2.ebuild b/app-misc/actkbd/actkbd-0.2.8-r2.ebuild
new file mode 100644
index 000000000000..0b926c6873fa
--- /dev/null
+++ b/app-misc/actkbd/actkbd-0.2.8-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit linux-info eutils toolchain-funcs
+
+DESCRIPTION="A keyboard shortcut daemon"
+HOMEPAGE="http://users.softlab.ece.ntua.gr/~thkala/projects/actkbd/"
+SRC_URI="http://users.softlab.ece.ntua.gr/~thkala/projects/actkbd/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+CONFIG_CHECK="~INPUT_EVDEV"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.2.7-amd64.patch
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin actkbd
+ dodoc AUTHORS ChangeLog FAQ README TODO
+ docinto samples
+ dodoc samples/actkbd.conf
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}
+
+pkg_postinst() {
+ elog
+ elog "System-wide configuration file is /etc/actkbd.conf."
+ elog "Use actkbd.conf from usr/share/doc/${PF}/samples as a template."
+ elog "You need to create the config and set right input device from"
+ elog "/dev/input/event* in /etc/conf.d/actkbd"
+ elog
+ elog "To obtain keycodes for pressed combinations/keys just run:"
+ elog " # actkbd -s -d /dev/input/event<MYDEVICENUMBER>"
+}
diff --git a/app-misc/actkbd/files/actkbd-0.2.7-amd64.patch b/app-misc/actkbd/files/actkbd-0.2.7-amd64.patch
new file mode 100644
index 000000000000..b962d7e861a7
--- /dev/null
+++ b/app-misc/actkbd/files/actkbd-0.2.7-amd64.patch
@@ -0,0 +1,38 @@
+# Try to fix pointer assigned to int and vice-versa problems. Written by Joe Pelkey.
+
+diff -ru actkbd-0.2.7.orig/actkbd.h actkbd-0.2.7/actkbd.h
+--- actkbd-0.2.7.orig/actkbd.h 2006-05-02 13:24:01.000000000 -0400
++++ actkbd-0.2.7/actkbd.h 2006-10-27 03:37:37.000000000 -0400
+@@ -122,7 +122,7 @@
+ typedef struct _attr_t attr_t;
+ struct _attr_t {
+ int type; /* Attribute type */
+- void *opt; /* Options for this attribute */
++ int opt; /* Options for this attribute */
+ attr_t *next; /* The next node */
+ };
+
+diff -ru actkbd-0.2.7.orig/config.c actkbd-0.2.7/config.c
+--- actkbd-0.2.7.orig/config.c 2006-08-20 07:05:36.000000000 -0400
++++ actkbd-0.2.7/config.c 2006-10-27 03:55:21.000000000 -0400
+@@ -107,7 +107,7 @@
+ strtolower(attrs);
+ while ((tmp = strsep(&attrs, ", \t")) != NULL) {
+ int type = -1;
+- void *opt = NULL;
++ int opt = 0;
+ char *num = NULL;
+
+ if (strlen(tmp) == 0)
+@@ -174,9 +174,9 @@
+
+ errno = 0;
+ if (strlen(num) > 0) {
+- opt = (void *)((int)strtol(num, (char **)NULL, 10));
++ opt = ((int)strtol(num, (char **)NULL, 10));
+ } else {
+- opt = (void *)((int)(-1));
++ opt = ((int)(-1));
+ }
+
+ if (((int)opt < 0) &&
diff --git a/app-misc/actkbd/files/actkbd.confd b/app-misc/actkbd/files/actkbd.confd
new file mode 100644
index 000000000000..5c67b5151717
--- /dev/null
+++ b/app-misc/actkbd/files/actkbd.confd
@@ -0,0 +1,12 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# Configuration file
+CONFIG="/etc/actkbd.conf"
+
+# Event provider providing the keypress events
+EVENT_DEVICE="/dev/input/<DEVICE>"
+
+# PID
+PIDFILE="/var/run/actkbd.pid"
+
diff --git a/app-misc/actkbd/files/actkbd.initd b/app-misc/actkbd/files/actkbd.initd
new file mode 100644
index 000000000000..bb03870adb2f
--- /dev/null
+++ b/app-misc/actkbd/files/actkbd.initd
@@ -0,0 +1,31 @@
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+checkconfig() {
+ if [ ! -f ${CONFIG} ] ; then
+ eerror "Config file \"${CONFIG}\" does not exist. Create it prior launching the daemon."
+ return 1
+ fi
+ if [ ! -c ${EVENT_DEVICE} ] ; then
+ eerror "Device \"${EVENT_DEVICE}\" is not valid pointer to input provider."
+ return 1
+ fi
+}
+
+depend() {
+ before acpid
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting actkbd"
+ start-stop-daemon --start --quiet --pidfile ${PIDFILE} --exec /usr/bin/actkbd -- -c "${CONFIG}" -D -q -x -l -p "${PIDFILE}" -d "${EVENT_DEVICE}"
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping actkbd"
+ start-stop-daemon --stop --quiet --pidfile ${PIDFILE} --exec /usr/bin/actkbd
+ eend $?
+}
diff --git a/app-misc/actkbd/metadata.xml b/app-misc/actkbd/metadata.xml
new file mode 100644
index 000000000000..80d57fa74097
--- /dev/null
+++ b/app-misc/actkbd/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription>
+actkbd is a simple daemon that binds actions to keyboard events. It recognises
+key combinations and can handle press, repeat and release events.
+ </longdescription>
+</pkgmetadata>