summaryrefslogtreecommitdiff
path: root/app-metrics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
commitcb3e8c6af7661fbcafdcacc7e0ecdfb610d098fa (patch)
tree047fc92023c520d07f13ec5ac96e094d1b312a7a /app-metrics
parent7b9f15840068dfaeea5684f8a1af1fe460dfa14c (diff)
gentoo resync : 09.06.2018
Diffstat (limited to 'app-metrics')
-rw-r--r--app-metrics/Manifest.gzbin3257 -> 3257 bytes
-rw-r--r--app-metrics/prometheus/Manifest2
-rw-r--r--app-metrics/prometheus/prometheus-2.3.0.ebuild70
3 files changed, 72 insertions, 0 deletions
diff --git a/app-metrics/Manifest.gz b/app-metrics/Manifest.gz
index 9f419a4280f5..237358e57aed 100644
--- a/app-metrics/Manifest.gz
+++ b/app-metrics/Manifest.gz
Binary files differ
diff --git a/app-metrics/prometheus/Manifest b/app-metrics/prometheus/Manifest
index be914f90617c..0c896b409e6a 100644
--- a/app-metrics/prometheus/Manifest
+++ b/app-metrics/prometheus/Manifest
@@ -1,5 +1,7 @@
AUX prometheus-3.initd 851 BLAKE2B 600d9e541206f99c0ddddc0f5a1d37d9bea69d8f45ce6562a2d3c040a75c3665d9862829fc44134db2fbbbbf1d38b7dc4010c9c284f5af38f0dd2cf4be1f9d11 SHA512 7d3650ef5b632507ade4cfb00a167ec7c2d3d8e91551ef8f4550f9947038df0b22a3dd0a33e093296eeb0ca88f1d12ae40e73c7fec4df03e5dcc7630893ded59
AUX prometheus.confd 43 BLAKE2B c83afa8ad1133c9e93abd40c862ff5b3ac9a3b3c4447b915ae1482d92096dec9f200d089de2458a6cdb0e72d2bf0652d56e3afd6d5a3cd8a3ed7a6c9a0e3e42c SHA512 37468e897cd34b50b0edc65ada3f0c2e05459c3d96bb7f82d58b6de5bf10a127f1bf7912af93d83d94e3ea7287cfeb2311e36535f291d01a11d152a0b438591c
DIST prometheus-2.2.1.tar.gz 5629500 BLAKE2B 7645267a2c5ed1c4138a5dd3929a48cb9dfa27789db38e98addbb06c37c6b482abfcf296ef1a5836bebd971d8224136c24a4ccd3093175882bb0beda1673deff SHA512 a94cf867de2b3be65b0a07307f89ebfa9c0a319820a72b3b6691edcd2e2b56b5268d27fb52bdaefea0e7084906d69b818e5292a39ccd5991e04e56d594f56ea7
+DIST prometheus-2.3.0.tar.gz 6171790 BLAKE2B bf08aaa124925a6fa1f610117919b5d4d15f4f4a71ff1bed1edca588b7cd4a14483a7ecbf3b3aaf5bfabe968290732b9fe3da522f726b673e0b910d2be3ead3e SHA512 2ab2bc2cc7c9bd9cafa16f54e24845b2e5c4b923bbc200ad9efae985b56587752892a364f08673e34278e6f8ad0b477482eec56632b281212af13a9110940aca
EBUILD prometheus-2.2.1.ebuild 2022 BLAKE2B 35b2eb824625cac8505bcc933130dd2810fd19855f73d975ef1e665baf98a60b95d4f3afcac1edc4b9cb2d6a030e7aeecff9926a460fddd9ea4ad8fa9f34cd6b SHA512 e378cbd27a7e2d033bf2ab6203955207d27f879f8c040cc54e873db8e64b225bf7aa6e977238d0203e00fe688c6328fef611516aea6d8e4afc4a5ea4649df127
+EBUILD prometheus-2.3.0.ebuild 2022 BLAKE2B 894d843ed2df1d5c9f6aaf084d1d1f4f726d2e01d6eb6dad44b435f72f79ea8ddcc3d84e617cba5a9b1aeb2fc48428440251260b7d10a1160d0f6437ce3d6ea4 SHA512 d0cbb12ac9da43f2e27aabaf0a0b7b534b297aca132dfeafcd5e2cd4528a2ad048c324e561f7ccb6874126c370ff0f44c2bcfb65d0fc70b6da6320dd5609dd9f
MISC metadata.xml 331 BLAKE2B 80bf59233349fc1fdc6c102fb65ba146bcde2c5c2a6039ec9b9f50f21a36fb1e8c864cba422e721d01216c792ffcf0429a3a840540305442b5e516ac09c03850 SHA512 06fd0da413c0280a902bbdf50e1e0557375d2208021fda3c3081d8a25a4b17ad1ca647d994dd97ba2d838ea5c87148d3ffd13a8a54cb8dc007b45927df8de47a
diff --git a/app-metrics/prometheus/prometheus-2.3.0.ebuild b/app-metrics/prometheus/prometheus-2.3.0.ebuild
new file mode 100644
index 000000000000..f437abf471ab
--- /dev/null
+++ b/app-metrics/prometheus/prometheus-2.3.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/prometheus"
+MY_PV=${PV/_rc/-rc.}
+EGIT_COMMIT="v${MY_PV}"
+PROMETHEUS_COMMIT="290d717"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus monitoring system and time series database"
+HOMEPAGE="https://github.com/prometheus/prometheus"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=dev-lang/go-1.10
+ dev-util/promu"
+
+PROMETHEUS_HOME="/var/lib/prometheus"
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup prometheus
+ enewuser prometheus -1 -1 "${PROMETHEUS_HOME}" prometheus
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${PROMETHEUS_COMMIT}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" promu build -v || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin promtool prometheus
+ dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
+ insinto /etc/prometheus
+ doins documentation/examples/prometheus.yml
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
+ popd || die
+
+ newinitd "${FILESDIR}"/prometheus-3.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "This release requires a clean storage directory and is not compatible with"
+ ewarn "files created by previous beta releases"
+ fi
+}