summaryrefslogtreecommitdiff
path: root/app-metrics/prometheus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /app-metrics/prometheus
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'app-metrics/prometheus')
-rw-r--r--app-metrics/prometheus/Manifest3
-rw-r--r--app-metrics/prometheus/prometheus-2.19.1.ebuild65
2 files changed, 68 insertions, 0 deletions
diff --git a/app-metrics/prometheus/Manifest b/app-metrics/prometheus/Manifest
index 5d45b5ce0a84..01dcdc5e5483 100644
--- a/app-metrics/prometheus/Manifest
+++ b/app-metrics/prometheus/Manifest
@@ -1,5 +1,8 @@
AUX prometheus.confd 43 BLAKE2B c83afa8ad1133c9e93abd40c862ff5b3ac9a3b3c4447b915ae1482d92096dec9f200d089de2458a6cdb0e72d2bf0652d56e3afd6d5a3cd8a3ed7a6c9a0e3e42c SHA512 37468e897cd34b50b0edc65ada3f0c2e05459c3d96bb7f82d58b6de5bf10a127f1bf7912af93d83d94e3ea7287cfeb2311e36535f291d01a11d152a0b438591c
AUX prometheus.initd 929 BLAKE2B d48650b11b77d4d04b5458682456fb20f8085dc3efe9d0ddd2a6c75751ddae156bbb83c20082bc7b6833395602c24da61e2f7610bdff291e05e3eeb4fb651317 SHA512 504122eb8ed19beac81987b77eb78bba9b36b2ef15f28b1a542804271046e06363baf464f3c303982f647eba65fbc2b5459235f56625e1ff3fed9834937cd0d2
DIST prometheus-2.13.1.tar.gz 15249891 BLAKE2B 35cd3c81bdb4f3a783c2ab1f1318946db5b25c94496fe351739a59259a726bf54d418d6b29efeff44c8007353ed63368819ce89ffe6a4f380b7ae216da3c4d63 SHA512 aed3b44db97cd2a67add64d13e950246b25c2b459f6b1081a6c548862c4e85c055254a0dfb94b08ac85f83dbbe30afceb1c54a8ad6f7ff1367aeb6af6d270e8a
+DIST prometheus-2.19.1-assets.tar.gz 5032055 BLAKE2B 75bc247d3dfbcccf3a9d7ef8a23fabe2d92d698670f5aabb19e1ee019e0197aa4fd49cfd53353e09a765a014af70ad860c7d1b6bce292632e5ed1175dd206ae9 SHA512 52d1f80d9ab2de778e8a0c81549ff83647d3d8af37ccf535a6fc4ac45fe29f25f6592e9b5eb137cd5ed6f6730835e4ba52b6c4c82e5b0bb2336b90c809d756de
+DIST prometheus-2.19.1.tar.gz 13343138 BLAKE2B 042f2c6e10e3d7f50b2373d9c3977db0318c8c9839e313463890ccae58c91d6d46c306d5aaeb795fb1a9649477b179999cb6b182aca9dee222d8fba557bf6d74 SHA512 a54a83b21ac8f3477e678ca365b8f04adcbe5cdd8a17d842eb9cd2e3428238841fb0492da6f4ec973f48803b0739667c734ae8a88b48d12555e23410e6461629
EBUILD prometheus-2.13.1.ebuild 2059 BLAKE2B 4614929b87ff860eac5b7b46d9b8f60474c51faab659699a0866dccaaef4d149214430d370dc5f0420c756d8d240da4cc8bb33b1948e6b4baf690c20b8905f06 SHA512 aac4922659750e6bcde07a8ef7823a5d8c4d47ccd1107a9f593b95079322031f4c8546b7d0d6df20f736a6a24d869105866c30eaf9e81773e21a6dcad27beac9
+EBUILD prometheus-2.19.1.ebuild 1942 BLAKE2B 4a644da79ba0ec628ede6636469a478d5c6166349c33b86d0667b55e927fb78be8e2e037ca8a87144860f7962b33da55c2d5d7892c556ae3635ec3208311b094 SHA512 7d63dff9863a248b2fee4e26e059d3ceda546c5c6d97f3cc08e0d11ba5030ac88c309370aedd3ac23b69289719be650dcaa670f1a78a56e37caca4074db485ba
MISC metadata.xml 334 BLAKE2B f35628a28c6087863ab4d96e1a4a3705f470845fe6c963c47457caf85e14cb1f99938b1b78bad2f87653f525c154f76c8e0e7b18d6f21d2cf10016eacc565984 SHA512 1a64169c81388848bb26d32e8706fb6d4fbcbde847b1e075f1eee297d5fd4b35ecc835e9ed16ac79825f8c17efac78271e6c8735809a57a8b4ed73b5a789300a
diff --git a/app-metrics/prometheus/prometheus-2.19.1.ebuild b/app-metrics/prometheus/prometheus-2.19.1.ebuild
new file mode 100644
index 000000000000..86894dfc6925
--- /dev/null
+++ b/app-metrics/prometheus/prometheus-2.19.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module user
+
+MY_PV=v${PV/_rc/-rc.}
+GIT_COMMIT=eba3fdcbf
+
+DESCRIPTION="Prometheus monitoring system and time series database"
+HOMEPAGE="https://github.com/prometheus/prometheus"
+SRC_URI="https://github.com/prometheus/prometheus/archive/${MY_PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~williamh/dist/${P}-assets.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+BDEPEND=">=dev-util/promu-0.3.0"
+DEPEND="!app-metrics/prometheus-bin"
+
+PROMETHEUS_HOME="/var/lib/prometheus"
+
+RESTRICT+=" test"
+
+pkg_setup() {
+ enewgroup prometheus
+ enewuser prometheus -1 -1 "${PROMETHEUS_HOME}" prometheus
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${GIT_COMMIT}/" .promu.yml || die
+ mv ../assets_vfsdata.go web/ui || die
+}
+
+src_compile() {
+ promu build --prefix bin -v || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
+ insinto /etc/prometheus
+ doins documentation/examples/prometheus.yml
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
+
+ newinitd "${FILESDIR}"/prometheus.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "This release requires a clean storage directory and is not compatible with"
+ ewarn "files created by previous beta releases"
+ fi
+}