summaryrefslogtreecommitdiff
path: root/app-metrics/prom2json
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-19 06:42:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-19 06:42:08 +0000
commitb2ec252cbc0a7476fb6892f96130c8cdc35591ac (patch)
treefaa70af7dbf41d6216e466c4b411639ea30cd45e /app-metrics/prom2json
parent5046e96fa41cb320765bdf30253b2a98c27fe94d (diff)
gentoo auto-resync : 19:01:2025 - 06:42:08
Diffstat (limited to 'app-metrics/prom2json')
-rw-r--r--app-metrics/prom2json/Manifest3
-rw-r--r--app-metrics/prom2json/prom2json-1.4.1.ebuild40
2 files changed, 43 insertions, 0 deletions
diff --git a/app-metrics/prom2json/Manifest b/app-metrics/prom2json/Manifest
index 3fc440a77e08..80063c7c985c 100644
--- a/app-metrics/prom2json/Manifest
+++ b/app-metrics/prom2json/Manifest
@@ -1,3 +1,6 @@
DIST prom2json-1.3.0.tar.gz 1646893 BLAKE2B 9b8fcfa4a3e45ee08a57016fa6a7611604cbb578f162f0bf7ff8338f345f98788b75c3ac047ffca95b62020e972c302bc1c44f2f7f00240cfd978f73b8d9c829 SHA512 8f02c7b2616d915e2b4ff5f195a8c2eff89d18417f7396dc02d2aa4cf34711358b0beef6effae9b42a3d6f4b0616c5d3ab995a73ab9e37a4a0ec230adff6f249
+DIST prom2json-1.4.1-deps.tar.xz 2788996 BLAKE2B b720c8d4fb0157c63873e2c15ad2adaef057ac6e6f340d25b321f9a380ee35d6d8eac153fc4cd6e75e60f0a75f6f74c17d8caaa51c46cead0e9942a2b9e29660 SHA512 47f33537a83ed0d24f49f3faa1805593ad4f848b1ff79fe19d3a6a3b2dc3a1e1587217ea7a985c6ae4eae4aca2fac2cff8773e3782c0d0e265722341d0296247
+DIST prom2json-1.4.1.tar.gz 21261 BLAKE2B 76d0f4ba6f7433fbb8701945d297df5fd011d2c62ca39c12647c114202e0a74db8d2c08808b179a5b07f08b7ec7742da238dec9b31bead6b1414b1265f495834 SHA512 4ec0aad8df3e1da4768fdf0c81c4f556589c7d84bee05ad5cf00eface323f3d8770ccb1c48b43a1598be4455307c21af3a0e62842c429ac194e34535b02fa8e8
EBUILD prom2json-1.3.0.ebuild 793 BLAKE2B 7b417de377b221c5ffa1fc802e584a6bcf565950531b16828f8bc9c31682c5c2afa51f42d949ffa3c595d3b29f80533ced03f6b41271fb8414d2b921219c81e8 SHA512 5a8e2e89a8eb8000b8ca65428db640e93b10ca55cc01379774f53cd95a8d0a804c1aa3d19413c2218a001ed73413c2438e2b6a6a03e2c1a0003e741e82143f82
+EBUILD prom2json-1.4.1.ebuild 868 BLAKE2B e5ea611be677755f33c4357de9fa84a7e8f64fe4aaad978bd890f2707473232f23d540039a9f3dec2c859a647d91bf2d35a92ac5b72812d63b2562e59ba61ba0 SHA512 dd43d7cc3961a9f7a9e5b2496f88021050071937f829493df69646314ed5ca8e1a245df1df7bdb11e8517bf3aa7621817a1bfd0091e2bb02c583a13b3aa75323
MISC metadata.xml 338 BLAKE2B 323f1010d7bf975b53a7b9e6278425143c59c276af24a6c486a0e0c57524e25efc3d1bffa3652c6f5362b2a81f8a7656a17a81816a731a3073ab6f2d9b34093b SHA512 3ca80debc07302431da65641a6443c3192fb04d3b40fcd3503176fe450d08157b848d1f4c99a40d2d058d8061072116c21694a603c809d28203ad78288d58cca
diff --git a/app-metrics/prom2json/prom2json-1.4.1.ebuild b/app-metrics/prom2json/prom2json-1.4.1.ebuild
new file mode 100644
index 000000000000..34d59e6ec49d
--- /dev/null
+++ b/app-metrics/prom2json/prom2json-1.4.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module edo
+
+GIT_COMMIT=e76e84858a35a1094458b792c631cb75867fd550
+
+DESCRIPTION="A tool to scrape a Prometheus client and dump the result as JSON"
+HOMEPAGE="https://github.com/prometheus/prom2json"
+SRC_URI="https://github.com/prometheus/prom2json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~arthurzam/distfiles/app-metrics/${PN}/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="dev-util/promu"
+
+src_prepare() {
+ default
+ sed -i .promu.yml \
+ -e "s/{{.Revision}}/${GIT_COMMIT}/" \
+ -e "s/{{.Version}}/${PV}/" || die
+}
+
+src_compile() {
+ mkdir bin || die
+ edo promu build --prefix bin
+}
+
+src_test() {
+ emake test-flags= test
+}
+
+src_install() {
+ dobin bin/*
+ dodoc {README,CONTRIBUTING}.md
+}