summaryrefslogtreecommitdiff
path: root/app-metrics/prom2json/prom2json-0.1.0_p20170523.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-metrics/prom2json/prom2json-0.1.0_p20170523.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-metrics/prom2json/prom2json-0.1.0_p20170523.ebuild')
-rw-r--r--app-metrics/prom2json/prom2json-0.1.0_p20170523.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-metrics/prom2json/prom2json-0.1.0_p20170523.ebuild b/app-metrics/prom2json/prom2json-0.1.0_p20170523.ebuild
new file mode 100644
index 000000000000..8bc84e323834
--- /dev/null
+++ b/app-metrics/prom2json/prom2json-0.1.0_p20170523.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/${PN}"
+EGIT_COMMIT="4a7436442837da72f9e211d99f0145dff3246b66"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="A tool to scrape a Prometheus client and dump the result as JSON"
+HOMEPAGE="https://github.com/prometheus/prom2json"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-util/promu"
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${EGIT_COMMIT:0:7}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ mkdir -p bin || die
+ GOPATH="${S}" promu build -v --prefix ${PN} || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin ${PN}/${PN}
+ dodoc {README,CONTRIBUTING}.md
+ popd || die
+}